I opened up your dxf drawing, and the Snap and Grid settings were on.

You should turn those settings off instead of setting the X and Y spacing to zero.

Turning the Snap setting off allowed the...