+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Forum Newbie
    Using
    Inventor 2012
    Join Date
    Oct 2011
    Posts
    6

    Default Arc/circle smoothness setting

    Hi,
    I'm trying to find a way to set the number (or multiplier) of line segments that make up an arc when rendering. If I model a large circle and render it in a high resolution image I can clearly see the line segments and it messes up the clarity of certain models.

    I know that in AutoCAD this setting is in options->Display->Display Resolution ("rendered object smoothness"). Is there an equivalent setting in Inventor?

    I found this post that refers to a much older version:
    http://forums.autodesk.com/t5/Autode...ss/td-p/578420

    It mentions changing a registry setting, which I can't find (presumably it was moved?).

    Any help would be appreciated.

  2. #2
    Luminous Being JD Mather's Avatar
    Using
    Inventor 2015
    Join Date
    Sep 2007
    Location
    Williamsport, PA
    Posts
    8,267

    Default

    How do you render a circle?
    Certified SolidWorks Professional
    Autodesk Inventor 2014 Certified Professional
    Autodesk AutoCAD 2013 Certified Professional
    http://home.pct.edu/~jmather/content..._Tutorials.htm

  3. #3
    Forum Newbie
    Using
    Inventor 2012
    Join Date
    Oct 2011
    Posts
    6

    Default

    JD: Either extrude a circle (or a sketch with an arc in it) or revolve a sketch. I guess I should have said render a cylinder or a 3D object with an arc in it. The simplest way to see this is by placing a circle in a sketch, extruding it only slightly (so that the result is a disc), and then rendering it top-down (viewing the top of the disc).

  4. #4
    Forum Newbie
    Using
    Inventor 2012
    Join Date
    Oct 2011
    Posts
    6

    Default

    Registered forum members do not see this ad.

    Update:
    I found another old post addressing this issue, this time from 2006:
    http://forums.autodesk.com/t5/Autode...1813741/page/3

    The suggestion is again to modify the registry -- " HKEY_CURRENT_USER\Software\Autodesk\Inventor\Regis tryVersion11.0\System\Preferences\Display “Faceting Options” ". The value should be changed from "0x00000042" to "0x00010042". The problem is that in my registry the value for that key is "0x00200042". Also, it seems to reset every time I run inventor.

    Oddly enough, what *does* work (at least in the tests I made) is the "zoom in" hack suggested by Josh_Petitt: Zoom in (a lot) and then zoom back out again, but not all the way. What I did was place a camera from which to render, so that I can zoom in and then just open the render dialog and hit "render". That way it doesn't matter how zoomed-in you are. In the models I tested so far this seems to work. It's a hack, though, and if there's a more "formal" fix it would be useful to know.

Similar Threads

  1. ACAD09: Options-Display Resolution-Arc & Circle Smoothness (always set to 1000)
    By dughug in forum AutoCAD Bugs, Error Messages & Quirks
    Replies: 5
    Last Post: 18th Mar 2010, 03:32 pm
  2. smoothness
    By blowe56789 in forum AutoCAD Beginners' Area
    Replies: 22
    Last Post: 6th Feb 2008, 11:12 am
  3. ..change the Default for Arc and Circle Smoothness?
    By DaKnown in forum AutoCAD General
    Replies: 1
    Last Post: 28th Jun 2006, 12:09 am
  4. Getting smoothness at the joint
    By kanyakumari_t in forum AutoLISP, Visual LISP & DCL
    Replies: 1
    Last Post: 5th Jan 2006, 03:09 pm

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts