+ Reply to Thread
Results 1 to 4 of 4
  1. #1
    Junior Member
    Using
    AutoCAD 2014
    Join Date
    Dec 2011
    Location
    Great Pacific Northwest - USA
    Posts
    19

    Default mtext background masking not working over xrefs

    Registered forum members do not see this ad.

    I have a dwg that I'm using paperspace for text with a viewport of an xref'd 3D model, I have some mtext with background masking, using drawing background color, border offset factor of 1.2, it only masks when I hover over the text. I used Draworder and brought the mtext to the front, nothing I do works, what can the problem be? Fill is on, shademode is 2Dwireframe. I am using Acad 2011.
    Thanks for any help!
    R. L. Hamm
    Last edited by rhgrafix; 14th Jun 2013 at 06:35 pm.

  2. #2
    Super Member CyberAngel's Avatar
    Computer Details
    CyberAngel's Computer Details
    Operating System:
    Windows 10
    Discipline
    Architectural
    CyberAngel's Discipline Details
    Occupation
    Civil Drafter
    Discipline
    Architectural
    Details
    Roofing and Waterproofing
    Using
    AutoCAD 2014
    Join Date
    Jul 2006
    Location
    Anywhere Else
    Posts
    1,120

    Default

    I've had this same problem. From what I've heard, xrefing another drawing reverses the draw order of objects in that drawing. Moving the text to the front in the original drawing actually moves it to the back in the xref.

    One clunky solution is to change the elevation of the text objects so that they're above the rest of the drawing. That will override the draw order.
    breaking AutoCAD on a regular basis since 1991

  3. #3
    Junior Member
    Using
    AutoCAD 2014
    Join Date
    Dec 2011
    Location
    Great Pacific Northwest - USA
    Posts
    19

    Default Thanks

    I will try that, I sure wish Autocad would spend more time fixing bugs than they do adding more bells and whistles.
    Ramon

  4. #4
    Full Member adrath's Avatar
    Computer Details
    adrath's Computer Details
    Operating System:
    Windows 7 64 bit
    Computer:
    Dell Precision t3500
    Discipline
    Civil
    adrath's Discipline Details
    Occupation
    CADD Designer
    Discipline
    Civil
    Details
    Most of what I do is commercial and residential land development, with a little bit of transportation and public works thrown in for good measure. I am also a self-proclaimed wizard of blocks, alchemist of assemblies and sorcerer of styles.
    Using
    Civil 3D 2014
    Join Date
    Jun 2013
    Location
    Texas
    Posts
    50

    Default

    Registered forum members do not see this ad.

    You say that the your text is in paperspace? If so, check your plot settings and make sure that the "Plot Paperspace Last" option is selected.

Similar Threads

  1. Background Masking wont delete
    By clarkey1987 in forum AutoCAD 2D Drafting, Object Properties & Interface
    Replies: 8
    Last Post: 17th Oct 2012, 08:52 pm
  2. Working With Consultants Drawings for Xrefs
    By insight design in forum AutoCAD General
    Replies: 10
    Last Post: 8th Aug 2011, 04:39 pm
  3. Mtext background mask lisp needed
    By bijoyvm in forum AutoLISP, Visual LISP & DCL
    Replies: 3
    Last Post: 17th Oct 2010, 11:37 am
  4. Text to Mtext lisp- add background mask?
    By mawelby in forum AutoLISP, Visual LISP & DCL
    Replies: 9
    Last Post: 1st Jul 2010, 05:58 am
  5. MTEXT Background Mask Not Displaying
    By Prospectmp in forum AutoCAD Drawing Management & Output
    Replies: 5
    Last Post: 30th Jan 2008, 12:57 am

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts