+ Reply to Thread
Results 1 to 5 of 5
  1. #1
    Forum Newbie
    Using
    AutoCAD 2016
    Join Date
    Nov 2015
    Posts
    2

    Exclamation Lisp error: bad argument type: stringp nil

    Registered forum members do not see this ad.

    When i run a lisp om my computer it gives me an error. the first problem was a missing font ic-romand (i renamed another font to continue). I included the files as attatchment. The path to files should be:C:\Program Files (x86)\ProgeCAD\progeCAD 2014 Professional ENG\Program. With appload i load the file \misc\DK_Load.
    When i run dk (found in dk_main.lisp) it trows me an error : argument type: stringp nil. It should open a dialog box to enter data

    Can anyone please help me i have to get this running before monday. Some help would be really apreciated!!!!! PROBLEM SOLVED
    Last edited by archiprodesign; 17th Nov 2015 at 08:46 pm.

  2. #2
    Super Member rlx's Avatar
    Computer Details
    rlx's Computer Details
    Operating System:
    W10
    Computer:
    i74ghz/ssd500/2tbhdd
    Discipline
    Electrical
    rlx's Discipline Details
    Occupation
    electrical designer dragon
    Discipline
    Electrical
    Details
    I dont excel in anything but I rearly give up
    Using
    AutoCAD 2012
    Join Date
    Nov 2014
    Location
    Bergen op Zoom , Netherlands
    Posts
    599

    Default

    is this something you 'borrowed' ?

    I can (have) fixed it but normaly I would expect to see the name of the author and I see zip , ziltsch , nada , noppes... so I don't want to be your partner in crime , snappez vous?

    gr.Rlx
    Last edited by rlx; 14th Nov 2015 at 10:19 pm.

  3. #3
    Forum Newbie
    Using
    AutoCAD 2016
    Join Date
    Nov 2015
    Posts
    2

    Default

    Hallo Rlx, Je had gewoon kunnen vertellen dat ik een ini bestand gemist had om de rest te laden en dat je voor de rest niks "gefikst hebt" , maar bedankt voor je collegialiteit. Mij is verzocht om dit werkend ik de cloud te krijgen en angezien ik niet zoveel verstand van lisp zelf heb had ik gehoopt hier hulp te vinden maar nogmaals bedankt.

    Mvg
    Last edited by archiprodesign; 17th Nov 2015 at 08:51 pm.

  4. #4
    Super Member rlx's Avatar
    Computer Details
    rlx's Computer Details
    Operating System:
    W10
    Computer:
    i74ghz/ssd500/2tbhdd
    Discipline
    Electrical
    rlx's Discipline Details
    Occupation
    electrical designer dragon
    Discipline
    Electrical
    Details
    I dont excel in anything but I rearly give up
    Using
    AutoCAD 2012
    Join Date
    Nov 2014
    Location
    Bergen op Zoom , Netherlands
    Posts
    599

    Default

    Hoi archiprodesign,

    Ze zijn hier (terecht) nog al heel erg gesteld op ere wie ere toekomt weetjewel... Dat het programma bepaalde default waarden mistte was idd snel duidelijk dus heb ik een aantal lisp routines aangepast om daar tegen bestand te zijn en ook zat er een probleem in de units module met een of andere dim-setting dus die had ik ook aangepast. Maar om deze dan zo op dit forum te zetten kan gevolgen hebben en daarom hebben ze hier ook een optie uitgevonden om iemand een prive bericht te sturen en dan had ik je via de prive mail verder kunnen helpen.

    gr. Rlx

  5. #5
    Super Member rlx's Avatar
    Computer Details
    rlx's Computer Details
    Operating System:
    W10
    Computer:
    i74ghz/ssd500/2tbhdd
    Discipline
    Electrical
    rlx's Discipline Details
    Occupation
    electrical designer dragon
    Discipline
    Electrical
    Details
    I dont excel in anything but I rearly give up
    Using
    AutoCAD 2012
    Join Date
    Nov 2014
    Location
    Bergen op Zoom , Netherlands
    Posts
    599

    Default create

    Registered forum members do not see this ad.

    program.zip

    (ik doe het toch ook effe in het engels hoor)

    I made the following changes :

    In DK_Dim : dimscale could be zero , added default 1

    In severall routines I used findfile to obtain dcl path

    in DK_start created (empty) defaults (setcfg "AppData/Dakkapel/Sales/VerkoperProject" "")

    (You could first test if they are empty)

    Via options I added all paths under programm to the support path

    Gr. Rlx

Similar Threads

  1. ; error: bad argument type: (or stringp symbolp): nil
    By PuzzzleClub in forum AutoLISP, Visual LISP & DCL
    Replies: 3
    Last Post: 28th Mar 2014, 12:28 am
  2. error: bad argument type: stringp
    By samifox in forum AutoLISP, Visual LISP & DCL
    Replies: 5
    Last Post: 13th Aug 2013, 07:01 am
  3. What is wrong with this code? (; error: bad argument type: stringp)
    By Perifanos in forum AutoLISP, Visual LISP & DCL
    Replies: 7
    Last Post: 3rd Mar 2013, 10:42 pm
  4. error: bad argument type: stringp nil
    By woodman78 in forum AutoLISP, Visual LISP & DCL
    Replies: 11
    Last Post: 6th Dec 2010, 11:53 am
  5. Error: bad argument type: stringp nil
    By Electroman7979 in forum Electrical
    Replies: 1
    Last Post: 4th Jul 2009, 10:31 pm

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts