+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Full Member squareknees's Avatar
    Using
    AutoCAD 2015
    Join Date
    Nov 2014
    Posts
    72

    Default error in hatch pattern "Missing parameter on line 21619"

    Registered forum members do not see this ad.

    I hope I am posting this on the correct forum.
    I am having an issue with a custom hatch pattern. not one that I made. I found it on a website where you can share custom lisp routines and hatch patterns. I do not know how to create a hatch pattern. I am having an error with a certain line in the pattern and I can't figure out what the issue is. I do know some basics about how the code works for hatch patterns but that is it.
    I know the numbers work something like this, angle, x-origin, y-origin, delta-x, delta-y , and if there are spaces in the line, you can do a positive number is a line, negative number is a space and a 0 is a dot.
    what I don't know is how the line is effected by the line previous and after the offending line.
    I have done everything I can think of to correct the issue and nothing has worked.


    line 21618: 0, 34.9243125, 45.6868125, 0, 53.8125, 13.99125,-39.82125
    line 21619: 90, 30.6193125, 0, 0, 53.8125, 4.843125,-48.969375
    line 21620: 90, 30.6193125, 51.0680625, 0, 53.8125, 2.690625,-51.121875


    I copied the text for the original hatch pattern into my acad.pat so I wouldn't have to deal with a lot of extra information. I just want the hatch pattern to work and I want to know how to fix it. this is not the only pattern that is having issues but this is the current one that is ticking me off.


    Just to let you know I did go to the end of line 21619 and hit enter, that didn't fix it, I removed the spaces between the delta x and y, and origin x and y. and nothing helped. these are all solutions that I found when googling this error.


    I just know that it is really obvious to someone what is wrong with this hatch pattern code and that when I figure it out I am going to say that was so obvious yet I didn't see it.


    Thanks for any help,

  2. #2
    Senior Member
    Using
    not applicable
    Join Date
    Nov 2006
    Location
    Melbourne Australia
    Posts
    245

    Default

    Registered forum members do not see this ad.

    Any pattern containing over 20,000 lines will be a heavy burden to the drawing.


    Post a link to the source and you may receive alternative suggestions.


    Hugh Adamson
    www.hatchkit.com.au

Similar Threads

  1. "Open" missing on autocomplete menu at CMD line?
    By Croweyes1121 in forum AutoCAD Bugs, Error Messages & Quirks
    Replies: 3
    Last Post: 13th Aug 2015, 02:50 pm
  2. Missing "Flat Pattern Panel" Inventor 2014
    By ConMan in forum Autodesk Inventor
    Replies: 4
    Last Post: 24th Feb 2014, 03:37 am
  3. Help with flip - BE error "Circular Reference in action / parameter selection set"
    By rajeev_acpl in forum AutoCAD Drawing Management & Output
    Replies: 4
    Last Post: 29th Oct 2013, 11:52 am
  4. LISP to get past the "Dense Hatch Pattern" Dialog Box
    By rayg11757 in forum AutoLISP, Visual LISP & DCL
    Replies: 9
    Last Post: 18th Jan 2013, 05:58 pm
  5. Hatch pattern error, making a "Hatch Code" .pat
    By SDSinc in forum AutoCAD General
    Replies: 4
    Last Post: 18th Jan 2011, 03:25 pm

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts