+ Reply to Thread
Results 1 to 7 of 7
  1. #1
    Junior Member
    Using
    not applicable
    Join Date
    Dec 2016
    Posts
    10

    Default Problem with video card on Solidworks 2017

    Registered forum members do not see this ad.

    Have this strange problem with video card in Solidworks 2017 on Windows 10. As you can see it on video that I made it, it's like the video card is lagging. It's not certified video card for Solidworks, it's NVIDIA GeForce GTX 750. Before Solidworks 2017 had I Windows 7 and Solidworks 2015, with no problems.
    This happens when I work in Solidworks 2017 couple of minutes. When I start working, everything is normal and then is beginning that to hapen. That happens if RealView is turned on or off.
    If I enable software OpenGL is everything working more slowly, but normal.
    I have tried everything for video card that this wouldn't happen, but nothing helps.
    Is there something that would help with this problem, or just simple must be certified video card for Solidworks? Or it's maybe related to Windows 10?


    video:
    https://www.youtube.com/watch?v=GVeSD32EIfc

  2. #2
    Forum Deity shift1313's Avatar
    Using
    not applicable
    Join Date
    Sep 2008
    Location
    VA
    Posts
    3,249

    Default

    There might be 2 issues. 1 is the card. That is a card that is for video games, but also i don't think there is a GeForce driver that supports windows 10. I could be wrong there but check the Nvidia.com site for drivers to see whats available. That may be part of the issue.

    2., With it being a PC Game card that is a problem for sure.

    The best thing you can do without upgrading is to turn of shading, shadows/reflection, realview etc and go into the options for image quality and make sure the edges are low poly(there is a slider in there and its on the 2nd tab).

    Gaming cards deal with low polygon models and predefined shading in a lot of cases. CAD cards are designed to deal with millions of polys and need to be accurate, unlike game graphics. If the car on your game is not perfect scale it doesn't matter.

    If you are looking to upgrade on the cheap but want really good performance I have been really happy with the Nvidia Quadro k2200. This is a really good compromise between spending a few thousand dollars and spending a hundred dollars. They typically go for $300-$500 if you shop around. I have run low end cards up to a quadro5000 that came in my machine. I wouldn't suggest the $6000 investment in the k5000 card for very many people(or the k6000), but spending $400 on a K2200 will be worth it.

    Some other things to check out on the Win10 settings, any visualization themes that mess with the graphics. I can't remember off the top of my head what the settings are in 10(i still run 7) but they used to be Aero themes. Some visualization type things can clamp down GPU performance so play around with that.
    Matt - Certified Solidworks Expert -Advanced Surfacing, Mold Tool and Sheet Metal Specialist
    Current Software: SolidWorks17,Mastercam2017, fusion360, Inventor 2017, HSMworksUltimate
    http://www.solidbox.tv Free and Paid Tutorials for Solidworks, Mastercam and Fusion360
    http://www.mysolidbox.com/ CAD and CAM optimized workstations and laptops

  3. #3
    Junior Member
    Using
    not applicable
    Join Date
    Dec 2016
    Posts
    10

    Default

    Can change everything and is always the same. At the beggining is working just fine, and when you think that maybe now will be OK just start doing those things.
    It will only work normal with enabled software OpenGL.

    Right now have I not in plan to upgrade, when comes to that, I will take Quadro k2200 as you mentioned.
    Thank you for yor advice.

  4. #4
    Junior Member
    Using
    not applicable
    Join Date
    Dec 2016
    Posts
    10

    Default

    And what do you think about k2000?
    Maybe will take that, used card and just for trying.

  5. #5
    Forum Deity shift1313's Avatar
    Using
    not applicable
    Join Date
    Sep 2008
    Location
    VA
    Posts
    3,249

    Default

    yeah OpenGL gets around the graphics card. Its typically used for troubleshooting.

    One thing you can try is to run Solidworks RX from the Solidworks Tools folder on your start menu. This will run through and let you know of any performance issues associated with your system.

    In terms of the K2000 vs K2200. The 2200 is faster, better rendering, texture etc. You are typically talking about a difference of $100USD between them. K2000 is usually around $250. The big differences.

    Memory, 2g vs 4g. Keep in mind this "memory" actually eats up a portion of your systems Ram which is needs to use. So if you have a K2200 with 4GB video memory you give up 4GB of your system. I suggest running at least 16GB of system RAM to most people doing anything remotely past basic modeling. There are slight differences in cuda cores, speeds etc. Depending on how complex or big your parts/assemblies are you may never notice the difference. But personally paying $250 vs $350 i think its worth it. If you only had $350 to spend i would probably suggest then getting the 2000 and upping your RAM if you have under 12GB. Ram can make a noticeable difference if it is slow or too few.
    Matt - Certified Solidworks Expert -Advanced Surfacing, Mold Tool and Sheet Metal Specialist
    Current Software: SolidWorks17,Mastercam2017, fusion360, Inventor 2017, HSMworksUltimate
    http://www.solidbox.tv Free and Paid Tutorials for Solidworks, Mastercam and Fusion360
    http://www.mysolidbox.com/ CAD and CAM optimized workstations and laptops

  6. #6
    Junior Member
    Using
    not applicable
    Join Date
    Dec 2016
    Posts
    10

    Default

    Have already tried Rx if show me some errors and nothing is wrong, also have tried with integrated graphics Intel HD 4600 and it's the same.

  7. #7
    Junior Member
    Using
    not applicable
    Join Date
    Dec 2016
    Posts
    10

    Default

    Registered forum members do not see this ad.

    It seems the problem is when you have maximized window is happening that and when is window unmaximized is everything normal.

    Here you can see behavior when is window unmaximized and then maximized:
    https://www.youtube.com/watch?v=32g6YoccIuY

Similar Threads

  1. video card
    By idllc in forum MEP
    Replies: 10
    Last Post: 18th May 2011, 04:17 am
  2. Video Card Help
    By afielder45 in forum Hardware & Operating Systems
    Replies: 20
    Last Post: 10th Apr 2009, 03:53 pm
  3. Video Card Help
    By afielder45 in forum Hardware & Operating Systems
    Replies: 0
    Last Post: 10th Apr 2009, 02:05 pm
  4. Video Card...
    By MostlyLqd in forum AutoCAD Drawing Management & Output
    Replies: 2
    Last Post: 19th May 2006, 08:53 pm

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts