Jump to content

Search the Community

Showing results for tags 'hatch'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CADTutor
    • News, Announcements & FAQ
    • Feedback
  • AutoCAD
    • AutoCAD Beginners' Area
    • AutoCAD 2D Drafting, Object Properties & Interface
    • AutoCAD Drawing Management & Output
    • AutoCAD 3D Modelling & Rendering
    • AutoCAD Vertical Products
    • AutoCAD LT
    • CAD Management
    • AutoCAD Bugs, Error Messages & Quirks
    • AutoCAD General
    • AutoCAD Blogs
  • AutoCAD Customization
    • The CUI, Hatches, Linetypes, Scripts & Macros
    • AutoLISP, Visual LISP & DCL
    • .NET, ObjectARX & VBA
    • Application Beta Testing
    • Application Archive
  • Other Autodesk Products
    • Autodesk 3ds Max
    • Autodesk Revit
    • Autodesk Inventor
    • Autodesk Software General
  • Other CAD Products
    • BricsCAD
    • SketchUp
    • Rhino
    • SolidWorks
    • MicroStation
    • Design Software
    • Catch All
  • Resources
    • Tutorials & Tips'n'Tricks
    • AutoCAD Museum
    • Blocks, Images, Models & Materials
    • Useful Links
  • Community
    • Introduce Yourself
    • Showcase
    • Work In Progress
    • Jobs & Training
    • Chat
    • Competitions

Categories

  • Programs and Scripts
  • 2D AutoCAD Blocks
  • 3D AutoCAD Blocks
  • Images
    • Backgrounds

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 78 results

  1. i have multi hatch in drawing how to get hatch area? i have all hatches are not separate layer all hatches r have same layer so i need to find out area separately please help me any one
  2. If I get a file with a hatch I'd like to save as my own, is there a quick way to do this (besides for contacting the sender and asking for their PAT or obsessively searching online?) I can see in Properties that the hatch is called 020 and it's under Custom, but when I try to Match Props to get it to replicate it just turns out solid. Any ideas?I'm attaching the file, the hatch I want is for the mirror. Thanks! mirror hatch question.dwg
  3. nicolas

    Hatch Creation

    Hi, I need to create a rectangular tile hatch that is 200 (w) x 300 (h). So far using USER, I have been able to do square tiles (100x100 and 300x300). Is there any simple way to create a hatch pattern file for such rectangular tiles? Thanks.
  4. Hi all - I don't know what happened, but I was CADDing along and now when I double click a hatch, it invokes what I think is the Quick Properties, not the Hatch Edit command. I can still type the Alias "he" and get to it, but I'm used to double clicking and don't see what change. I looked in the CUI, and under Double Click Actions>Hatch, the Hatch Edit command is listed. What gives? THANKS to the community at large, as always.
  5. Hi all, I've made a simple dynamic block, a rectangle with a hatch and added a linear stretch to it. The stretch works fine on the rectangle itself, but the hatch only gets moved. Any ideas why this might be? I've attached an image and a drawing containing the block. Thanks in advance. BlockHatch.dwg
  6. Assemblies are built with cross hatching, or shading, built in - can I style (edit) the cross hatch? I'd like to be able to hide/show the hatching, or at the very least change the color to what will print as a half tone. Any tips? I've looked everywhere, but had no luck.
  7. Hi all, I need help on selecting a nested object which is attributed text from the block to be able to remove hatch over it. Below is the code that I'm using currently (not mine originaly, I tweaked it a bit for my application). This code just works for the whole block but doesnt allow me to select just the text. (defun Fixhatch (/ Hatchfix objct) (while (setq Hatchfix (entsel "\nSelect Hatch to fix (or Enter to close):")) (redraw (car Hatchfix) 3) (Alert "\n***Select object(s) to clear/skip hatch:***") (setq objct (ssget)) (if (eq (cdr (assoc 0 (entget (setq Hatchfix (car Hatchfix))))) "HATCH") (command "_.-hatchedit" Hatchfix "Ad" "s" objct "" "") (princ "\nSelected entity is not a hatch.") );end if );end while );end defun As you can see the text TB6 is an attribute text of the rectangle block and I want to remove hatch just from the text. Can this be done? Thanks in advance.
  8. Hello everyone, I've always layout my floor plans three dimensionally with the tools pallets commands such as walls, rails, door, windows & ect. I always have my walls pre-hatched with the solid pattern which is really effective to the floor plan. Normally when I put windows in the wall the window is clearly shown without the hatch in the wall but for some reason my wall's hatch started covering the windows and I can't seem to solve this problem.
  9. Hi to all, So, this is my lisp. It does the following: 1) Adds revision clouds to multiple entities 2) Adds Layer (or create if required and add properties) 3) Adds hatch 4) Inserts a block for leader and text (already formated) I have very limited knowledge of the lisp. As you can see I have copied few different codes and combined it to make it work for my application. It works but I know this is not systematic at all. I dont know if my error handeling is correct. One thing that I wish to add is if the revision cloud is too big or too small, it should allow to do that without closing and undoing everything. In other sense, I need undo and reset arc length option in this. Can someone help me on this please? (defun c:RVC6 (/ *error* oce mflag ans) ;************************************Error handling********************************************* (defun *error* (msg) (setvar "cmdecho" OCE) (setq *error* nil) (princ "\nRevision cloud program is done.") (princ) ) ;************************************Program begins********************************************* (setq OCE (getvar "cmdecho") OOS (getvar "osmode") ) (setvar "cmdecho" 0) (setq mflag nil) (while (not mflag) (prompt "\n*** Enter option C, H, L, or E ***") (initget 0 "Cloud Hatch Leader Exit") (setq Ans (getkword "\nconvert to revision Cloud/Hatch/Leader/<Exit>: ")) (if (= Ans nil) (setq Ans "Exit") ) ;end if (cond ( (= Ans "Cloud") (convcloud) ) ( (= Ans "Hatch") (Addhatch) ) ( (= Ans "Leader") (Addleader) ) ( (= Ans "Exit") (setvar "cmdecho" OCE) (setvar "osmode" OOS) (quit) ) ) ;end cond );end while );end defun ;************************************Program ends********************************************** ;*******************************Start of "convcloud" program*********************************** (defun convcloud (/ al ss) (initget (+ 2 4)) (setq al (getreal "Specify Arc length <0.5>:")) (if (= al nil) ;If user do not input a value here (setq al 0.5) ;Consider "Enter" as 0.5 ) ; end if (if (setq ss (ssget '((0 . "LINE,*POLYLINE,CIRCLE,ELLIPSE,SPLINE,ARC")))) (progn (repeat (setq i (sslength ss)) (command "_.revcloud" "a" al al "" (ssname ss (setq i (1- i))) "") (if (not (tblsearch "LAYER" "CONSTRUCTION")) (command "-layer" "N" "CONSTRUCTION" "C" "1" "CONSTRUCTION" "LT" "continuous" "CONSTRUCTION" "") ) ; end if (command ".-layer" "S" "CONSTRUCTION" "C" "red" "" "") (Command "Chprop" "l" "" "la" "CONSTRUCTION" "C" "BYLAYER" "Lt" "BYLAYER" "LW" "BYLAYER" "") );end repeat (princ "\nRevision cloud(s) created on CONSTRUCTION layer.") );end progn (princ "\nNo objects selected.") ) );end defun ;*******************************End of "convcloud" program************************************* ;*****************************Start of "Addhatch" Program ************************************* (defun Addhatch (/ htype selset thisobj setlen entname) (initget 1 "D R") (setq htype (getkword "\nSpecify hatch type? Demo(D)/Rebuild(R):")) (if (= htype "D") (setq htype "ANSI31") ) ;end if (if (= htype "R") (setq htype "DOTS") ) ;end if (princ "\nSelect object(s) to hatch:") (setq selset (ssget)) (if selset (progn (setq thisobj 0) (setq setlen (sslength selset)) (while (< thisobj setlen ) (setq entname(ssname selset thisobj)) (Command "-bhatch" "Advanced" "Style" "Outer" "" "") (command "-bhatch" "p" htype "3" "" "s" entname "" "") (if (not (tblsearch "LAYER" "CONSTRUCTION")) (command "-layer" "N" "CONSTRUCTION" "C" "1" "CONSTRUCTION" "LT" "continuous" "CONSTRUCTION" "") ) ; end if (command ".-layer" "S" "CONSTRUCTION" "C" "red" "" "") (Command "Chprop" "l" "" "la" "CONSTRUCTION" "C" "BYLAYER" "Lt" "BYLAYER" "LW" "BYLAYER" "") (setq thisobj(+ thisobj 1)) ) ; end while (alert "\n ***WARNING*** Hatching could not skip the inner objects. To solve this, Double click hatch and `Add: select objects' and select inner object & click OK") ) ; end progn ) ;end if selset (princ "\nNo objects selected.") );end defun ;*******************************End of "Addhatch" program************************************* ;*****************************Start of "Addleader" Program *********************************** (defun Addleader (/ pt1) (while (setq pt1 (getpoint "\nInserting task description note, Specify Arrow End Point or hit Enter to close:")) (Command "_INSERT" "CP TEXT" pt1 "" "" "") (command "explode" "l") );end while );end defun
  10. Hi, I need help on 1. clipping 3D Drawing views and 2. chaging the hatch pattern/scale in the sectional Drawing views that the generated automatically when hatch option is on. A last question is whether Sectional Drawing view is better than a section generated with section plane. Thanks.
  11. Hi, I am unable to fill objects with any sort of hatch in my current drawing. Other drawings are fine, but in this one, nothing will hatch, either form the tool palettes option or from the hatch menu. Any ideas what I have done out there? Thanks, Alec.
  12. Hi all, I'm wondering if you guys have some suggestions, I'm looking for the best way to create some sort of background mask in my blocks. I'm using blocks as my mechanical symbols, to be inserted into my piping and instrumentation diagrams. The diagrams contain several lines, and in the past the company would simply trim out the lines around the symbols. I would like to stop trimming the lines by simply putting an invisible hatch/mask around my blocks. Any sweet suggestions?? Thanks!
  13. Hi! I would appriciate if someone would help me soloving this problem. As the first picture presents: 1.Only some of the quadrangle are being crossed with two red lines 2.Numbers, quadrangles and red lines are in separate layers I need to do the following thing: 1.Make sure that all quadrangles are closed and that each quadrangle has one number inside of that closed area. 2.Get a list of quadrangles that are being crossed over with two red lines (the space between two red lines is the one that counts) (for this example I must get: 500, 501, 505, 506, 507, 508) 3.Find out the area of each given quadrangle in step 2. (for example 500 – 1360.32, 501 – 4056.42, 505 – 5050.03 etc.) and hatch each one of them (it would be nice if I could automatically find out the number of hatched quadrangles – for this example: 6). So the final result should be: in CAD as in picture 2 with number of hatched objects: 6 and in a file that is excel/notepad readable as in picture 3. http://imageshack.us/f/850/blaog.png/
  14. Hi Guys, Trying to remove multiple hatch grips. My problem is as simple as that! Since 2011 brought in the pop-up option, single grips can be removed with this method. But when I want to delete a larger number of grips at once, I can't achieve the required result. Process is as follows: 1. Select Hatch itself 2. Holding SHIFT, select multiple grips (which turn from blue to red) 3. Then 1 left click on a grip, and scrolling through the options using CTRL key until I arrive at 'REMOVE'. Then another left click and nothing happens! Any assistance would help with avoidance of head being done in! Cheers, Clarky.
  15. I am working on a drawing (not originally created by me) and cannot create any hatches at all. If I make a closed shape, select Hatch, and select an interior point, nothing at all happens. No hatch is created, no error messages are generated. The command simply appears to finish as normal but doesn't actually create anything. Any suggestions?
  16. I have always used *.ctb files, and have always plotted by color. It just makes infinite sense to me. However, a recent client of mine used *.stb files, so I had to use them for the first time. I was pretty impressed with them, I'm surprised to say. You don't plot by color, unless I'm missing something, but for the most part you don't have to. The only instance where I still wanted the plot-by-color option was in having a background solid hatch pattern. I ended up going two layers for that hatch area, one with the pattern, the other with a background solid that I could independently control.
  17. I am pretty new to lisps, but I think that I have made this a little more complex than it needs to be. I am trying to create a offset box around a set polyline and then hatch the box. I have succeeded in making it work for four user designated points, but I am looking for more. I would like to be able to run the lisp, draw a polyline with infinite bends and angles, and then have it hatch the resulting offset box. If anyone has any optimization ideas I would love to hear them trench.lsp
  18. Apparently I have overloaded AutoCAD's little mind. I needed a way to cover the background of a bubble note, which is a multileader with the standard circle for content. First I tried Wipeout, but it kept turning out dark in PDFs. Then I tried a solid hatch with override color 255. Obviously I want the note itself to display, so I set Draw Order for the hatch to Behind Boundary. In model space the note displays correctly, but in layouts the hatch moves to the front and takes on the color of the multileader's layer, whether the multileader is in model space or paper space. The notes plot correctly, so these misbehaving hatches are more of a nuisance than a problem. Is there a simple way to fix this? Some system variable that reverses draw order in paper space or controls the appearance of hatches?
  19. Hi, I'm new and self taught on cad (so sorry if i appear dumb) I've used cad now in a basic 2d architectural sense now for 10 years, through various versions. I have recently dropped back to a 2007 from 2008 (changed jobs) and for some reason the draw order is all messed up i noticed this first through hatching but its on everything including inserted images. I've tried a few of the solutions on other threads even uninstalling cad and re-installing it and nothing seems to be sorting it. Functions like 'send to back' etc just don't work and the draw orders are all to pot. Any ideas ?
  20. Hi all I was wondering if anyone knows of a lisp code to hatch squares, i have a textfile with xyz coordinates and a color code, the coordinates are in the center of all the squares. what i would like is to hatch the squares with a specific color, defined in the text file. Can anyone help to make this. (theres a lot of squares that needs to colored) thanks in advance.
  21. Hi again, I have a serious problem when hatching in AutoCAD LT 2011, it's making my PC hang but only when I'm using the 'Add: Pick points' command. It's so bad that I can't even call up the task manager to stop the process and I have to switch it off and on again to get it working. I've never encountered this before with earlier versions of AutoCAD, is there a way around this? It's driving me nuts! I'm using AutoCAD LT 2011 on Windows Vista. **EDIT** Since opening my most recent backup file I think I may have found the cause. I had inserted a .jpg image (150 x 150 @ 8KB) that I was using to trace around it and it was these tracings that I tried to hatch. I have since deleted the image and now the hatching causes no problems.
  22. Dear Fellow DeepCADers, Our office recently upgraded to AutoCAD Civil 3D 2012 from AutoCAD Civil 3D 2010, and I'm experiencing one very annoying issue. When opening drawing files that were made in 2010, we frequently find these 4x20 solid hatches in either magenta or cyan. Sure, we could easily just click and delete them... But what is causing these random hatches to be created? At first I thought maybe Civil 3D was misreading our legends and creating a hatch from them (we usually have hatches in our legends), but in the attached photo you'll see a part of a drawing that had no legend, viewports, or hatches previously still fell to this annoyance. You'll notice the little guy behind the text box... Is there a way we can prevent this from happening in the future? Is there anyone out there who is experiencing the same issue? I've searched forums for an answer, but, as of yet, it seems that my coworkers and I are the only ones who are having this problem. Thanks for your time! Thomas
  23. k3rnal

    Hatch grrips

    Hi, Hi, I recently upgraded from Autocad 2011 to Autocad 2012. When editing hatch in 2011 I used to be able to single click the hatch pattern, and then use one of the many grips to edit it, but now, when single clicking the hatch pattern in Autocad 2012, only one grip appears in the centre, in the form of a blue dot? How do I set my Autocad 2013 to behave as it did in Autocad 2011? Thanks in advance
  24. Probably this question has been asked before. I have a hatch pattern in one of my objects. I want to apply exactly the same hatch pattern to other objects but I don't remember the settings for original hatch. There is a command in ACAD to apply properties of one object to others (brush icon in toolbar). I tries to use this command but it seams that it doesn't work for hatch. Am I correct? What is easiest way to apply a hatch pattern from an object to the other one?
  25. Hi, I've been workin on Autocad since last year and I was using hatch patterns just perfectly, then I tried to download and install new hatch patterns, as I needed more variety. I don't know what happened, but I can't use anything now. If I try to fill in with a Hatch Autocad will tell me that it can't find a file, there arre no standard patterns available, and there is error in reading the pattern file. What should I do? I very lost. Any help would be great
×
×
  • Create New...