Jump to content

Search the Community

Showing results for tags 'mtext'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • CADTutor
    • News, Announcements & FAQ
    • Feedback
  • AutoCAD
    • AutoCAD Beginners' Area
    • AutoCAD 2D Drafting, Object Properties & Interface
    • AutoCAD Drawing Management & Output
    • AutoCAD 3D Modelling & Rendering
    • AutoCAD Vertical Products
    • AutoCAD LT
    • CAD Management
    • AutoCAD Bugs, Error Messages & Quirks
    • AutoCAD General
    • AutoCAD Blogs
  • AutoCAD Customization
    • The CUI, Hatches, Linetypes, Scripts & Macros
    • AutoLISP, Visual LISP & DCL
    • .NET, ObjectARX & VBA
    • Application Beta Testing
    • Application Archive
  • Other Autodesk Products
    • Autodesk 3ds Max
    • Autodesk Revit
    • Autodesk Inventor
    • Autodesk Software General
  • Other CAD Products
    • BricsCAD
    • SketchUp
    • Rhino
    • SolidWorks
    • MicroStation
    • Design Software
    • Catch All
  • Resources
    • Tutorials & Tips'n'Tricks
    • AutoCAD Museum
    • Blocks, Images, Models & Materials
    • Useful Links
  • Community
    • Introduce Yourself
    • Showcase
    • Work In Progress
    • Jobs & Training
    • Chat
    • Competitions

Categories

  • Programs and Scripts
  • 2D AutoCAD Blocks
  • 3D AutoCAD Blocks
  • Images
    • Backgrounds

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

  1. I need some help. I have a drawing that has 2000+ utility poles in it. All of the poles are labed numerically using mtext. Is there a way to select just the odd values and delete them?
  2. Cad Monkey 2

    Varying text size in MTEXT

    I am encountering a problem with MTEXT In layout space I use 3/32" text height (matching my text style) for mtext, but sometimes when I try to change the top line to 1/8" height it becomes HUGE - just the line that I'm trying to change. It happens with certain blocks of mtext, but not with others. Anybody know what might be going on?
  3. Hello everybody, This is my first post on CADTutor. I've been reading alot here even before I became a member, but it is time for me to join the community with a question since I cannot find the exact answer to mine. Question: Is it possible to sum numbers in Mtext fields created with lisps? AT.LSP OT.LSP I edited them to suit my needs with prefix and suffix and decimal precision (they are in the core the same, originally made by JTB), one is displaying area of selected polyline (AT.lsp) and the other perimeter/length (OT.lsp). I would like to preserve possibility of field updating so when polyline/area is changed I just enter regenall. I copied Mtext fields maually to "oldstyletable" made from lines and mtext, mtext fields. See attached dwg for example. I've seen this thread: http://www.cadtutor.net/forum/showthread.php?43699-Sum-Text-Strings-to-Text-Field... I tried all the lisps but none are applicable to my problem. I get only #### even after regen (I think it's maybe because of prefix and suffix, but don't know). I've managed to work only with text and then my updating Mtext fields are, for sure, gone. Please advise. TEST1.dwg
  4. As posted over at theSwamp, I thought I'd post it here for you guys also CopyText.lsp The program will allow a user to copy the text content from a source object to a selection of destination objects or swap the text content between two objects. The user may select from Text, MText, Attribute, or Multileader objects. Upon choosing 'Settings' the user can alter whether source object formatting should be retained upon copying/swapping to/with objects which permit the use of such formatting. Ideas/criticism/feedback are, as always, welcome Enjoy! Lee CopySwapTextV1-6.lsp
  5. Hello there :-) I am wondering whether anyone may be able to provide a relative newbie with some assistance. I have been trawling the pages here and elsewhere to try and find an answer that I can comprehend or use, but had no luck so far :-( What I am trying to achieve, is to import an excel spreadsheet to AutoCad 2010, and use cells from this table to automatically populate text fields. What I am trying to generate are some 19" patch bay labels (that can only be printed on A3 at an angle, hence the use of cad). We have to create these types of labels a lot, and Excel is a far more friendly place to be able to do this (plus the data already exists from wiring schedules). I have not tried any form of automation like this before, so am not really sure where to start. The searches I have made are probably failing, as I don't know what to call the thing I am looking for. I have managed to copy and "paste special" as an object the table that I wish to use - however I cannot seem to find a way to replicate the data from the table to the areas on the drawing where the text needs to appear. I did try the insert field/formula/cell - but I of course only get #### as the fields are text rather than numerical (well a mix of both). Does anyone know if there is a solution to being able to complete this task please? It takes a long time to go through and manually change all of the separate mtext blocks as there are 2 off rows of 48 per patch bay, and each pair of patches uses 3 separate text inputs. Todays job has a total of 13 patch bays, so any form of automation from the existing excel sheets would make me a very happy man... Any assistance very much appreciated, Kind Regards, Lee Rich
  6. I am using AutoCAD 2010 (D.309.0.0) - English Version 3 I have a page setup using Adobe PDF as the plotter. I am using Acrobat 7.1.4 Standard. When using Batch Plot to plot a number of figures together (into a Multi-sheet file) - random Mtext objects will be left off random drawings. If I batch plot the same group of figures - different figures/MText objects could be missing in each batch. Since this is a random occurrence - I am not sure how to troubleshoot or report the issue. This image is of two PDFs of the same figure. You can see that one PDF is missing Mtext objects that appear in the other PDF. Has this happened to you?
  7. I'm in ACAD 2006. All of a sudden my Mtext is not working. If I try to create some, the field stays blank although the cursor moves as I type. If I try to edit some, I can delete things fine but typing delete's everything or some portion (everything before or everything after the insertion) out of the field. This means that when I try to do leaders, I can't create Mtext to label them. Any ideas?
×
×
  • Create New...