Jump to content
Goomba

Tekla import to Inventor

Recommended Posts

Goomba

I know this has been questioned before, since that is what bought me back to these forums, but was wondering if there is a definite answer for importing Tekla into Inventor?

 

If one of the steps is going through AutoCAD that isnt a bother because at that stage I can union the structure to decrease the number of parts which will make the model faster too load.

 

Note that the model has to come through into Inventor as solids, not surfaces. If it is in surfaces, once added to my model you then need to "included all surfaces" when generating drawing views.

 

It is abit hard guessing on the exporting side as I am guessing how Tekla goes about the process, since I have not used the program. We have had the people using Tekla try several different methods but most end up in surfaces :x

 

Any ideas?

Share this post


Link to post
Share on other sites
JD Mather
We have had the people using Tekla try several different methods but most end up in surfaces :x

 

Any ideas?

 

Post examples here.

Share this post


Link to post
Share on other sites
Goomba

I think I have attached them correctly..

 

These are the samples that they sent through for me to test.

 

I thought "Model_AsIs" was OK but then when we got the full model I realised that each component was like a block of surfaces/regions.

 

After having another look I think that "Model_ManifoldSolidBrep" should be OK so I have requested the full model like this.

Model_AsIs.zip

Model_BRep.zip

Model_Faces.zip

Model_GeometricCurveSet.zip

Model_ManifoldSolidBrep.zip

Model_ShellBasedSurfaceModel.zip

Share this post


Link to post
Share on other sites
Goomba

Had no luck with those files but with the link you posted and an earlier SAT file we tried I think I have solved my problem.

I imported the SAT as a single part and then when through the steps in the Class for converting the DWG file.

They just recently sent through the model in Microstation which I thought was no good because when converted to AutoCAD it should all the model as regions.

Out of curiosity I tried to export from Microstation to SAT and it seemed to work.

I am waiting for the handrails to stitch which is taking a while because one closure bend has approx 500 surfaces... with about 20 closure bends plus all the handrailing being 20 surfaces each.. its taking its time but think progressing

 

I guess converting back and forth and in and out isnt ideal but I think we might have at least got a resolution.

 

Thanks for the help!

Share this post


Link to post
Share on other sites
JD Mather

If you end up using SAT just make sure you set to version 7 as that is the latest that Autodesk products will read. I would use STEP if you have that option.

Share this post


Link to post
Share on other sites
Goomba

The step files when importing as a multibodied part comes through as a blank screen with no parts or anything in the model.

Would be nice to have a better understanding of Tekla and to know what the other person is doing to export.

Oh well I am happy with what I have got, now just need to wait for them to send through the other systems I am waiting on...

Share this post


Link to post
Share on other sites
JD Mather
The step files when importing as a multibodied part comes through as a blank screen with no parts or anything in the model.

 

I'm trying to determine if there is something wrong with the STEP or if there is something wrong with the install of your translator.

 

Attach the file (one and only one) that exhibits this behavior.

Share this post


Link to post
Share on other sites
Goomba

The file is too large to upload, also not too worried anymore.

 

I do however have another part from a while ago that came from ProE and I tried the steps to convert that to solids but got alot of errors when trying to stitch it. However this file is too large to upload when zipped aswell. :( oh well

Share this post


Link to post
Share on other sites
Goomba

Ok a different assembly wont let me conver the whole lot of the handrails etc to solids using the methods above.

 

I have attached a sample of the parts which I am having trouble converting, in autocad format.

 

I would like these to be solids once I get them into inventor, whether or not the conversion is done in autocad or inventor I am not too fussed.

handrailsproblem.dwg

Share this post


Link to post
Share on other sites
JD Mather

This model is heavily faceted surfaces - generally of little use in an engineering application. (The term I would use is - garbage). I would simply re-create in Inventor (Sweep or Revolve).

Share this post


Link to post
Share on other sites
mark1981
I know this has been questioned before, since that is what bought me back to these forums, but was wondering if there is a definite answer for importing Tekla into Inventor?

 

If one of the steps is going through AutoCAD that isnt a bother because at that stage I can union the structure to decrease the number of parts which will make the model faster too load.

 

Note that the model has to come through into Inventor as solids, not surfaces. If it is in surfaces, once added to my model you then need to "included all surfaces" when generating drawing views.

 

It is abit hard guessing on the exporting side as I am guessing how Tekla goes about the process, since I have not used the program. We have had the people using Tekla try several different methods but most end up in surfaces :x

 

Any ideas?

 

 

I'm working with Inventor and very often I convert a tekla model to a Inventor assembly with solid parts (no surface parts).

Follow these steps:

- In tekla: dwg export (without bolts)

- In AutoCAD (or Rhino): deleted items you do not want to have in Inventor (The solid model might be 50x larger than the 3d-dwg)

- Import in Rhinoceros (free trial versions available). A licence is about €1000,-

- In Rhino: "meshtonurbs" -> select all (or type "all") -> enter (might take a while)

- In Rhino: save as SAT-file (choose a good name, i prefer to start with the date "yymmdd....", later this will be the name of the folder and assembly)

- In Inventor: open the SAT-file; make sure a setting under options is not selected: "import to a sinlge part" unless that's the thing you want. (might take a while, sometimes it looks like nothing is happening, but the task manager will show Inventor is still working)

The biggest advantage to have it all in an assembly, is the possibility to delete or suppress parts (so, to create different "level of detail"), which is impossible when it's a sinlge solid part.

- Then save the assembly. With the default settings, it will be saved in a seperate folder named "Imported Components". (might take a while). You do not need to type a name, Inventor will use the same like as the SAT-file.

 

Try it, I hope this makes sense.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...