Jump to content
elijahjt

Placing a Point in 3D

Recommended Posts

Hello everyone --

 

I'm basically new to AutoCAD (I'm using 2011, student version) and I'm having a lot of trouble with what I thought would be a very simple task: simply placing a point in 3D.

 

I open the acad3d template and switch to 3D Modeling mode. I choose the line tool, but when the option comes up to type in the coordinates of the first point, I only get a choice of X and Y coordinates. I'm forced to be at Z=0, which is not what I want (I would like to, for example, place the point at (1,2,3)). Wherever I look for help regarding this -- in an AutoCAD book I have or in the help files available with AutoCAD -- it makes it sound so simple (just type in the X, Y, and Z coordinates as you would in 2D space). They make no indication that there's something else you have to do to enable you to do that.

 

I have searched through dozens of menus and toolbars (luckily learning some things along the way), but I can't seem to find out how to accomplish this basic task. Is there some setting that needs to be changed so I'm not locked into Z=0? Does anyone know what I could be doing wrong? I have spent hours trying to figure this out, and I have come to my wits' end.

 

Thanks in advance for any help you can provide.

Share this post


Link to post
Share on other sites

It sounds like you may have OSNAPZ = 1 ((Options-Drafting-Object Snap Options- Replace Z value with current elevation) with an OSNAPCOORD = 0 ((Options-User Preferences - Priority for Coordinate Data Entry - Running object snap).

 

Setting OSNAPCOORD = 1 (Options-User Preferences - Priority for Coordinate Data Entry – Keyboard Entry) may fix the problem.

Share this post


Link to post
Share on other sites
It sounds like you may have OSNAPZ = 1 ((Options-Drafting-Object Snap Options- Replace Z value with current elevation) with an OSNAPCOORD = 0 ((Options-User Preferences - Priority for Coordinate Data Entry - Running object snap).

 

Setting OSNAPCOORD = 1 (Options-User Preferences - Priority for Coordinate Data Entry – Keyboard Entry) may fix the problem.

 

OSNAPCOORD was originally set to 2. Even after changing it to 1, the problem still exists.

 

Also, "Replace Z value with current elevation" was not selected.

Share this post


Link to post
Share on other sites

Damn . . . . thought that notion had promise. I don’t have any other suggestions, nor do I have AutoCAD 2011 to test them if I did. :(

Share this post


Link to post
Share on other sites
It sounds like you may have OSNAPZ = 1 ((Options-Drafting-Object Snap Options- Replace Z value with current elevation) with an OSNAPCOORD = 0 ((Options-User Preferences - Priority for Coordinate Data Entry - Running object snap).

 

Setting OSNAPCOORD = 1 (Options-User Preferences - Priority for Coordinate Data Entry – Keyboard Entry) may fix the problem.

 

However, you did seem to point me toward the correct area. Apparently, there was a setting under Options / 3D Modeling: Show Z Field for Point Input under Dynamic Input needed to be checked. Thanks for the help.

Share this post


Link to post
Share on other sites

I didn’t know that option was there, either. But I don’t use Dynamic Input regularly.

Share this post


Link to post
Share on other sites
Apparently, there was a setting under Options / 3D Modeling: Show Z Field for Point Input under Dynamic Input needed to be checked.

 

Maybe I am missing something here, but I don't think the z coordinate box has to be initially present in dynamic input to use z coordinates.

 

On my machine there is no z box, I enter the x,y and as soon as I hit , (comma) after the y the z box automatically appears. Always been this way (with dynamic input) as far as I know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×