Jump to content
ColinPearson

Very slow properties CAD on a decent machine

Recommended Posts

ColinPearson

Hi all, I would appreciate any help I could get on this matter.

 

I'm running CAD2011, a pretty good flavor of an i5, 8GB, Win7x64, 1GB graphics, etc... a nice-enough laptop for sure that CAD should be run seamlessly.

 

HOWEVER! When I select a dimension, it takes at least 5 seconds for the properties box to correctly display and populate, then another few seconds once I click inside the box to be able to scroll/operate a drop down, type, etc.

 

I have seen this posted with no resolution before... can anyone offer any advice on this matter?

 

I saw one poster mention reloading support files such as fonts that may be corrupted but I must concede that I don't know exactly how to do this i.e, where would I get another copy of all of my fonts?

Share this post


Link to post
Share on other sites
ReMark

I kind of have my doubts that the speed at which AutoCAD appears to be running on your laptop has anything to do with corrupted fonts.

 

Are you working in 2D or 3D?

 

Do you have a bloated scalelist?

 

Do you make use of layer filters?

 

Are there xrefs attached?

 

Does this "slowness" happen with a single drawing or all drawings?

 

Do you have Update 1 for 2011 loaded?

Share this post


Link to post
Share on other sites
ColinPearson

2D or 3D is the same - this will even happen on a new drawing with nothing but a line a dimension, so layer filters and xrefs are not affecting this behavior. It does happen on all drawings, so it's not an issue with the source having something incompatible. Update 1 is in....

 

I am *gasp* resorting to using my work computer for the time being. It sounds like a small annoyance, but anything that disrupts your rhythm is a killer as I'm sure you also know.

 

Also, the ribbon is turned off - if that might matter.

 

And Mark, to be honest, I don't know what a scalelist is, but this has happened since Hour 1 of a new install.

Share this post


Link to post
Share on other sites
ReMark

Are any other programs exhibiting the same symptoms (slowness)?

Share this post


Link to post
Share on other sites
ColinPearson

No, nothing similar. This is a fresh machine that I spent a week on setting up just right - no crapware from the manufacturer, nothing that isn't vital running on startup, etc.

 

This machine runs very nicely with everything else I have on it - Photoshop, font creators, CAD 2007, office programs, you name it. I can't understand this one very particular slowdown. It's as if it has something very specifically to do with line/arrows - whether you pick a dimension or a leader, the properties box actually slows as its populating RIGHT AT the "Lines and Arrows" section. Strange!

Share this post


Link to post
Share on other sites
ReMark

So, AutoCAD is up and running as well as your OS obviously but what other programs are also running in the background and sucking up resources?

 

 

A list of suggestions for speeding up AutoCAD 2009. Maybe some of them are applicable to 2011 as well. I am not the author. This was originally posted by another forum member.

 

Speed AutoCAD up.doc

 

I have one more suggestion. Try disabling your antivirus software temporarily and see if that makes a difference. Some AV programs aggressively target AutoCAD dll files as supicious even though they aren't.

Share this post


Link to post
Share on other sites
ReMark

I'd say this would be my last suggestion but I'd probably be lying.

 

When you experience a "slowdown" minimize AutoCAD, do a Ctrl-Alt-Delete (the three finger salute) and open Task Manager. Find the entry for WSCommCntr1.exe and highlight it. Click on the End Process button to kill the process. Return to AutoCAD. Does that make any difference?

Share this post


Link to post
Share on other sites
ColinPearson

I will try all things suggested in the .doc as well as WScommcntr1. Thanks very much, will post back later today.

Share this post


Link to post
Share on other sites
gigi43

I spent 4 hours this morning trying to diagnose the problem of the very slowly regenerating properties pallette. I finally discovered that turning off McAffee's Realtime Scanning solved the problem completely. I tried to find a way to create an exception for AutoCad (within McAffee), but came up short. I then contacted McAffee's technical support department to see if there was a way to create an exception. They spent the next hour and a half trying to convince me of the following things: that there was no problem, that there was no significant problem, that the lag was normal because of the amount of memory AutoCad uses, that the lag was not a big deal (3-4 seconds every time I select an object seems like a big deal to me), and finally that I should contact AutoCad support. Does anyone know of a virus scanning program that is compatible with AutoCad? For now, I just have Realtime Scanning turned off, and I will take my chances.

Share this post


Link to post
Share on other sites
ReMark

I'm using a freebie antivirus program on my home computer at the moment by AVG and I don't notice a lag.

Share this post


Link to post
Share on other sites
Jack_O'neill

I use Norton 360 with no problems. Back when the hackers were attacking this site, it fought off literally hundreds of intrusions, and I've never noticed any detriment to performance with 2010 or revit.

Share this post


Link to post
Share on other sites
SLW210

What graphics card are you running?

 

Have you tried a repair?

Share this post


Link to post
Share on other sites
ColinPearson
What graphics card are you running?

 

Have you tried a repair?

Laptop is a Toshiba, NVIDIA GEforce GT 330M 1GB, Intel I7-740QM 1.73-2.93GHz, 8GB 1066Hz DDR3RAM...

What do you mean by repair? Are you talking physical repair, or a repair to the install? It's been a while, and I still can't figger this one out. Thanks.

Share this post


Link to post
Share on other sites
THESHADOWED

I looked for a long time and finally found a solution on another forum --> Set your theme to windows 7 basic (go to desktop>right click> personalize)

Share this post


Link to post
Share on other sites
Leafrider

Well I have the same problem, but I've tried everything you've all suggested. I select anything in a blank drawing, and my properties dialogue box looks like it's regenerating a list of criteria to display. It's very painful, but oddly enough, it's only started happening recently. I've also had a few fatal errors over the past few weeks as well. Thoughts? Wasn't the Windows 7 theme.

 

I open Civil 3D 2012 and I have this problem. I open the old 2011 version and everything is back to normal. Thoughts?

Share this post


Link to post
Share on other sites
rkent

Start AutoCAD with a new profile and test that.

 

Start you computer in Admin mode, start AutoCAD, test to see if there is any change.

 

Turn off computer antivirus products as a test.

Share this post


Link to post
Share on other sites
mikecmix

Minimize the "Lines & Arrows" section of the Properties form fixed it for me. And Yeah, MaAffee sux. I wasn't using it and still had this problem. It may any anti-virus program.

Share this post


Link to post
Share on other sites
ColinPearson

@rkent, @mikecmix

Thanks for the ideas guys, I'm going to try them both.

Share this post


Link to post
Share on other sites
Tinbum
I will try all things suggested in the .doc as well as WScommcntr1. Thanks very much, will post back later today.

 

Did you ever work out the fix for this. I have 1 user in a group of 20 that has the issue and found that minimising the 'Lines and Arrows' section of the properties pallette reduces the lag to a manageable level, but I am looking for a fix, not a work around.

Share this post


Link to post
Share on other sites
mikecmix

I found that I also has to uninstall the VBA Enabler for AutoCAD 2012 (I don't remember if it was exactly for this same reason, but it got to the point where I couldn't do anything with it installed, on certain dwgs that were recovered, audited, etc.!). It caused problems that were not fixable otherwise, that I ever found. ACAD 2013 (& newer) has a fix to allow VBA, so now I use 2014 for anything that requires any custom code, and 2012 for other things (since others at work use 2012, and I haven't fully set it up yet). If I can't automate or use any code, then my employer doesn't need me, they can get a school kid to use it OOB inefficiently without intelligence ("dumb lines", forget about 3D & trimming out, i.e., Quality) for less pay!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...