Jump to content
dulerong

Gizmo Problem - Doesn't let me select it

Recommended Posts

dulerong

Hi,

 

I'm having a Gizmo problem, and it has been recurring for a long time.

 

Problem:

When I select an object, either with scale/rotate/move selected, the corresponding Gizmo appears

 

Great:shock:

 

But as I hover my cursor over it, and it clearly shows I'm over it by changing color, and try to click on it. It disappear.

 

It's very frustrating as I try to click on it, and it's gone, and the command window displays this message

"Please select an axis" duhhh :(I can't cuz the Gizmo is GONE. Then I ended not being able to perform all those functions.

 

Any idea guys?

 

Regards,

Dulerong

Share this post


Link to post
Share on other sites
dulerong

Actually guys,

 

I found my solution, it's really weird but in case someone with the same problem.

 

To avoid this:

In 3D mode, Home->Selection then you can see gizmo selection types (scale, rotate, move)

 

Basically the problem I was having is due to selecting the different gizmo then what I intended to do,

 

so like this: type "rotate" but had "scale" selected in that tab.

 

This is not gonna work.

 

Hope it helps anyone like me.

Share this post


Link to post
Share on other sites
nestly
Hi,

the command window displays this message

"Please select an axis"

 

Is that the exact message? None of my gizmos in 2011 prompt for an "axis" before, during, or after using the gizmo.

Share this post


Link to post
Share on other sites
nestly

Not sure I understand, but I'm glad you figured it out.

 

You may want to look into the GTDEFAULT variable, if you have it enabled (1), it should present the correct Gizmo, even if you invoke a 2D command (ie rotate / move / scale) while you're in a 3D view, regardless of which gizmo is selected on that Ribbon tab.

Share this post


Link to post
Share on other sites
dulerong

i've managed to fix this problem with manually typing in 3Dmove, 3Dscale, 3Drotate,

 

For some reason this problem still persists

 

I just can't select an object and use the GIZMO right away, like I need to type in the command

 

Thanks for the help guys!

Share this post


Link to post
Share on other sites
SLW210
i've managed to fix this problem with manually typing in 3Dmove, 3Dscale, 3Drotate,

 

For some reason this problem still persists

 

I just can't select an object and use the GIZMO right away, like I need to type in the command

 

Thanks for the help guys!

 

Try reading the help files.....

 

From Help

Gizmos are available only in 3D views that are set to use a 3D visual style such as 3D Hidden. You can set the gizmo to be displayed automatically when you select a 3D object or subobject. Gizmos are also displayed during the 3DMOVE, 3DROTATE, and 3DSCALE commands.

 

If the visual style is set to 2D Wireframe, entering 3DMOVE, 3DROTATE, or 3DSCALE automatically converts the visual style to 3D Wireframe.

 

By default, the gizmo is initially placed in the center of the selection set. However, you can relocate it anywhere in 3D space. The center box (or base grip) of the gizmo sets the base point for the modification. This behavior is equivalent to temporarily changing the position of the UCS as you move or rotate the selected objects. The axis handles on the gizmo constrain the movement or rotation to an axis or plane.

Share this post


Link to post
Share on other sites
qball

 

so like this: type "rotate" but had "scale" selected in that tab.

 

 

It sounds to me like you're executing a command line command. The gizmo works when you select an object, then that gizmo suddenly appears around the centre of that mass. Then you select one (or more) axis, whether it's move, scale, or rotate. No typing necessary with the gizmo.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...