Jump to content
thedarkmaster

Can I disable right click dragging?

Recommended Posts

thedarkmaster

Hallo everybody, this is my first post here, I'm writing because I'm having a really frustrating experience with Autocad... I don't know why, I never had such a problem since the latest version, never realized there was this problem.

When I right click on a selected object, I need the contextual menu to show up but, very very often, the result is that the object moves itself slightly! And that's of course terrible. Basically, when I select an object and right click on it, it can randomly move to somewhere else (a few millimiters away from the original point, so it's often hard to notice if it moved or not) or autocad can show me the menu. This is not acceptable, of course! How can I disable this annoying and useless dragging feature? I've realized that these kind of things happens only now and looking at some of my drawings, I've seen that many objects (mainly hatches) are moved from the point they are supposed to be!! Please help..

Share this post


Link to post
Share on other sites
ReMark

Sounds more like a mouse setting problem not an AutoCAD problem.

Share this post


Link to post
Share on other sites
Tiger

A bit of scouring the CUI didn't yeild any result as to where the right-click-hold-action is determined - I can say that my AutoCAD behaves the same way. Luckily mine is a bit on the slow side so it freezes for a few seconds when I accidently use this Move command so I always (as far as I know) notice it. And I rarely use the right-click menu.

Share this post


Link to post
Share on other sites
ReMark

Right-click customization can be found on the User Preferences tab under Options. Your options however are limited. I'd start by check your mouse sensitivity settings under Device Manager in Windows.

Share this post


Link to post
Share on other sites
Tiger

the command that you are invoking is called DROPGEOM - a google search reveals that there have been a few questions posed in a few places (Autodesks own, Swamp etc) about how to disable it but noone has responded with a way to do it.

Share this post


Link to post
Share on other sites
thedarkmaster
the command that you are invoking is called DROPGEOM - a google search reveals that there have been a few questions posed in a few places (Autodesks own, Swamp etc) about how to disable it but noone has responded with a way to do it.

 

Ah, at least now I know the name of the command... well, in any case the command moves objects instantly on my computer, so I'm really troubled.. :\

And I'm having this problem only with autocad 2012!!

Share this post


Link to post
Share on other sites
ReMark

Do you have Grips enabled by any chance?

 

I've never noticed any sensitivity issues with DROPGEOM (when using the right-click feature of my mouse) across multiple versions of AutoCAD dating as far back as 2004.

 

I'm running 2012 this morning and no problems encountered with right-click. Just tested it a minute ago. The only way an object will move is if I hold the button too long and purposely move my hand.

Share this post


Link to post
Share on other sites
Tiger

from what I have read, this command have been in AutoCAD (and I assume always active since its a hidden command that noone seems to know how to disable it) since 2005 so its not new to 2012.

 

Perhaps you have made some changes to the mouse sensitivity recently? Or a new mouse?

 

I'm afraid the only other thing I can say is don't use the right-click menu :(

 

Another tip is that if you lock the layer, you can't move anything on that layer. I realise that its not practical to lock everything, but if something is very sensitive to stay in one place (ie maps for coordinate purposes), it could be a good idea to lock that layer down.

Share this post


Link to post
Share on other sites
thedarkmaster
Do you have Grips enabled by any chance?

 

I've never noticed any sensitivity issues with DROPGEOM (when using the right-click feature of my mouse) across multiple versions of AutoCAD dating as far back as 2004.

 

I'm running 2012 this morning and no problems encountered with right-click. Just tested it a minute ago. The only way an object will move is if I hold the button too long and purposely move my hand.

 

Yes I'm using grips, why? they're very very handy, specially when working with hatches. In any case, if I try and replicate the problem on purpose it won't happen often. As you said, I need to keep the right click button a bit. But the problem is that if I keep it pressed long enough when moving, after releasing the mouse a contextual menu appears asking me if I prefer to move, copy, etc! If this menu could appear always I'd know for certain that I moved something! but this menu doesn't appear always, it only shows when I keep pressed the right button for too much... and this is confusing. When working normally, so, the accidentally moving problem often happens :(

And I cannot find a way to modify the sensitivity of the mouse in windows (I'm a mac user normally). In the properties of the mouse I only see sensibility for the weel, double click, these kind of things..

Share this post


Link to post
Share on other sites
ReMark

There is one way to disable DROPGEOM but you aren't going to like it. Change the system variable value for PICKFIRST from "1" to "0".

 

Just as an experiment disable grips and see what happens when you right-click on an object.

Share this post


Link to post
Share on other sites
Tiger

I can't find a sensitivity setting for single click either now that I looked, just assumed that it should be there :(

 

PICKFIRST=0 does solve it - but I wouldn't trade this issue for those...

Share this post


Link to post
Share on other sites
nestly

I did not know it was possible to drag-n-drop with the right mouse button before this post. For me, it's very difficult to do unintentionally, I might suggest turning on time sensitive right-clicking to train yourself to be more deliberate with your right clicks.

Share this post


Link to post
Share on other sites
ReMark

Quickie Move.

 

Click on an object to highlight it. Now click on it a second time but continue to hold the button down. Drag the object to another location in your drawing. Note that the Move command does not have to be invoked to do this.

Share this post


Link to post
Share on other sites
SLW210
Sounds more like a mouse setting problem not an AutoCAD problem.

 

This was the first response.

 

Have you tried adjusting your mouse settings through the Windows Control Panel or your Mouse Software?

 

Tell use what mouse you use. Sounds like you have some sort of click-lock or time sensitivity problem.

Share this post


Link to post
Share on other sites
nestly

As I said earlier, I never even knew you could Right-click drag in AutoCAD, but I just tried it on a 2nd machine and it's definitely a lot easier to drag objects around inadvertently without getting the right click options on this machine.... I don't know what makes the difference.

 

http://www.screencast.com/t/yvw8pS3se

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...