Jump to content
vweavers

Model Space vs Viewport scale

Recommended Posts

vweavers

Am trying to use millimeters for the first time. In model space, I set UNITS to millimeters. I draw a 5 unit line. No problem. I go to a layout tab and the viewport shows a 5" line, using a 1:1 scale. How do I make the viewport show a true 5mm line? What am I missing? If I choose inches as my units, the viewport scale is true 1:1 scale

Edited by vweavers
clarity

Share this post


Link to post
Share on other sites
SLW210

What units did you set to mm? You need to set length in UNITS to decimal.

 

How are you measuring the line?

Share this post


Link to post
Share on other sites
BIGAL

Firstly draw a title block in a layout at 1:1 scale in mm A4 A3 A1 etc zoom extents then have a mview window within it then check your scale again. If you dont have the mview window the correct size then it will be very hard to work out whats going on with scale.

Share this post


Link to post
Share on other sites
nestly

Can you post the file?

Share this post


Link to post
Share on other sites
Jeff H

Objects are drawn in AutoCad drawing units.

5 drawing units = 5 inches = 5 mm.

 

To get it to draw a true 5mm line

Using a ruler make a line on your monitor with a sharpie and create a line the same distance is about the only way.

 

Notice when you set 'units' you are setting insertion scale.

You have to scale between different measurements

If you draw a line 2.54 units long with insertion scale set cm then changing it inches just makes it report the line is 2.54 inches.

 

What that setting is for when you enter Block command and create a block notice the Block Unit combo box at bottom left.

So it is set to what your current settings is say inches.

When you insert notice bottom right where is says Factor.

If you change the insertion scale 'units' to cm then it change from 1 to 2.54.

 

Couple other notes

Select a viewport and on the properties pallete notice the standard scale and annotative scale and make sure you know the difference.

 

 

If you use the DI(distance command) in paper space and you are not inside the viewport it still gives model space length.

So if you create a line in model space 10 units long, then go to paperspace and set the viewport to 1:2 then use distance command it reads 10.

You can draw a line in paperspace the same length and it will report 5 and again this is in paperspace and not double clicking inside the viewport

Share this post


Link to post
Share on other sites
lpseifert

 

To get it to draw a true 5mm line

Using a ruler make a line on your monitor with a sharpie and create a line the same distance is about the only way.

 

 

What??? ...

Share this post


Link to post
Share on other sites
Jeff H

Was just trying to emphasize the point that AutoCAD uses Drawing units and does not represent 'units' as centimeters, inches, etc......

Share this post


Link to post
Share on other sites
qball
What??? ...

Then use white-out to erase it when you're done.

 

Then go buy a new monitor and do what SLW wrote.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...