Jump to content
MisterJingles

Incomplete drawing

Recommended Posts

MisterJingles

Hi all

 

Anyone got any idea why a drawing would open without a number of objects (text) showing?

I open it up and all notes are gone, yet another user opens it up in "eDrawings" and it opens fine.

Oddly, when in ACAD I click OPEN, the preview ACAD gives me when I click this file once shows the missing text etc. But when I open it they're missing.

 

Any help?

 

Below is a screenshot of firstly the drawing open in ACAD and secondly open in eDrawings.

 

Capture-1.jpg

 

Capture1-1.jpg

Share this post


Link to post
Share on other sites
Dadgad

Try setting ANNOALLVISIBLE system variable setting to '1'.

annoallvisible.jpg

Share this post


Link to post
Share on other sites
MisterJingles

Hi Dadgad. Unfortunately it was already set to "1". Any other ideas?

 

Sorry I must add, all objects in PAPER SPACE are missing too.

 

I have attached the file here, perhaps someone has the time to take a look?

 

Thanks ST-A2.dwg

Edited by MisterJingles
Additional information

Share this post


Link to post
Share on other sites
ReMark

Tested using full AutoCAD 2012 this morning. All text in model space is there and readable. What objects are you referring to in paper space other than the viewport? There does not appear to be any other objects in your layout. By any chance we you making use of any xrefs? If so for what purpose? Title block and border perhaps?

Share this post


Link to post
Share on other sites
MisterJingles

Thanks ReMark. I actually hadn't checked for XREF's, this is one of a pile of standard drawings tucked away in a folder I have never had to refer to until today.

As it turns out there was 1 reference, a titleblock which I have reloaded. This was in MS not PS as I had thought (All drawings in this office plot from PS)

 

But the mystery of the missing text in MS remains.

Share this post


Link to post
Share on other sites
ReMark

Do you get a message when you open the drawing about a missing font?

Share this post


Link to post
Share on other sites
MisterJingles
Do you get a message when you open the drawing about a missing font?

 

No nothing at all.

Share this post


Link to post
Share on other sites
Dadgad

I got a message that it was not created on an Autodesk product, which was followed by this missing SHX font message. Bingo ReMark! :beer:

 

If I instruct it to ignore and continue, it looks just as shown by the OP in the first post.

missing SHX files.JPG

Share this post


Link to post
Share on other sites
MisterJingles
I got a message that it was not created on an Autodesk product, which was followed by this missing SHX font message. Bingo ReMark! :beer:

 

If I instruct it to ignore and continue, it looks just as shown by the OP in the first post.

 

Hmmm ok, I actually recall getting this a few days ago on another drawing (after doing the 2013 upgrade), I must have ignored and told it to always perform current choice. How do I go about undoing it?

Share this post


Link to post
Share on other sites
Dadgad

I'm not sure how to change, or rather override your previous instruction. The only SYSTEM VARIABLES I see that deal with fonts are FONTALT and FONTMAP. If you enter SYSVDLG at your commandline you can access information on available system variables for those. I do recall Stykface having posted what appeared to be a definitively comprehensive compendium of SHX fonts, or maybe it was a link to it. If you can get your hands on that, your drawing will probably open for you. Try etransmitting the drawing from a computer that is able to open it to you, and in that way you should receive the font too, if I am not mistaken. Search for SHX fonts on the forum, or google 'MISSING SHX FILES'. Somebody will know how to reverse your preference selection. Had you specified the FONTALT to use, you would be sitting pretty.

Good luck with it.

 

Just start a new thread titled MISSING SHX FILES, and you will probably get it sorted out pretty quickly.

 

I found that post by Stykface.......Luminous Being StykFacE's Avatar

Computer Details

 

Discipline

Mechanical

Using

MEP 2012

 

Default 762 SHX AutoCAD Fonts

 

http://www.tannarzane.com/files/749_Fonts.zip

 

*EDIT* Until I get my file manager server resolved, I have zipped them up and offering a direct link. I have removed a few fonts that were corrupt so 749 is the grand total. I know everyone kept bugging so this is an alternative for now. Once again, enjoy.

 

Stykface, thanks for sharing these! :beer: I hope you don't mind my copying and pasting this into this thread.

Edited by Dadgad

Share this post


Link to post
Share on other sites
SLW210
Hmmm ok, I actually recall getting this a few days ago on another drawing (after doing the 2013 upgrade), I must have ignored and told it to always perform current choice. How do I go about undoing it?

 

_OPTIONS>System>General Options>Hidden Messages Settings> Expand the AutoCAD selection then choose Missing SHX files.

Share this post


Link to post
Share on other sites
Dadgad

Nice save there Hulk, I should have known that, I've poked my nose in there before! :beer:

Seems there is a lesson to be learned here. As annoying and frustrating as it may seem to be presented with options which we may not as yet understand, best to recognize that, and not make any knee jerk long range decisions reactively. Hopefully Mister Jingles should be off the bench by now, and back in the game. :beer:

Share this post


Link to post
Share on other sites
MisterJingles

You really are a bright lot :beer: Problem solved thanks

Share this post


Link to post
Share on other sites
Dadgad

We aim to please. No problems, just solutions. Glad to hear that it all came out in the wash. Now, stop your lolly-gagging, and get back to work! :beer: :wink:

Share this post


Link to post
Share on other sites
leongtechno

Dear sir,

 

I just registed this CADTutor:), I also have this problem 'MISSING SHX FILES'.

this '749 fonts' can add into Autocad LT2008? 10ssssss.

 

 

I'm not sure how to change, or rather override your previous instruction. The only SYSTEM VARIABLES I see that deal with fonts are FONTALT and FONTMAP. If you enter SYSVDLG at your commandline you can access information on available system variables for those. I do recall Stykface having posted what appeared to be a definitively comprehensive compendium of SHX fonts, or maybe it was a link to it. If you can get your hands on that, your drawing will probably open for you. Try etransmitting the drawing from a computer that is able to open it to you, and in that way you should receive the font too, if I am not mistaken. Search for SHX fonts on the forum, or google 'MISSING SHX FILES'. Somebody will know how to reverse your preference selection. Had you specified the FONTALT to use, you would be sitting pretty.

Good luck with it.

 

Just start a new thread titled MISSING SHX FILES, and you will probably get it sorted out pretty quickly.

 

I found that post by Stykface.......Luminous Being StykFacE's Avatar

Computer Details

 

Discipline

Mechanical

Using

MEP 2012

 

Default 762 SHX AutoCAD Fonts

 

http://www.tannarzane.com/files/749_Fonts.zip

 

*EDIT* Until I get my file manager server resolved, I have zipped them up and offering a direct link. I have removed a few fonts that were corrupt so 749 is the grand total. I know everyone kept bugging so this is an alternative for now. Once again, enjoy.

 

Stykface, thanks for sharing these! :beer: I hope you don't mind my copying and pasting this into this thread.

Share this post


Link to post
Share on other sites
ReMark

Any SHX font can be added to AutoCAD simply by putting a copy of the font in the correct AutoCAD font folder. I'm not sure you'd would need all 762 fonts though. I barely use more than half a dozen and only two of those did not come with AutoCAD to begin with.

Share this post


Link to post
Share on other sites
leongtechno

In Autocad LT 2008, i pick 'option', pick 'file' , pick 'support file seach path', shown the c:\program files\autocad lt 2008\fonts, this is the correct Autocad font folder in autocad lt? I just need put 'shx' to this folder? after this i need do another thing to ?

Share this post


Link to post
Share on other sites
ReMark

That is the correct folder. Put your new SHX fonts in it and they will become available to you in the exact same way all the normal AutoCAD SHX fonts are via the STYLE command.

 

Another option (safer) is to create a separate folder for the new fonts and add the path to this folder in Options > Files and Folders > Support file search path. Why? So in case you have to repair or uninstall/reinstall AutoCAD you don't lose all the fonts you worked hard to download.

Share this post


Link to post
Share on other sites
leongtechno

Dear sir,

 

Thany you Help me! to settle this problem.....:)

 

 

That is the correct folder. Put your new SHX fonts in it and they will become available to you in the exact same way all the normal AutoCAD SHX fonts are via the STYLE command.

 

Another option (safer) is to create a separate folder for the new fonts and add the path to this folder in Options > Files and Folders > Support file search path. Why? So in case you have to repair or uninstall/reinstall AutoCAD you don't lose all the fonts you worked hard to download.

Share this post


Link to post
Share on other sites
ReMark

You're entirely welcomed leon. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×