Jump to content
Magnum Z

Wire Attribute Grips

Recommended Posts

Magnum Z

So I've been toying around with AutoCAD Electrical 2013 for a couple weeks now. I've been trying to figure out a way to adapt it to create P&ID drawings. There seems to be a lot more setup work involved but for now I've been mainly trying to convert my custom P&ID symbols to ACADE symbols using Symbol Builder.

 

I thought I had the basics figured out until I inserted the first said blocks from the Icon Menu dialog box. The original block turned component symbol now shows all of the wire connection attribute grips when selected instead of just the insertion point grip. I have no idea what went wrong. I should note that these blocks also have dynamic attributes like flip, scale, and visibility.

 

I've looked around on the web, through the ACAD help, and did a couple searches here to find a similar problem to no avail. Anyone have any insight into this issue?

 

These kinds of issues make me wish the "higher up's" had listened when I said we need to switch to P&ID but that's a whole other issue I won't get into here...:glare:

Share this post


Link to post
Share on other sites
ReMark

ACADE has some minimal P&ID functionality but does really sound like your company made the wrong choice.

 

When you converted your AutoCAD block into AutoCAD Electrical an intelligent symbol did you first explode it so that you could select the attributes in Symbol Builder?

 

When you name your blocks are you following the ACADE specific naming convention?

 

Where are you saving your new blocks? I hope it is not in the default library area as this could cause problems later on if you share symbols or upgrade your program.

 

Have you had any training to use ACADE?

 

I'd like to point out that "Electrical" has commands that should be used instead of the normal commands one associates with lain AutoCAD. The basis behind the program is a massive database that tracks all the components knowing where they are and what they are connected to and maintaining those relationships across a project. I believe that to use the program most effectively one should get some serious training ( 3-4 days worth ).

Edited by ReMark

Share this post


Link to post
Share on other sites
Magnum Z

Just for some insight into my situation for the rest of this post. I only work 3 days a week. I'm hired through a temp company as a 'continuous' employee. I've been at this job for 6 years with almost 4 of them at this part-time status. That should give you an idea of my mentality toward this place.

 

First, your questions.

 

I did not explode the block. From the Symbol Building dialog box, I choose the block from a drop down list of existing in-drawing/loaded blocks. It then opened the block in the Symbol Building/Block Editor environment. Now in this evironment, I could convert some attributes and all the drawing objects were editable. Would that have been like exploding the block or no?

 

I'm not familar with the naming conventions yet, so no to following the ACADE block naming.

 

I have been saving the blocks to the default p&id library but with their original block names so they should be easy to remove later on. In plain AutoCAD, I use one base drawing to hold my blocks and Design Center to distribute them to the drawings. Organizing the blocks for ACADE would of course be one of the first things I do before I'd switch to ACADE completely.

 

Now here's where the first part of this post comes into play.

 

Anything I've done with ACADE so far has just been to familarize myself with its functionality. I've made no permanent changes to my core drawings yet. I still do that with plain Autocad. No, I haven't had any training. I won't get any either as this company won't pay for it and I'm sure as hell not pulling it out of my own pocket for what little they give me right now. For now, I'm stuck with want instructional videos came with the software which do point out a few of those particular commands you mention. ACADE database does seem quite massive but I also realize, for our purposes here, the setup time to utilize it fully will take a rather long time. AutoCAD P&ID would make things so much 'cleaner', but I've been told in no uncertain terms that "I need to make due" with what we have.

 

/rant :P

 

Anyway, back on-topic. The grips did disappear after I restarted the program. It must have been a graphical glitch or something. I'll fiddle with it again at some point. Until then it's back to plain AutoCAD to do everything manually...:(

 

Thanks for the reply ReMark. Here's to hoping those with the $$ see reason and get the proper software next year.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...