Jump to content

Recommended Posts

SAFeSTeR

Hi,

 

I've noticed in AutoCAD 2012 that the MTEXT grips have changed, for example, MTEXT justified to 'middle centre' displays just 3 grips, one centrally for moving and 2 'arrow' style grips for stretching. In previous versions of CAD which I used, the MTEXT would have 5 grips, the additional 2 giving more versatility when placing text. However, when using the TXT2MTXT command the resulting MTEXT will display 5 grips (see image).

 

TEXT.png

 

What I would like to know is if it's possible, perhaps with a system variable, for normal MTEXT to display 5 grips as standard as mentioned above? I've searched the help files and the forum but have found nothing...

Thanks

Share this post


Link to post
Share on other sites
Tyke

Select one of your MText objects and check what valur the property Columns has in the Properties Palette (Ctrl+1 to switch it on if its not already open).

 

Then repeat it for the other MText entity. My guess one is Static and the other Dynamic. If so just change the Property value. The Static value gives you five grips and Dynamic three.

Share this post


Link to post
Share on other sites
SAFeSTeR

Yes you're right, but I think I didn't explain my issue properly, sorry.

 

What I needed is for all new MTEXTs to display these 5 grips as standard. While your reply didn't fully fix my issue, it did highlight some things that I could look further into and as a result I found the MTEXTCOLUMN command. I set the variable to 0 and now it works just as I need.

 

Thanks for your help :)

Share this post


Link to post
Share on other sites
Tyke

Glad to have been of help.

 

BTW MTEXTCOLUMN is a System Variable not a Command ;). It has three values 0,1,2. And 0 sets it to "No Column" , and you said it is what you wanted. This System Variable is saved in the registry not the drawing, so it will apply to all drawings.

 

A value of 0 in the SysVar will set the columns property of your MText to "None" and that will only produce four grips. Either way if must have five grips you will need to set the vaue to "Static".

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...