Jump to content
mgmarisa

Hatch doesn't appear when applying it from viewport but shows fine on model space.

Recommended Posts

I'm drafting for an office that likes to create just one single main drawing with everything on top of it (ARCH, STRUC, MEP) and just work frezzing layers on each viewport so of course I have to use "maximize viewport" icon all the time and enter model space from there to work. The problem is when I try to apply hatch it just doesn't show (like if applying hatch to a frozzen layer), I'm very careful making sure that the layer is not frozen or off and still just simply doesn't show, however when I go back to model space is there. It's really lagging my work. Any help or idea on how to fix it?

Thanks

Share this post


Link to post
Share on other sites

Please pay attention that the trouble-maker layer may be frozen only in that particular viewport - in layers pop-up list, check the third column.

Share this post


Link to post
Share on other sites

Thank you for your reply, well the layer is not off or frozen, I can draw any polyline with no problem, then click "hatch" pick inside (is dashes the perimeter) but when accepting it the hatch simply doesn't show, but it is on model space.

Share this post


Link to post
Share on other sites

Have you checked that the Use paper space units for scaling box is checked in the "linetype manager"?

 

This function has a bearing on how units are view from model to paper space.

Share this post


Link to post
Share on other sites

Another setting that prevents hatches to be display is FILLMODE system variable set to 0. But this will affect also the Model Space, so doesn't seems to be your case.

Can you post the trouble-maker drawing (just strip out all not-relevant items)?

Share this post


Link to post
Share on other sites

isn't there a setting that lets you see all the linetypes and hatches in model space no matter what the scale is? I remember having this exact same issue and the fix was to scale up the hatch or linetype so I could see it in paperspace.

Share this post


Link to post
Share on other sites
I'm drafting for an office that likes to create just one single main drawing with everything on top of it (ARCH, STRUC, MEP) and just work frezzing layers on each viewport so of course I have to use "maximize viewport" icon all the time and enter model space from there to work. The problem is when I try to apply hatch it just doesn't show (like if applying hatch to a frozzen layer), I'm very careful making sure that the layer is not frozen or off and still just simply doesn't show, however when I go back to model space is there. It's really lagging my work. Any help or idea on how to fix it?

Thanks

 

This may be old... but I have the same problem in Plant 3d..

I solved by:

creating a new viewport on the same layer as viewport that has the hatching

problem

I put the same scale on the new view port as the one with the problem

Then I matchprop from new one to old one.

 

This solved the problem for me.. however I believe that there's got be a variable controlling that.. since viewport with hatching problem had on overrides through viewport or model space, no frozen layers, no hidden layers, no locked layers.

 

I am still in the hunt for this variable.

 

I hope it helps.

Andre

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×