Jump to content
Uomoviso

Text rotates in MTEXT while editing

Recommended Posts

Uomoviso

Hi all, whenever I enter the MTEXT editing function, then type a letter on any given line of text, that line rotates to the world UCS. This makes typing almost impossible, as the overlapping text can't be read clearly.

 

Any suggestions?

 

I'm using AutoCAD 2013 for Mac and looking at my drawing with a rotated UCS.

Share this post


Link to post
Share on other sites
Dadgad

Welcome to CADTutor. :)

 

I have not used CAD on a MAC, but the image may shed some light on your

situation. I have used the SYSVDLG command to access the variable dialog box,

which may or may not be available on a MAC.

mtextfixed.jpg

Share this post


Link to post
Share on other sites
Uomoviso

Thanks for your input, Dagdad. I've tested every configuration of both the MTEXTED and MTEXTFIXED variables to no avail. The text still rotates during editing.

 

One other note: this is only happening to drawings saved before today. New drawings to do not attract the same problem.

Share this post


Link to post
Share on other sites
Chris Broadway

I have noticed 1 other factor in this scenario that I fought for 2years before I figured it out. The Mleader was created while a certain linetype was being used, set linetype to continuous and fixed. Set mtextfixed to 2. I have only had this problem with mleaders though, not just a mtext.

Share this post


Link to post
Share on other sites
dspringer

I have the exact same problem that the original post describes. Have you found a solution?

 

I'm using AutoCAD Land Desktop 2009

Share this post


Link to post
Share on other sites
Chris Broadway

I have only encountered this problem while a linetype other than continuous was applied to the MTEXT or Mleader, If I changed the linetype in the properties it corrects the problem. I have my MTEXTED set to "internal" & MTEXTFIXED set to 2.

Share this post


Link to post
Share on other sites
dspringer

Chris thanks for your reply. I got excited and checked the mtext but there was no linetype applied. But just now I may have found a solution! While editing the text I clicked on the little button on the right for options and go down to "Editor Settings" and toggle on "Always Display as WYSIWYG" and now it is editing normally. I hope that solution sticks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×