Jump to content

Problem Textuing and/or UVW Mapping an Eyeball

Recommended Posts

Digital Gepetto

Greetings All,


I have been modeling non-characters for years and have just started venturing into making actors for stories and have run into a problem, so far only the one.


I would greatly appreciate anyone who can help me with this. I have been trying to solve this problem for 4 days already, a couple hours here, a couple hours there and its about to drive me NUTZ!


I have modeled an eye ball model for use in my characters (eyes for a face obviously). The modeling went smooth and perfect. I then tried to texture the previously mentioned modeled eye. And everything went perfect except the texture for the Pupil and Iris also shows up on the back of the eye ball which I need them not to do.


I have ended up with an eye ball with the front of the eye on the 'front' and the 'back' of the eye. I had a similar problem 12 years ago while I was making a Lego-man in college and this happened when placing his 'face' on his head (basically a cylinder). I just used a UVW Gizmo placed the map on it and then shrank it to fit.


This method isn't seeming to work here because I am trying to do the same thing on a sphere (Round Capsule) that I did on the Cylinder.


The Lego-man problem I messed with for about 8 days also but was using Max 4 or 5 at the time and just 'accidentally' fixed by messing with the buttons in the different roll-outs over and over. I can't seem to have the same dumb luck here.


I also wished to ask if anyone who can help me solve this boggle would know an alternate way of how to put one texture on the front of the sphere and a different one on the back? I'm trying to get rid of the white line on the textures on the separation between the front and back of the eyeball.


Thanks in advance,




attached are the texture files I am trying to use.


back of eye.jpg

Link to post
Share on other sites

It doesn't really matter if the texture shows up on the back side of the eyeball does it? No one will ever see it once it's stuck inside your characters head.


Anyway, there's a really simple way to apply 2 textures to the sphere so that the iris doesn't show up on the back side.


1. Create a sphere and convert to editable poly.

2. Select the top half of the poly's and set the material ID to 1

3. Select the bottom half of the poly's and set the material ID to 2

4. Create a Multi/Sub-Object material and stick your eyeball texture in material slot 1 and your backside texture in material slot 2

5. Apply a UVW Mapping modifier to the sphere, leave the Mapping type set to Planar and leave all the settings at their defaults

6. Apply the material to the sphere


You will probably have a problem with the textures, where they meet at the center of the sphere. So select the bottom row of poly's, closest to the center, that are in material ID 1 and switch them to material ID 2.


Hope that made sense. If not, post back and I'll try to explain a little better.


Here's the eyeball I created using your textures:


Link to post
Share on other sites

Like Rod say's you prob don't need to worry in this case as the pupil is hidden. There is an option though in the bitmap node to 'show map on back ', and if you really wanted to map both textures, the easiest way would be to use a falloff map set to Towards/Away.


Just tighten up the mix curve a little.

Link to post
Share on other sites
  • 2 months later...
Digital Gepetto

I am still having trouble with this. Yes the double faced eye ball is okay for modeling but I would like to have an eyeball with the iris and pupil only on the front side and the red on the back side. I was also trying to get an operating Iris and pupil as for them contracting and expanding slightly. I was using the original maps I provided but can't seem to get it to work. The more I try to figure it out the worse my results are. Can anyone please help me figure this out!

Link to post
Share on other sites

Did you try my suggestions?


Put a planar UWV map on your eyeball. Uncheck tiling and then untick 'show map on back'. Probably best not to use real world map size in this case.

Link to post
Share on other sites
Digital Gepetto



I have been trying this since before I posted the first entry on this post. I missed the uncheck tiling and untick 'show map on back' that you posted on entry #5, so I'm trying that now. I had no problem with the modeling portion of this endeavor but trying to map both textures on one object has been daunting to say the least. I expected to have a slight problem but the more I have worked at this the worst my results became.


What is the Falloff Map Set that you mentioned? Set to Towards/Away. How does one do this? Do you know of a tutorial out there on one of these blog sites or tutorial sites?


I think I have been humbled by this project slightly. Anyone can model an object or objects 7 ways from Sunday, but to truly be able to claim you know what your doing, you might need better mapping skills or at least an upgrade.


I can't believe I've had this much trouble with something I thought would be rather simple.

Link to post
Share on other sites
Digital Gepetto

To Sir Spittle,


I did as you instructed and it worked perfectly. I can not believe I didn't see those little boxes to check and uncheck and the resulting actions. I will be saving all my versions of all my eyes in every color variation and pattern, so that I will never have to do this again. This was a pain in the arse, to say the least. I thank you for your post, I do not know where I would be had it not been for your instructions. I thank you Sir.

Link to post
Share on other sites

No sir here mate. I was just writing a response. These may help:



The falloff gives a nice blend - can be control with the curve.




This uses two shaders so you can have much more control.



You could also use a blend material, with two shaders plugged in - with a falloff map in the blend mask slot.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...