Jump to content
rasnoland

Lagging, Slow, Jerky movemements of the pointer in Autocad

Recommended Posts

rasnoland

Hi

 

I have been having this issue with several versions of Autocad. At some point the application will start showing a lagging behavior when entering and existing commands. It completely blows my concentration and the productive flow away.

 

I have researched quite a lot on the net, and tried all the usual suspects: Disabling all CPU consuming features (cycle, dynamic inputs, properties palette, visual effects, etc). I have de-activated all the 3d performance settings. Disable "enable desktop composition" in Windows. All my graphic drivers are up to date. But nothing seems to work and the frustration start to be quite annoying.

 

Anyone managed to find a solution for this?

 

Your help will be super appreciated!

 

 

I am running AutocadCAD 2013 in W7 (64bits)

 

Ras

Share this post


Link to post
Share on other sites
Dadgad

Welcome to CADTutor. :)

 

Are you using ADAPTIVE DEGRADATION?

On the SYSTEM tab in your OPTIONS,

in the PERFORMANCE settings.

I believe the default is 5, but it can be set as high as 60.

 

What is your ISAVEPERCENT variable set to?

You sound savvy enough that it isn't that your SNAP setting (not O Snaps)

are enabled?

check your ISAVEPERCENT setting.JPG

Share this post


Link to post
Share on other sites
Organic

If you have some sort of antivirus on your computer, try disabling it and see if it fixes the issue.

Share this post


Link to post
Share on other sites
ReMark

Did you also kill off the CommCenter? It has been known to cause a system slow down.

 

Is hardware acceleration enabled?

Share this post


Link to post
Share on other sites
rasnoland

Thanks very much to all for your replies.

 

I seem to have found the cause. Strangely the massive slow down is caused by the command line window. As soon as I turn it off (ctrl 9) the problem goes away. Now I have another problem which is to work without command line, but at least this is not impairing productivity as the lagging was. There seems to be no much info regarding this bug (becasue bug it is). As I said I have been having this problem with different versions of Autocad and different computers, only I could work because the problem only becomes impairing when the file I am working on is big.

 

Dagdad: Adaptive degradation is on and set to 5, I will also change that. But I only works in 2D in autocad, and as far as I know this is only applied when working in 3D, right?

Organic: I have not tried to disable the antivirus, but even if it works, i dont think is a viable option, because working without antivirus would be a total suicide. Would you agree?

ReMark: Hardware acceleration is on, and I have dissabled Info centre, autocad 360 and so on in the registry.

 

My gut feeling is that this is related to windows. I have already tried to disable all visual effects but the problem is still there. Any ideas?

 

For now I will work with dynamic input, not that i like it that much, but at least i can work, because with the previous lagging it was totally impossible, specially when you are working with autocad all day long as I am doing now.

 

Best

Share this post


Link to post
Share on other sites
Dana W

Have you researched ways to speed up your computer in general? Almost everyone's computer boots up dozens of unneccesary processes and services that slow it down.

 

Have you looked at Windows task manager to see what is running with AutoCad that is hogging a lot of resources?

 

I think the command line being turned off is an incorrect assumption. It may be that turning off pretty much anything would speed it up.

 

Are there internet windows open while you are working?

 

When your drawings are pretty big? How big?

 

I have not tried to disable the antivirus, but even if it works, i dont think is a viable option, because working without antivirus would be a total suicide. Would you agree?
Does your virus software allow you to exclude certain programs from the Open/Access/real time scan options? How often does your email do an auto send/receive? How often does your AutoCad do an autosave?

 

If you have one of those free download virus programs that does not have any options, you may as well turn it off anyway.

Share this post


Link to post
Share on other sites
Dadgad

You failed to report what your ISAVEPERCENT system variable is set to?

Share this post


Link to post
Share on other sites
rasnoland
You failed to report what your ISAVEPERCENT system variable is set to?

 

yes, sorry I forgot. I had ISAVEPERCENT set to 50 (the default I believe). I changed that to 25, but I didnt notice any change in performance.. Also I have dissabled Adaptive degradation altogether, also without increase in performance (is this because i only draw in 2D?)

 

Have you researched ways to speed up your computer in general? Almost everyone's computer boots up dozens of unneccesary processes and services that slow it down.

 

Have you looked at Windows task manager to see what is running with AutoCad that is hogging a lot of resources?

 

I think the command line being turned off is an incorrect assumption. It may be that turning off pretty much anything would speed it up.

 

Are there internet windows open while you are working?

 

When your drawings are pretty big? How big?

 

Does your virus software allow you to exclude certain programs from the Open/Access/real time scan options? How often does your email do an auto send/receive? How often does your AutoCad do an autosave?

 

If you have one of those free download virus programs that does not have any options, you may as well turn it off anyway.

 

DanaW I will have a look at the system as you suggest and report back. What application do you use to streamline windows 7?

Share this post


Link to post
Share on other sites
ReMark

You have had this same problem in the past with different versions of AutoCAD? Are you saying that every version of AutoCAD you have used has this unusual bug? Seems rather far fetched. I don't believe it is a bug in the software. I believe either your computer hardware is at fault or it is operator induced error.

Share this post


Link to post
Share on other sites
rasnoland
You failed to report what your ISAVEPERCENT system variable is set to?

 

Have you researched ways to speed up your computer in general? Almost everyone's computer boots up dozens of unneccesary processes and services that slow it down.

 

Have you looked at Windows task manager to see what is running with AutoCad that is hogging a lot of resources?

 

I think the command line being turned off is an incorrect assumption. It may be that turning off pretty much anything would speed it up.

 

Are there internet windows open while you are working?

 

When your drawings are pretty big? How big?

 

Does your virus software allow you to exclude certain programs from the Open/Access/real time scan options? How often does your email do an auto send/receive? How often does your AutoCad do an autosave?

 

If you have one of those free download virus programs that does not have any options, you may as well turn it off anyway.

 

You have had this same problem in the past with different versions of AutoCAD? Are you saying that every version of AutoCAD you have used has this unusual bug? Seems rather far fetched. I don't believe it is a bug in the software. I believe either your computer hardware is at fault or it is operator induced error.

 

True true... i thought about that myself as well. Maybe due to the way I work with Autocad, or some software I use that dont go well with Autocad. The point is I had it with different computers, and that lagging and delay in response is an issue that happens to many people from what I can gather, plus.. why is works perfectly well without the command line. So far for me is a mistery.. I will keep trying things and reporting. Thanks!!

Share this post


Link to post
Share on other sites
ReMark

Re: hardware acceleration. Did you try disabling? Sometimes doing the opposite of what might be expected works too.

 

I've never used a version of AutoCAD that "lag" but then again I've always been lucky enough to have a hardware setup that exceeded AutoDesk recommendations. And "lag" is not a wide spread problem otherwise this and other forums would be overrun with questions regarding it.

 

What are the full specifications of your hardware setup? Important: How much RAM installed? What graphics card is installed and how much video RAM is on the card? What do you have for a hard drive (platter or SSD)?

 

What OS are you using and what version of the OS?

 

What other programs are running in the background? Ex. - MS Office, anti-virus program, browser, etc.?

 

Do you use any add-on programs in conjunction with AutoCAD? If so what are they?

 

Are you on a network or running standalone?

 

When was the last time you ran a virus scan?

Share this post


Link to post
Share on other sites
Dana W
DanaW I will have a look at the system as you suggest and report back. What application do you use to streamline windows 7?
Maybe we need to hold off on that one until we've eliminated the many things mentioned before being at fault.

 

One can do bodily harm to the OS when running the program msconfig which is the Microsoft app that can change your boot sequence, your startup sequence, and which programs are loaded at start-up. At least it has a reset button, but that can be sidestepped if one is a noob to it.

 

You can however, safely use your Windows run command to execute services.msc which is a safer, more foolproof version of msconfig in that it won't even let you see the essential services that will mess you up if disabled. Start with third party apps that you know you don't use. Write down whatever you disable so you can back out your changes, if needed.

Edited by Dana W

Share this post


Link to post
Share on other sites
RobDraw

I'm leaning towards inadequate vid card.

Share this post


Link to post
Share on other sites
guran

Do you have your command line docked? If not, try to dock it!

Share this post


Link to post
Share on other sites
ScribbleJ

Obviously this is an old thread but it came up during my search for a solution to the same issue. So I wanted to contribute here in case others were looking for a solution. I tried all of the suggested tips in this thread and others as well from a different source. Nothing worked. The cause was something I wouldn't have even thought unless I just starting taking a stab in the dark at it.

 

The lag wasn't a problem as long as I wasn't in the process of a command. There was no cursor lag during navigation commands such as zooming in and out, panning but as soon as I executed the line command lag started.

 

The thing that caused it for me was the Dyamic UCS. It can be controlled by the icon's at the bottom of the window or by pressing F6 to toggle it.

Edited by ScribbleJ

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...