Jump to content
j10photo

Lock autocad out of 3d modes

Recommended Posts

j10photo

This is seemly a basic function that I can not find, and is really frustrating.

 

I use autocad only as a 2d program. I never want to allow the program to orbit because it just lags and wastes time. When I move back and forth between sketchup and autocad I always accidentally hit alt when I pan, this kicking autocad in pinwheel hell.

 

I want to turn off all 3d in autocad, making a 2d program in "top" view. Is this possible?

 

I'm using autocad 2012, mac and pc

Share this post


Link to post
Share on other sites
ReMark

Just disable the Orbit command. You aren't "accidentally" invoking any other 3D commands are you?

 

Why did you buy AutoCAD for Mac (2D/3D) when you could have gotten Draftsight (strictly 2D) for Mac for free?

Share this post


Link to post
Share on other sites
j10photo

Our office uses autocad, I have no choice.

 

That works for the PC version, but not in mac.

 

I deleted both 3d orbit commands in CUI, but I can still trigger orbit with hotkeys.

 

Also, in the mac version I see no place where I can modify mouse behavior. What am I missing?

 

Thanks

Share this post


Link to post
Share on other sites
ReMark

As long as I have used full AutoCAD I've never accidentally hit the Alt key while panning. I think you're the first person I've come across mentioning this type of problem. Maybe a good key mapping program might do the trick.

Share this post


Link to post
Share on other sites
MSasu
Just disable the Orbit command.

Just like ReMark said, you may try to disable the command; just call UNDEFINE and enter the name of command you want disabled. To get it back call REDEFINE. May also attempt to remove from menu the trouble-maker hotkey trigger (although I’m not sure where is defined).

Share this post


Link to post
Share on other sites
Glen1980

I do it occasionally. Usually when really busy and trying to work faster than my hands (and probably brain) can handle! I always do it when trying to hold shift to select many pick points. It does cost me a couple of minutes between slow computer and fiddling about trying to get it back to the view I had (in 2d.)

Share this post


Link to post
Share on other sites
Tiger

I do it now and again. I did it more often when I switched from Autocad to Revit and back - the zoom/scroll/commands where different in the different programs.

 

It is extremely annoying when working with a larger file because like the OP says, it can shut down the drawing for a while.

 

In the CUI, have you tried changing the commands under the Mouse Buttons-section?

Share this post


Link to post
Share on other sites
tray262

I know this is super old but you undefine 3DORBITTRANSPARENT

Share this post


Link to post
Share on other sites
ReMark
I know this is super old but you undefine 3DORBITTRANSPARENT

Someone suggested the use of the UNDEFINE command in post #5.

Share this post


Link to post
Share on other sites
tray262
Someone suggested the use of the UNDEFINE command in post #5.

 

True,just the command name suggested above that was incorrect. 3dorbit wouldn't do the trick and most folks try disabling the command through the CUI.

 

More or less was just stating the proper command to undefine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×