Jump to content
hobkyl

Drawing vertical risers from a sloped line

Recommended Posts

hobkyl

I drew out a sloped vent line and have all my branch lines with 90s looking down, however when I go to draw that vertical riser from the fixture or underslab piping the riser kicks out at a funky angle.

 

I've drawn vertical lines by rotating the UCS and placed them on the 90, and it kicks them out of plumb.

 

I've used the add pipe feature, and it kicks them out of plumb.

 

I've set the slope to 0 and it still does it.

 

It has worked on a few, but the vast majority it doesn't.

 

What am I doing wrong?

Share this post


Link to post
Share on other sites
hobkyl

Noticing a lot of views on all the threads in MEP here but very few replies to the majority of the questions.

Share this post


Link to post
Share on other sites
tzframpton

Best thing to do is to not use the "Add Pipe" command to continue the pipe run. Instead, draw in your vertical pipes, then go to an elevated or 3D view and let AutoCAD MEP auto-connect the two together. When continuing pipe runs that are sloped or have very small angles, AutoCAD MEP sometimes doesn't know how to compensate back to what we consider a straightened run of pipe.

 

Noticing a lot of views on all the threads in MEP here but very few replies to the majority of the questions.
It was a bit late when the AutoCAD MEP (as well as all the other verticals) were added as sub-forums, since Revit has a major stronghold on the BIM and AEC industry. They are still great programs but these forums have become increasingly inactive as of late.

Share this post


Link to post
Share on other sites
hobkyl

I've tried that, I think if this is what you mean?

 

I rotate the UCS, draw a vertical pipe, rotate the ucs back and then move the vertical pipe to the fitting. As soon as I connect the two it kicks the pipe out, I am guessing because the fitting is at a very slight angle. I have fitting tolerance turned on, so not sure why it is doing this!:x

 

That's too bad, it seems that there is alot of traffic through here. I am stuck using MEP and the support for it is non existent!!!

Share this post


Link to post
Share on other sites
ReMark

"I am stuck using MEP and the support for it is non existent!"

 

Has that been your experience for the AutoCAD Discussion Groups as well?

Share this post


Link to post
Share on other sites
hobkyl

No, I've gotten some help here.

Share this post


Link to post
Share on other sites
ReMark

You know I was referring to the discussion groups over at the AutoDesk website right?

Share this post


Link to post
Share on other sites
tzframpton
I've tried that, I think if this is what you mean?

 

I rotate the UCS, draw a vertical pipe, rotate the ucs back and then move the vertical pipe to the fitting.

This is not how you create a "riser". The way you create a riser is you stay in Plan View, and start the Add Pipe command. Set the elevation and click once to place the starting location... now, simply change the elevation and click again. This is what creates a "riser" and AutoCAD MEP sees that. When you change the UCS, it confuses AutoCAD MEP objects. This is probably what's happening.

 

Alternatively, you can do this very easily in a 3D isometric view. When you start the Add Pipe command, notice at the command line the routing options. You can use "P" for Plane, which toggles the "UCS for MEP Objects". This will greatly increase your pipe routing efficiency. Give that a shot as well.

Share this post


Link to post
Share on other sites
hobkyl
You know I was referring to the discussion groups over at the AutoDesk website right?

 

I actually have not tried that, perhaps you are hinting that I should. Will do, thanks.

Share this post


Link to post
Share on other sites
hobkyl
This is not how you create a "riser". The way you create a riser is you stay in Plan View, and start the Add Pipe command. Set the elevation and click once to place the starting location... now, simply change the elevation and click again. This is what creates a "riser" and AutoCAD MEP sees that. When you change the UCS, it confuses AutoCAD MEP objects. This is probably what's happening.

 

Alternatively, you can do this very easily in a 3D isometric view. When you start the Add Pipe command, notice at the command line the routing options. You can use "P" for Plane, which toggles the "UCS for MEP Objects". This will greatly increase your pipe routing efficiency. Give that a shot as well.

 

I've tried that as well, it still routes the riser at an odd angle/the angle that the hub of the fitting is sitting at due to being attached to the sloped pipe.

Share this post


Link to post
Share on other sites
ReMark
I actually have not tried that, perhaps you are hinting that I should. Will do, thanks.

Just another alternative that's all. The more "eyes" on your problem the better your chances of receiving a response.

Share this post


Link to post
Share on other sites
tzframpton

By chance can you upload the file? Or copy/paste the offending objects into a blank file and uploading so I can take a look?

Share this post


Link to post
Share on other sites
hobkyl

I would love to, however am not being able to. Keep getting error that file is too big. Sitting at 1.02 MB currently.

Share this post


Link to post
Share on other sites
tzframpton
I would love to, however am not being able to. Keep getting error that file is too big. Sitting at 1.02 MB currently.
Use Dropbox!! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×