Jump to content
xenological

Full catalog not showing

Recommended Posts

xenological

I've been working on an Autocad piping project for a few days now, in Autocad MEP 2011. I've been using butt welded steel pipe and it was working perfectly fine until today. Today, when I started up Autocad, for some reason, when I tried to place pipe or fittings, there were only 5 or 6 different pipe types to choose from. A LOT less than usual. Additionally, almost all of the fittings and valves were missing, so I could no longer find the parts i needed for my project. However, the pipe, fittings, and valves I in the model earlier are still there, so I figure the program can't be having trouble accessing the model files, it must just be a problem with the catalog. What might be causing this problem and how can I fix it?

Share this post


Link to post
Share on other sites
tzframpton

Did you open the same project file, or a new file altogether? Did you by mistake open up vanilla AutoCAD profile instead of the AutoCAD MEP profile? Also, certain catalog items aren't "always there". They must exist in the drawing first, which is why you should always use the MEP Template file to start from at the very least.

Share this post


Link to post
Share on other sites
KeithBrown

I am just going to repost my response on the Autodesk forums since you also asked the question there.

 

"Are you using the correct routing preference? Sometimes MEP gets locked into an incorrect routing preference so it only shows the fittings for the incorrect routing preference. A way to double check and see if you still have the fittings is to use the pipefittingadd command and see if the fittings are there. Another way is to use one the pipe tools on the tool palette listed under By Routing Preference and choose a different routing preference. This will shake the property palette from its incorrect routing preference.

 

Please report back and let us know what you find so we can go from there."

Share this post


Link to post
Share on other sites
xenological

Okay, so let me clarify a few things, and also share my new findings. First of all, I'm using the same project file that I've been working on for the past two weeks. Up until yesterday it worked fine, but upon opening that same file yesterday and trying to insert new pipe into it, that was when i discovered most of the types were missing. To see how extensive the problem was, I tried starting a new drawing, and inserting pipe into it. Sure enough, I don't get the full catalog there either. I tried the pipefittingadd command. All it opened was that same window from which i can select pipe fittings, and the pipe fittings that were missing earlier are still missing.

 

In my struggle to get this thing working again yesterday I found a few other things. I was able to locate the folder on my computer containing what I'm pretty sure are the pipe files (C:\ProgramData\Autodesk\MEP 2011\enu\MEPContent). In this folder are three folders: Global, USI, and USM. When I'm using autocad, the only parts that show are the ones in the "global" folder. On exploring the folders I found that there is no steel pipe in the global\pipe folder, but there IS steel pipe in USM\pipe and in USI\pipe. Is there an easy way to make autocad use one the USM or USI folder instead of the global folder?? I think this might solve the problem

Share this post


Link to post
Share on other sites
KeithBrown

It looks like you started up autocad mep with the global option instead of the imperial option. the easiest way to fix it is to change your profile to "AutoCAD MEP (US Imperial)". Please note that you can tell MEP which profile to use when starting up by changing the options in the shortcut for AutoCAD MEP.

 

When MEP is installed it usually installs a global, imperial, and metric shortcut if you have selected those options during install. Sometimes people delete 2 of the 3 icons and delete the wrong one. Changing your profile to the imperial one should fix the problem but if your shortcut is specifying the global profile then the next time you start MEP it will load up with the global profile.

Share this post


Link to post
Share on other sites
xenological

Ahhh that explains it! I started up autocad from the imperial shortcut and loaded my file from there instead of just opening my file directly, and all the pipe pieces I need are back! I'm not sure why my file had started opening with global by default when opening it used to just launch it with imperial, but oh well, my problem is solved. Thanks very much!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...