Jump to content
MorgaineDax

UCS and Modelspace Viewport Problems

Recommended Posts

MorgaineDax

So we do a lot of 3D coordination using AutoCAD and Fabrication, and since we upgraded to 2015, we've been having a lot of issues with viewports and the UCS.

 

We all typically have at 3 viewports in modelspace. One big one for the plan view, one front view, and a side view. We change them a lot on the fly depending on what we need to see. For example, we'll place a line of ductwork in the plan view and then switch over to one of the side or front views to check clearances between services and adjust accordingly.

 

However, now the viewports keep changing their UCS and we don't know how to fix it. So we'll set a view port to plan view, go to the front view, and not be able to move or dimension anything properly because the UCS looks like it's matching the plan view? Instead of having Y pointing "up" and x pointing "right" in every viewport, the UCS in every viewport will relate to the last view you set.

 

We're assuming it's some variable that didn't get carried over in the upgrade, but no one can figure out how to get it back to the way we usually draft.

 

Don't know if this is the proper forum, but please help? :)

Share this post


Link to post
Share on other sites
Dadgad

Check out this snippet from the SYSVDLG regarding UCSVP, might be the variable you are after.

NOTE that it is VIEWPORT SPECIFIC. I hope that helps you.

 

Or might you just want to set your UCSFOLLOW variable to 1?

 

It is always a good idea to keep a current .SVF (System Variable File) for safe keeping.

To create one, at the bottom of the SYSVDLG box, choose SAVE ALL, as insurance against just

such an inevitability, a system crash or other CADastrophy.

In that way it is very easy to load, or restore your personal preferences on any machine.

UCSVP perhaps.jpg

ucs follow settings.jpg

do yourself a favor sysvar file.jpg

Edited by Dadgad

Share this post


Link to post
Share on other sites
ReMark

Could it be that the Dynamic UCS feature is enabled?

Share this post


Link to post
Share on other sites
Spaj

Maybe try UCSFOLLOW 1 > UCS W > UCSFOLLOW 0

Share this post


Link to post
Share on other sites
MorgaineDax
Check out this snippet from the SYSVDLG regarding UCSVP, might be the variable you are after.

NOTE that it is VIEWPORT SPECIFIC. I hope that helps you.

 

I think this fixed it on my workstation; I'll see if it works for everyone else in the office. Thanks!

Share this post


Link to post
Share on other sites
MorgaineDax
I think this fixed it on my workstation; I'll see if it works for everyone else in the office. Thanks!

 

Nope, that fixes it somewhat, but there's another bug that keeps popping up now. You'll be working fine in multiple viewports for a while, but eventually the other UCSs in the other VPs will grey themselves out and when you switch over to work in a different viewport, you won't be able to annotate and move objects properly.

 

You can use the view controls in the locked VP to get the UCS unlocked, but then it locks the other ones. So I'll work in top view for a while and it'll be fine. But then I move to a front view and I'll only be able to move or draw side to side, but not up or down.

Share this post


Link to post
Share on other sites
Dadgad
Nope, that fixes it somewhat, but there's another bug that keeps popping up now. You'll be working fine in multiple viewports for a while, but eventually the other UCSs in the other VPs will grey themselves out and when you switch over to work in a different viewport, you won't be able to annotate and move objects properly.

 

You can use the view controls in the locked VP to get the UCS unlocked, but then it locks the other ones. So I'll work in top view for a while and it'll be fine. But then I move to a front view and I'll only be able to move or draw side to side, but not up or down.

 

Sorry to hear that didn't fix it for you. Did you remember to enter an appropriate value, in each of the viewports, as opposed to just once,

assuming that the setting would be global?

Share this post


Link to post
Share on other sites
MorgaineDax
Sorry to hear that didn't fix it for you. Did you remember to enter an appropriate value, in each of the viewports, as opposed to just once,

assuming that the setting would be global?

 

I definitely remembered that! Which did fix the issues for the UCS flipping around and changing to Z,X or Z,Y in relation to the first VP. I'm just not sure if this "greyed out" new problem is related or a separate bug or variable problem.

Share this post


Link to post
Share on other sites
Dadgad
I definitely remembered that! Which did fix the issues for the UCS flipping around and changing to Z,X or Z,Y in relation to the first VP. I'm just not sure if this "greyed out" new problem is related or a separate bug or variable problem.

 

Might there be another computer available, which is operating as you would like it to, upon which you could

save an .svf (system variable file), so that you can apply those settings to one of the computers

which is misbehaving, as a test?

Share this post


Link to post
Share on other sites
tonyj

I had a similar problem before and as far as I remember 'UCSORTHO' set to '1' fixed it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...