Jump to content
Valiance

Problem with OSNAP to tangent

Recommended Posts

Valiance

Hi, I'm having a problem with OSNAP and am not sure what I'm doing wrong. As you can see from the attached photo, I am using offset to create a parallel line to the one selected (the leftmost line) that I am trying to place tangent to the circle in the center. However, the tangent snap points (which should be visible in the picture) aren't working properly and cause the line to snap to a position inside the circle rather than tangent to it.

 

My command process is offset -> through -> select line -> select TAN onsnap option -> hover over circle near desired tangent point.

 

Any help would be appreciated. Thanks!

 

Screenshot 2014-09-10 18.29.44.jpg

Share this post


Link to post
Share on other sites
Valiance

I figured out a different way to do this by creating a perpendicular line from the original line to the center of the circle to find the snap point for the offset line, which solves the immediate problem, but I would still appreciate advice on what I was doing wrong with the tangent feature or if the program doesn't allow me to use offset and tangent in that manner

Share this post


Link to post
Share on other sites
dan20047

not sure if this answers the question, but two options:

set UCS to line, use Quadrant snap on circle

 

or

 

draw XLINE and use tangent snap on two circles to hit the one spot that works (there are really 4 possible tangent lines between any two circles)

 

Dan

Share this post


Link to post
Share on other sites
eldon

Sometimes the OSNAPS don't work as you want them to.

 

For example, if you break your target circle, so that it becomes an arc, then you could use the Perpendicular osnap to offset through.

 

Curiously, that technique does not work to a circle.

Share this post


Link to post
Share on other sites
steven-g

Try using the perpendicular OSNAP picking the line first and then the circle (also perp). I only did a quick test but it worked on a sample I tried

Share this post


Link to post
Share on other sites
RobDraw

AutoCAD is finding a tangent point in relation to some point on the original line. I'm guessing it is the point where you picked the line. There isn't a way to tell AutoCAD that you want the copy of your line to be tangent to the circle. As you figured out, a little simple geometry solves it for you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...