Jump to content
wing

Copy lines and arcs without extra information

Recommended Posts

wing

When I copy a line or arcs and paste to original coordinates. It seems to have "brought" with it all the extra dimstyle, line style, text styles, layers, etc. of which I cannot purge despite I set all layers to 0, select by layer and standard for text style. I've already purge a few times and set all linetypes to continuous.

 

How do I only have the cleanest possible line or arc in Autocad without all those "extra stuff"? It's driving me nuts!

Share this post


Link to post
Share on other sites
nestly

When copy/pasting an object, it's expected the the properties of the object are also copied (Layer, Linetype, etc). Unfortunately AutoCAD also unexpectedly copies "Current" settings from the source drawing that are unrelated to the objects being copied (current layer, current MLine Style, Current Dimstyle etc... which subsequently import any Text Styles that are associated with the Dimstyle) Annoying.... but I don't think there's a solution.

 

If you can't purge them, it's likely because they're either in use, or are set "Current"

Share this post


Link to post
Share on other sites
wing
When copy/pasting an object, it's expected the the properties of the object are also copied (Layer, Linetype, etc). Unfortunately AutoCAD also unexpectedly copies "Current" settings from the source drawing that are unrelated to the objects being copied (current layer, current MLine Style, Current Dimstyle etc... which subsequently import any Text Styles that are associated with the Dimstyle) Annoying.... but I don't think there's a solution.

 

If you can't purge them, it's likely because they're either in use, or are set "Current"

 

Thanks for your reply. I can confirm that the text styles are not in use, since there are no text only lines and arcs. As for as line style goes, all are set to by layer and continuous in layer manager.

 

To give people some background, the file was originally huge with lots of different object types like blocks and hatches. But I "quick select" only lines and arcs and deleted the rest.

 

What I don't understand is, (for the purpose of testing) how copying a single line, yes one single line, set on layer 0 with all settings "by layer", and layer then set to continuous, default lineweight, to a pristine new dwg with no template (as default as it can be), "brings" in 7megabytes worth of extra linetypes and text styles?

 

As a workaround, I imported the linework into LISCAD and then re-exported it. But obviously this is not an ideal solution.

 

I also tried CHECKSTANDARDS but it is a lot of clicking to fix. Tens of thousands worth when checked using the batch dwg checking program.

Share this post


Link to post
Share on other sites
ReMark

It can happen if the drawing the line you are copying from was, at one time or another, edited in Microstation.

 

Simple to check. Open your linetypes window. Any of them have the letters DGN included as part of the linetype name?

 

Read this.

 

http://knowledge.autodesk.com/support/autocad/downloads/caas/downloads/content/autocad-C2-AE-dgn-hotfix.html

Share this post


Link to post
Share on other sites
SLW210

Can you post a .dwg?

 

For AutoCAD 2015, you just need to PURGE, no hotfix is needed. http://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/AutoCAD-DWG-files-unexpectedly-increase-in-file-size.html?v=2014

 

Could these be Civil 3D objects and not AutoCAD lines, it should ALL Purge out if not Set Current or in use, I just checked on mine and everything not in use purges.

 

Are you using -PURGE (Hyphen in front)?

Share this post


Link to post
Share on other sites
BIGAL

Wblock and make sure Map info No

Share this post


Link to post
Share on other sites
wing
Can you post a .dwg?

 

For AutoCAD 2015, you just need to PURGE, no hotfix is needed. http://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/AutoCAD-DWG-files-unexpectedly-increase-in-file-size.html?v=2014

 

Could these be Civil 3D objects and not AutoCAD lines, it should ALL Purge out if not Set Current or in use, I just checked on mine and everything not in use purges.

 

Are you using -PURGE (Hyphen in front)?

No. I am using the command PURGE without the hyphen prefix. I have attached it to dropbox since it is too big. It's only one line.

https://www.dropbox.com/s/l7fs6bg0w2x6xdf/Drawing1.zip?dl=0

Share this post


Link to post
Share on other sites
SLW210

I can't access dropbox at work, perhaps someone else will be able to look at your drawing.

 

Did you try the instructions at the link I provided?

 

Did you try -PURGE?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...