Jump to content
Bobzy20

Export a DGN to DWG (Keeping the Scale)

Recommended Posts

Bobzy20

When I export a DGN file to DWG in MicroStation and then open it up in AutoCAD, it loads fine but the scale is completely out.

 

Is there a way within MicroStation to export but keep the scale correct?

 

Also I notice in the converted DWG Paperspace layout it doesn’t have a viewport, I guess this is the way MicroStation works?

 

Also I tried using the DGNIMPORT command in AutoCAD 2012 & 2015 and all I get is this error:

FATAL ERROR: Unhandled Access Violation Writing 0x0058 Exception at d9985e01h

 

Thanks

 

Bob

Edited by Bobzy20

Share this post


Link to post
Share on other sites
caddcop

Can you explain in more detail what you mean by the "scale is completely out"?

Annotation Scale is very different in these two programs so Bentley does not support it everywhere which could be your problem.

The other issue is units. In MicroStation, they support Master Units and Sub-units. So you can use Feet and Inches, Decimal Feet and Fractional Feet and Inches in the same file. In AutoCAD, if you want Architectural units, the file is actually stored in inches.

When you use the Export or Save As tool to create a DWG file, there is an extra button on the dialog box for Options for the save. In it, you can customize the units for conversion and also remap many other things. It even includes a way to use Excel to setup mapping tables for things like: level name to layer name, linestyle to linetype, and more. I believe it also supports Font Substitution, the ability to filter some of the remapping by display attributes. So if you had some red and green elements on one level, you can push them to two different layers in AutoCAD.

It's very easy to overlook the button and not realize its capabilities within the conversion.

Share this post


Link to post
Share on other sites
Bobzy20

Thanks for your reply.

 

I didn't even know you could save as a DWG!

 

I have been playing around with Micro Station more and more and the whole scale issue isn't as bad as I thought it was. Once I open the converted DWG in AutoCAD I can simply scale the drawing back to its original size. I did have a look at the options button but I couldn’t see anything to do with units?

 

I know you can set the units in AutoCAD when importing a DGN but if I try and import the main DGN file AutoCAD crashes. I’m thinking because the main DGN file uses reference files (XREFS) when it loads so AutoCAD just doesn’t know what to do and bombs out. Maybe there is a way to save the DGN file in Micro Station and Bind all the reference files together and then try importing into AutoCAD.

Share this post


Link to post
Share on other sites
ttray33y
Thanks for your reply.

 

I didn't even know you could save as a DWG!

 

I have been playing around with Micro Station more and more and the whole scale issue isn't as bad as I thought it was. Once I open the converted DWG in AutoCAD I can simply scale the drawing back to its original size. I did have a look at the options button but I couldn’t see anything to do with units?

 

I know you can set the units in AutoCAD when importing a DGN but if I try and import the main DGN file AutoCAD crashes. I’m thinking because the main DGN file uses reference files (XREFS) when it loads so AutoCAD just doesn’t know what to do and bombs out. Maybe there is a way to save the DGN file in Micro Station and Bind all the reference files together and then try importing into AutoCAD.

 

I need a sample file, also what is the correct unit your are using? (Imperial or Metric)

Please do check your unit by openning your DWG file via Microstation, then in microstation go to > Settings > Design File > Working Unit > look for the resolution and see if what Mu is currently using.

but a sample file will be much appreciated.

Share this post


Link to post
Share on other sites
Bobzy20

Thanks for all your replies.

 

I have managed to work with the DGN files more and more over the last few months and its no longer an issue.

 

Thanks again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...