Jump to content
Hydroman

Exported Leapfrog mesh to a solid

Recommended Posts

Hydroman

Hi guys,

 

I am new in this forum....and desperate. I have to run some tricky simulations on a software named Comsol. However, Comsol use Parasolid and IGES files. If these are not solids, it has to be a mesh, but if the mesh is not watertight, it crashes and cannot generate the solids.

 

The meshes are coming from a client with software named Leapfrog and Vulcans. These are geology oriented softwares as my problems is related to geology. During the export process to a dxf, some faces looks to disconnect to the mesh. So I am trying to repair the mesh with autocad and/or 3DS max and to create the solid, to finally export to a IGS format.

 

Howerver, I tried several commands in Autocad (I am not an experienced user, but a good 3D interface user of other software), to repair the mesh, and then create the solids....but no success.

 

My problem is that the mesh are far to be primitive. These are very random shapes, based on geology.

 

Is there a way to repair a mesh ? Consider that each mesh has 30 000 faces and I do have 15 meshes to convert....

 

Hope someone could help me.

 

Tks

Share this post


Link to post
Share on other sites
Cad64

During the export process to a dxf, some faces looks to disconnect to the mesh. So I am trying to repair the mesh with autocad and/or 3DS max and to create the solid, to finally export to a IGS format.

 

This is dead simple to do in 3ds Max. Simply switch to "Border" selection mode, Window select the entire object to select all open holes, then hit the "Cap" button to seal the mesh. Then delete the disconnected faces, export to IGS format and you're done. The only problem you might run into is if there are spots where you have 2 or more adjacent faces that are missing. In that case you would need to rebuild the geometry manually, but again, that's a pretty simple thing to do.

 

A better option might be to switch to "Vertex" selection mode, Window select the entire object to select all vertices and then hit the "Weld" button. This will work, assuming all the polygon faces are just disconnected, not missing. If the faces are missing then my previous suggestion would be the one to use.

Share this post


Link to post
Share on other sites
Hydroman

Thanks for answering Cad64,

 

However, I tried but nothing moved.....

 

I exported to IGS and the file is empty, so I suppose it is not working. Would you like to get the file for a quick crosscheck ?

 

Hydroman

Share this post


Link to post
Share on other sites
Cad64

If you can post it here, or put it up on Dropbox, I'll take a look.

Share this post


Link to post
Share on other sites
Cad64

I imported your dxf file into Studio Max and ran some tests on the mesh. If you go to the "Views" menu "xView" you can check for things like open edges, overlapping vertices, etc. I didn't find any trouble with those, but I did find that you have 7 overlapping faces which are shown as green in the screenshot below. You will need to fix those and then you should be able to export to IGS.

 

Also, when I imported the dxf, in the Import Options, I chose to "Weld Nearby Vertices" with a Weld Threshold of 0.03". After the object imported, it was completely black which means the polygons are inverted. So I selected the object and converted it to Editable Poly. Then I switched to Polygon selection mode, window selected the entire object and clicked the "Flip" button. Once all that was done, then I ran the xView tests I mentioned previously.

 

Hope that helps.

Overlapping Faces.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×