Jump to content
daveyboyd

Editable mesh not showing . . .

Recommended Posts

daveyboyd

Hi,

 

I have created a 3D image of a bridge in AutoCAD 2014 using 3D Solids, Surface Networks/Lofts and Mesh. When I import this into 3DS I am unable to assign materials to some of the surfaces. Its like they are hidden. I can select the polygon but cant apply materials. This is very random as some of the surfaces are fine and they have been created in exactly the same way in AutoCAD. Is there a way of making these surfaces 'live' for want of a better word ??

 

Thanks

 

Dave

 

Plymouth.max

Share this post


Link to post
Share on other sites
Cad64

Can you post some screenshots of the parts where you can't assign materials? I have opened your model but I'm not having any trouble assigning materials.

Share this post


Link to post
Share on other sites
daveyboyd

Here you go...

 

The first shows the polygon on layer 3D ROAD selected, I assign a material to it but it doesn't show

 

The second shows the polygon with a material assigned to it (note the embankment surface is also not showing even though all the other embankment surfaces are??)

 

Slide1.jpg

 

Slide2.jpg

Share this post


Link to post
Share on other sites
Cad64

Sorry but I don't know what's wrong. Everything works fine on my end. If I have time later I'll try to investigate further but right now I have a deadline to meet. Hopefully someone else will come along with some advice or you will figure it out on your own before I get back to it though.

Share this post


Link to post
Share on other sites
daveyboyd

Ok, no problems, I'll see if I can sus it out my end. Thanks for helping out

Share this post


Link to post
Share on other sites
daveyboyd

SOLVED: (sort of) I deleted the original surface and created a new mesh in the AutoCAD model, imported it in and voila it appears! Not sure why it didn't like the first one but all good, thanks again anyway :)

Share this post


Link to post
Share on other sites
lrm

It seems to work ok for me. I opened the file in 3ds Max 2016, selected all with a big select window. Assigned an orange material then clicked Assign Material to Selected. I then defined other materials an assigned them a color. I experimented with surface normals but that did not seems to be a problem.

Roads.PNG

Share this post


Link to post
Share on other sites
daveyboyd

No, thought I'd worked it out but its still happening. The polygons are there but they only show up in a Hidden Line viewport. I cant apply any materials to them, its a mystery. Going to try and make a solid out of the mesh and see if that works . . .

Share this post


Link to post
Share on other sites
daveyboyd

Ahaa! I worked out that I have to apply a 'NORMAL' modifier and flip it, god knows why but it works!!

Share this post


Link to post
Share on other sites
Cad64

I think I know what's happening. If you select the object, 3D Road, then right click and choose "Object Properties", I'm guessing you probably have "Backface Cull" enabled. When Backface Cull is enabled, polygons are invisible when viewed from the back side. If you disable it, you will be able to see polygons from both sides. I always have mine disabled which is why I was able to see everything when I opened your file. It's good that you flipped the polygons though. It's important for them to face the correct direction.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...