Jump to content
pefi

Attribute tag uses capital letters - how to change it?

Recommended Posts

pefi

AutoCAD LT 2016

 

- type att

- type test_attribute as the attribute tag

- place it

- the attribute has name TEST_ATTRIBUTE

 

is there a setting that controls that behavior? I don't want to use capital letters. I can change it in Properties, but that's a workaroud.

Share this post


Link to post
Share on other sites
ReMark

You can't change it via BATTMAN?

Share this post


Link to post
Share on other sites
pefi

I didn't try battman, but I can do it in Properties. It's annoying that I type small letters and -*boom*- they are capitals - I want to change that.

 

Same happens after I double click attribute to edit it.

Share this post


Link to post
Share on other sites
ReMark

Please attach a drawing with a copy of the block in it. Thank you.

Share this post


Link to post
Share on other sites
steven-g
Lord, grant me the strength to accept the things I cannot change,

the courage to change the things I can,

and the wisdom to know the difference.

I think this case falls into the category of wisdom, this is just how the program works. Though as you have discovered a bit of courage helps.

Share this post


Link to post
Share on other sites
pefi

@ReMark:

1. Open blank drawing

2. type att

3. type tag as tag

4. Place the attribute - it will be TAG, not tag

 

Does it behave differently for you?

 

@steven-g: I'm from the linux/open source world, so I'm used to changing anything down to single bits in the system kernel. However it's windows/autocad, so I'm going to bend my neck and accept the reality if that how the designers of autocad decided (*)

 

(*) unless there is a setting to change it! :-D

 

I'll get full autocad in a next few days - I'll be back to post an update if something changes.

Share this post


Link to post
Share on other sites
pefi

AutoCAD 2015 does the same thing. I'll have to be happy with the capitals (I'm working on excel to autocad link, so attributes have to match some fields in excel spreadsheet)

Share this post


Link to post
Share on other sites
ReMark

Why does it matter? Once it is part of a block then it will change anyway.

Share this post


Link to post
Share on other sites
pefi

I wanted to avoid potential problems if string comparison or other string manipulation functions in VBA are case sensitive. Anyway I have all capitals in the excel spreadsheet now.

Share this post


Link to post
Share on other sites
ReMark

It's how the feature was designed to work. If you have a problem with it then you'll have to take it up with the programmers at AutoDesk. Maybe they weren't as forward thinking as you expected them to be.

Share this post


Link to post
Share on other sites
pefi

Thanks for the info! I think in this case it's easier to change my habits instead of writing a workaround. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×