Jump to content
KRoCAD

Extremely long file opening and plot times Civil 3D 2013

Recommended Posts

KRoCAD

I've been having extremely long file opening and plot times for some projects at my company that we use AutoCAD Civil 3D 2013 on (three projects in particular). My computer specs are above the recommended specs for AutoCAD so I know my computer is not the issue. All files are opened and saved on a local server. The times range from 10 to 20 minutes per file, depending on the project. Some brief descriptions of the file management for each project:

 

Project 1: About 20 xrefs per file, -pu regapps performed on all xrefs (most from other firms), no data references used.

 

Project 2: About 30-40 xrefs per file, -pu regapps & audit performed on all xrefs (most from other firms), no data references used, some other settings used to help improve performance (indexctl=3, demandload=3, xloadctl=2, treedepth=32767, treemax=10000000). Note that many xrefs originate from dgn.

 

Project 3: About 30 xrefs per file, -pu regapps & audit performed on all xrefs (most from other firms), data references ARE used, some other settings used to help improve performance (indexctl=3, demandload=3, xloadctl=2, treedepth=32767, treemax=10000000). Note the xrefs are dwg files that we used DGNIMPORT to import linework from dgn files.

 

Project 1 has the longest wait times averaging around 15-20 minutes per file. Project 2 and 3 have similar wait times around 10-15 minutes per file.

 

Are there any settings I could change to improve the opening times on these files? Any settings I can use for the Sheet Set Manager to keep common xrefs open between the sheets it's trying to plot?

 

Also, when saving xrefs after purging regapps for Projects 1 and 2, file size can jump from

 

Any and all help is appreciated! Thanks for reading.

Share this post


Link to post
Share on other sites
ReMark

Do you suspect that there might be bloat as a result of the presence of numerous DGN linetypes?

 

What steps have you taken so far to reduce the file size?

Share this post


Link to post
Share on other sites
KRoCAD

For Project 1 it's unlikely. I just purged regapps in all basefiles for Project 1 and a lot of my file sizes have doubled or tripled in size. I haven't tried it yet, but I was going to try the DXFOUT/IN method talked about in this thread: http://www.cadtutor.net/forum/showthread.php?74740-AutoCAD-2013-Increasing-File-Sizes/page7. It's possible a handful of the 130 total basefiles we have came from DGN files, but I wouldn't have a clue as to narrow down which ones they are. Do DGN linetypes carry over to other files once they are referenced (like regapps)?

 

For Projects 2 and 3 it's likely. Most basefiles for these projects originate from Microstation dgn files. Purging regapps was my savior for Project 2, as when I first implemented it, open times reduced from 10 minutes to 3 minutes. It's not having that same effect now, so I suspect there is something else going on there. Purging regapps, auditing, and running a regular purge, along with the few settings I wrote in my first post are the things I've tried for these files.

Share this post


Link to post
Share on other sites
KRoCAD

It's unlikely for project 1. There may be a couple of basefiles from the 130 total basefiles that may have come from DGN, but I wouldn't know how to narrow them down to figure out which ones they would be. Most of these basefiles were "handed off" to us at some stage during design from another firm. All the clean up I've done on these files is purging regapps. It's helped some files, but has as much as tripled file size for others.

 

It's likely for projects 2 and 3. Most basefiles originated from DGN. Purging regapps, auditing, and running a regular purge used to help significantly with project 2 (reducing open time from 10 to 3 minutes), but that doesn't have the same effect anymore so I suspect there is something else going on. Exporting to 2010 has helped with some files, but we can't do this on a lot of our basefiles because all Civil 3D objects are exploded to 2D linework which causes more issues than it solves.

 

I haven't tried it yet, but when I get a chance I will be trying the DXFOUT/IN method you recommended in a similar thread.

Share this post


Link to post
Share on other sites
ReMark

Typically I recommend the following sequence be run twice when attempting to reduce the file size of a drawing.

 

1. Overkill

2. -Purge (note the dash as it must be included to run the command line version)> purge Regapps only

3. -Purge > purge ALL

4. Audit > respond "Yes" to fixing any errors that are found.

 

If the two iterations fail to remarkably reduce the file size then one can try the old WBLOCK trick which I'm sure you are familiar with.

 

I don't recall suggesting DXFOUT/IN but maybe I threw that in as an option of last resort somewhere along the line. My memory is fuzzy on that one.

Share this post


Link to post
Share on other sites
KRoCAD

The overkill, purging, and audit went from 1.6mb to 1.5mb. WBLOCK reduced from 1.5mb to 111kb, but when I open the wblock file and save it, it jumps back up to the 1.5mb file size. Is there some kind of setting I may have in AutoCAD that adds data to files that I save? All file versions I've been using are 2013.

 

The DXFOUT/IN thread is over three years old, so no surprise you don't remember that one.

Share this post


Link to post
Share on other sites
ReMark

We would need a copy of the .dwg file in order to troubleshoot the problem further.

Share this post


Link to post
Share on other sites
ReMark

Here is your drawing back. File size is approximately 141KB. Saved in AutoCAD 2010 file format. Tested twice by opening and saving each time.

 

Project_1 Basefile CLEAN.dwg

Share this post


Link to post
Share on other sites
KRoCAD

Thanks for looking at that. It looks like the same thing happens when I open and save this file as 2013. The file size jumps back up to 1.5mb. Do you know if there is data being added to the file when saving from 2010 to 2013? WBLOCKing to 2010 will be fine for my 2D files that don't have Civil 3D objects (I would just need duplicate files - one for editing and one for WBLOCKing/XREFing). Do you have any advice on what to do with 2013 files that have Civil 3D objects like surfaces, alignments, pipe networks, etc? It's seems like a hassle having to WBLOCK this stuff out every time I make a change in my basefiles.

 

Thanks again for your help!

Share this post


Link to post
Share on other sites
ReMark

I'm suffering from question overload.

 

First let me see what happens if I save the 2010 drawing as a 2013 file type. Hold on 90 seconds. I'll be back.

 

Good news, at least for me. The file size DROPPED to 113KB. I have no idea why the file I gave you, when saved in 2013 file format, went from 141KB to 1.5MB. The problem is definitely on your end. I cannot test this on Civil 3D as I do not have access to the program.

Edited by ReMark

Share this post


Link to post
Share on other sites
KRoCAD

Not the answer I hoped for, but the answer I needed. Thanks for your help ReMark!

 

If anyone else has run into this issue and has suggestions, I'm all ears...

Share this post


Link to post
Share on other sites
ReMark

You and your co-workers will have to troubleshoot the problem on your end unless someone here who also uses Civil 3D volunteers to test out your drawing.

Share this post


Link to post
Share on other sites
KRoCAD

Yeah, that will be the game plan when we have some down time. There are at least two other drafters that have the same result as I do with saving back to 2013. We may end up switching our file setup to use 2010 regular AutoCAD unless Civil 3D objects are needed. More groundwork needs to be done first though.

Share this post


Link to post
Share on other sites
ReMark

Troubleshooting will require a plan of attack. Start by writing one up with the input of your coworker's. Be methodical in your approach and you should be successful.

Share this post


Link to post
Share on other sites
BIGAL

There was a program posted by Autodesk on their website to clean "Orphaned linetypes" when importing dgn's but it did not work for me with 2013 we have 2016 now which has Purge orphaned linetypes so fixes that problem.

 

If I can remember will try with 2013 Civ3d at home tonight rather than the 2016 we are on here.

Share this post


Link to post
Share on other sites
KRoCAD

For kicks, I tried WBLOCKing and saving the file I shared to 2010 using AutoCAD 2014 (not Civil 3D). I got similar results as you ReMark, with the file size at about 222kb in 2013 DWG format. I'm thinking the AutoCAD Civil 3D program adds extra data to DWG files.

 

BIGAL, after doing a bit of research it looks like the orphaned linetype command was introduced in 2015. The Autodesk DGN hotfix is what I'll likely need to do since I'm running an earlier version.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...