Jump to content
Murphy625

Strange Behavior or Bad Setting?

Recommended Posts

Murphy625

Hi Folks,

I'm using Autocad 2012 and just ran into a problem in my drawing.

I will describe the symptoms:

 

*My USC icon at the bottom left of the screen doesn't look right. Its just X and Y and 2 lines without any arrows.

 

*Trying to draw a 2 x 2 square box.. The box will look square on the screen as I draw it but the dimensions being shown will not match.. One side will say 2 inches while the other side says some crazy number like 9 inches or something.

 

Its almost as if my viewport and my USC are in two different worlds but I don't think I've done anything to cause it.

 

What setting tells autocad to keep the USC with the viewport?

 

More info: My lines in the Y direction don't match with the length displayed but if I draw it then go to measure, the measurement will be correct..

Edited by Murphy625
additional info:

Share this post


Link to post
Share on other sites
Murphy625

I just figured out that if I go to another location in my drawing, it works fine. But if I try to draw something within the structure I've already drawn, it doesn't work. Huh?

Share this post


Link to post
Share on other sites
ReMark

Would this be a 3D drawing by any chance?

Share this post


Link to post
Share on other sites
Murphy625
Would this be a 3D drawing by any chance?

 

Yes.. all 3d solids..

Share this post


Link to post
Share on other sites
ReMark

From your description of the UCS icon wouldn't that mean you are using a 2Dwireframe visual style? The icon is white in color? Have you tried this?

 

"At the command line, type "UCS" then choose the "World" option. Next type "Plan" and choose "World".

Share this post


Link to post
Share on other sites
Murphy625
From your description of the UCS icon wouldn't that mean you are using a 2Dwireframe visual style? The icon is white in color? Have you tried this?

 

"At the command line, type "UCS" then choose the "World" option. Next type "Plan" and choose "World".

 

I am using 2d wireframe.. My screen background is white so my UCS (x,y) indicator is black.

 

Tried the USC>>World and then Plan>>World and no difference. My UCS icon doesn't look right.. its just two lines like an L.. no z indicated, no arrows, nothing.

 

When I draw what looks like a square box on the screen, the X and Y are not even close. X is at 2 inches, Y is at 16 inches.

 

Just noticed something.. This problem has something to do with an object I drew into the drawing. My project sits on a sloping hill and so I drew in the ground plane to help me visualize the slope that goes from east to west. From north to south its flat. If I'm looking at my slope from the east and I try to draw something within the area that represents the slope, that's when ACAD does the funny stuff. If I try to draw a cube outside of that inserted block, everything works fine. My UCS coordinate still looks funky though. I've never encountered this before.

Share this post


Link to post
Share on other sites
ReMark

You've skewed the UCS to match your ground plane that's why it looks odd from a top view.

 

Can't you reorient your UCS so it lines up with the object on the hill?

 

UCS = User Coordinate System

Edited by ReMark

Share this post


Link to post
Share on other sites
Murphy625
You've skewed the UCS to match your ground plane that's why it looks odd from a top view.

 

Can't you reorient your UCS so it lines up with the object on the hill?

 

UCS = User Coordinate System

 

Its only giving me problems when I try to draw in an area of the ground plane... If I go outside that area, the UCS, or whatever is causing the problem, doesn't do it. So in other words, if I go to the far edges of my drawing limits and draw a box, it works fine.. if I try to draw it towards the center of the drawing limits, in an area where the ground plane is drawn, it acts up.. Boy am I confused on this one.

Share this post


Link to post
Share on other sites
Murphy625

Yes.. the USC is matching the ground plane for some reason when I try drawing in that area! How do I turn that off?? When I try to draw a cube, the UCS tilts it to match the ground plane. I don't know why.

The ground plane is a mesh.

Share this post


Link to post
Share on other sites
ReMark

It sounds like you have Dynamic UCS enabled. Disable it (there is a toggle for it in the Task Bar) or freeze the layer it is on.

Share this post


Link to post
Share on other sites
Murphy625

I converted the mesh to a smoothed surface (or at least I think I did), and the problem has gone away.. really weird. I will check on the dynamic UCS thing.. thanks,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×