Jump to content
VictorDigai

Degrading quality of pointcloud in Autocad 2016

Recommended Posts

VictorDigai

Hi everyone, first post.

 

Does anyone know why x-referenced point cloud can suddenly degrade in visual quality?

 

This is what happens:

I insert a huge point cloud scan into AutoCAD drawing and it looks almost perfect. When zooming point cloud regenerates and its quality is corrected. When I zoom very close I can see neat rows of points that were generated by the laser station.

After while AutoCAD regenerates the view and point cloud quality decreases significantly, huge gaps appear in the point's fabric and I cannot see neat rows of points anymore. I can barely see the picture up-close, so I have to zoom out significantly in order to see general overview.

 

So my settings for point cloud are:

POINTCLOUDDENSITY:100

POINTCLOUDCASHESIZE:32000

Maximum point cloud points per drawing 25000000

 

Does anyone has an idea how to get back to that perfect scan that I inserted in the first place? I have suspicion that AutoCAD unloads huge part of points to increase productivity, but is there any setting to restrict that?

Share this post


Link to post
Share on other sites
SLW210

Graphics card or driver (certified?) maybe, that seems like a lower end card. Ram, you may need more than 8GB.

 

What are the rest of your computer specifications? Is hardware acceleration on or off?

Share this post


Link to post
Share on other sites
VictorDigai

SWL210, thanks for the reply.

 

Hardware acceleration is on.

 

I am running on Intel Core I7 (2.80 GHz) , 8Gb RAM, GeForce GT 430 (latest driver is installed).

Share this post


Link to post
Share on other sites
tzframpton

I'm familiar with point clouds, just not with AutoCAD. What happens when you save, close and reopen?

Share this post


Link to post
Share on other sites
VictorDigai

tzframpton, nothing really changes.

 

By the way, Autodesk ReCap presents the same point cloud in very good quality, so it might be not the hardware problem but rather software restrictions.

It seems as if AutoCAD intentionally makes pointcloud less dense so it can work faster, maybe be some legacy code carried over from older releases, now that I think about that.

Plus 25000000 points limit.

 

Thank you for the reply.

Share this post


Link to post
Share on other sites
tzframpton

Hmm, so if ReCap doesn't degrade the point cloud then it's definitely an AutoCAD problem. ReCap does a very good job at handling points... I mean it's what it was built for.

 

I'm just walking out on very small branches here so please forgive me in advance. I'm just going off of my own curiosity is all. So one thing I would try is to look at a list of all the System Variables that contain POINTCLOUD. Typing this in the command line would give you a "quick list" of what's available:

*POINTCLOUD*

This way you can see if there's any variable that controls this. It would be a trial and error process.

 

The other thing that comes to mind is the Adaptive Degradation option found in the old school 3DCONFIG dialog. Since 3DCONFIG is no more, and the replacement GRAPHICSCONFIG doesn't give you an option in the dialog, you must use the command line version of the tool. Type this in the command line:

Command: -GRAPHICSCONFIG
Enter option [acceLeration/Adaptive degradation/General options/eXit] <acceLeration>: A
Enter mode [ON/OFF] <ON>: OFF

Adaptive Degradation may be the issue, but you'll just have to see. Be warned that it can be taxing on your system so maybe you cycle this on/off as needed. More info here:

https://knowledge.autodesk.com/support/autocad/learn-explore/caas/CloudHelp/cloudhelp/2016/ENU/AutoCAD-Core/files/GUID-70FA7B84-142C-4D23-9C75-CCA6C01223FC-htm.html

 

Not sure if any of this will be useful, but either way: hope this helps.

 

-TZ

Share this post


Link to post
Share on other sites
SLW210

If you don't have a certified card, AutoCAD tends to get finicky. You may need to tweak your settings manually in the 3D Performance Tuner in AutoCAD or see if Windows can optimize the Graphics Card for appearance, it usually sets it up for performance or a compromise.

 

What Operating System are you using? Maybe turn off some bells and whistles in Windows.

 

Maybe check your System Variables related to Point Clouds.

 

Start With POINTCLOUDDENSITY

 

Controls the number of points displayed at once for all point clouds in the drawing view.

 

The system variable value is a percentage of 1,500,000, which is the maximum number of points that can exist in a drawing, regardless of the number of point clouds attached to a single drawing.

 

For example, if the system variable is set to 1, a maximum of 15,000 points is displayed at one time, even if there are multiple point clouds displayed on the screen. The 15,000 points are evenly distributed between the viewable point clouds.

 

POINTCLOUDAUTOUPDATE

Controls whether a point cloud is regenerated automatically after manipulation, panning, zooming, or orbiting.

 

POINTCLOUDLOCK

Controls whether an attached point cloud can be manipulated, moved, or rotated.

 

POINTCLOUDRTDENSITY

Improves performance by degrading the number of points displayed in the drawing view zooming, panning, or orbiting in real time.

Share this post


Link to post
Share on other sites
VictorDigai

tzframpton, SLW 210, thank you very much for suggestions, guys.

 

tzframpton, I looked into your options, but unfortunately nothing changed in the quality. But your line of thought got me thinking about digging in to my graphic card settings, and also general graphic settings of Windows. I also discovered CASHEMAXFILES and CACHEMAXTOTALSIZE variables that I might need to explore more. I also got to think that I actually loading all those point clouds from separate portable hard drive provided by our partners on the project. So it might be that I need to copy over those files directly on my computer and try again, unfortunately now I don't have time, because other projects are taking over. I'll post any results as soon as I got a minute.

 

SLW 210, yep, unfortunately my graphic card is not certified, but graphic log says it is ok. So I need to explore some hardware system variables more.

 

Anyways, thank you for help guys. I will post in the future if I found solution to this problem. Or I might just need to ask my boss for a new machine =). As I heard that AutoCAD as many other Autodesk programs carry over an old philosophy of requiring max. hardware characteristics to perform top notch, so if you don't upgrade often you left behind.

Share this post


Link to post
Share on other sites
boxel0

I agree, with the other guys on this thread, if your not running an 'approved' graphics card then things do play up

 

We work with Pointcloud data full time and we require ssd and Nvidia Quadro Graphic Cards

 

p.s unfortunately recap use a different 3d graphics system to Autocad so pointcloud data is rendered alot better

Share this post


Link to post
Share on other sites
VictorDigai

 

Thank you for the input, I guess I will save some time and don't bother about this issue anymore. There is to many variable in the process that don't worth money and time. Solution is to use ReCap for beautiful stuff, AutoCAD for creating 2D section and utilitarian stuff.

Thanks for everyone's effort, guys!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×