Jump to content

Recommended Posts

rihiz

Hello there!

 

I have a fairly simple question, but it has been bugging me for a while now.

 

I know that there are many different snap settings. But for example if I take some type of snap, I drag a line near the place I want it to snap, it shows where it will snap, but if my mouse is a bit above the target ( green square for example ) , it will just draw it there instead of snapping to where it was supposed to.

 

UPDATE: Also while im at it. Is it possible to have the dynamic input in isometric grid understand that the 0 degrees is 30 degrees on the sheet? Or I have to just calculate it on the fly.

Share this post


Link to post
Share on other sites
Dana W

Your aperture and pickbox may be sized a bit too large.

 

Have you noticed that the cursor will sort of LOCK ON to the snap marker? Any further movement will break the lock. It happens pretty much right away as soon as you first come close enough to it. Also, don't click on the marker when is is dashed, only when it is solid lines.

 

Try polar tracking with vector lines displayed. At least then when the vector lines are spinning crazily around the snap marker, you know you are not locked onto the snap. See the attached images. The first one is DSETTINGS (drafting settings). The second is OPtions > Drafting tab.

 

Yes, I have a weird set of angles to track while polar tracking is active. I recommend 5 deg. at the smallest. I have to fix mine.

 

I am not sure about how dyn input works in Iso. I don't use it much, but I think polar tracking may help you with 30 deg added to the tracking angle list.

polar.jpg

aperture.jpg

Share this post


Link to post
Share on other sites
rkent

There are only two ways to ensure that the osnap either grabs onto an object or doesn't acquire a picked point. One is to not use running osnaps and instead use another method to set the osnap needed at the moment. The obvious one is to start the line command and then type END, but that is not efficient. I use F-Keys with each one assigned to an osnap, so I start the line command and hit F1 for endpoint and pick on the line. You can use keyboard overrides as well.

 

The other way is to set OSNAPOVERRIDES to 1.

Share this post


Link to post
Share on other sites
rihiz
Your aperture and pickbox may be sized a bit too large.

 

Have you noticed that the cursor will sort of LOCK ON to the snap marker? Any further movement will break the lock. It happens pretty much right away as soon as you first come close enough to it. Also, don't click on the marker when is is dashed, only when it is solid lines.

 

Try polar tracking with vector lines displayed. At least then when the vector lines are spinning crazily around the snap marker, you know you are not locked onto the snap. See the attached images. The first one is DSETTINGS (drafting settings). The second is OPtions > Drafting tab.

 

Yes, I have a weird set of angles to track while polar tracking is active. I recommend 5 deg. at the smallest. I have to fix mine.

 

I am not sure about how dyn input works in Iso. I don't use it much, but I think polar tracking may help you with 30 deg added to the tracking angle list.

 

what exactly does polar tracking do ?

Share this post


Link to post
Share on other sites
rihiz
There are only two ways to ensure that the osnap either grabs onto an object or doesn't acquire a picked point. One is to not use running osnaps and instead use another method to set the osnap needed at the moment. The obvious one is to start the line command and then type END, but that is not efficient. I use F-Keys with each one assigned to an osnap, so I start the line command and hit F1 for endpoint and pick on the line. You can use keyboard overrides as well.

 

The other way is to set OSNAPOVERRIDES to 1.

 

What will the last command do ? I feel like it will be annoying to remember each snap for the each button

Share this post


Link to post
Share on other sites
tombu

10 AutoCAD temporary override keys

Enables Snap Enforcement

Override key: Hold SHIFT + S or SHIFT + ;

This key will activate snap enforcement, changing OSNAPOVERRIDE system variable from 0 to 1.

 

You can add more if you like.

Share this post


Link to post
Share on other sites
Dana W
what exactly does polar tracking do ?
Polar tracking adds the ability to acquire snaps at discernable angles while showing you what the angle is. Typing in some (let's call them prefered) angles to the polar tracking angle table will allow the cursor to snap onto a "vector" at these angles.

 

For instance, you start a pline and pull it at an angle for a distance. Using the dynamic cursor readout, and watching your projected polar tracking vector line(if displayed) will help you find, say 45 deg. visually without having to type in your angle and distance. PT will snap mildly (the cursor only) to your vector as sort of a lock-on, then you can keep to that angle to pull to the end point of your pline,or key in a distance. There is a very mild assistance present to holding the cursor on a particular vector, but it is not nearly as strong as the lock to X and Y that ortho mode uses, probably less than 1%.

 

While drawing a line perfectly horizontal, PT will display a vector line, which you can see make an obvious snap and unsnap, if you pull the cursor off the horizontal or bring it back on. This works with any of the angles defaulted or added to the angle table in the above image I posted.

 

Displaying the polar tracking vector lines will show you which snap you have "acquired" by establishing a displayed vector line from your cursor to that snap.

 

You can change your orientation to the acquired snap and vector in, then snap in on a new location, say perpendicular to the original acquired snap even if the perpendicular point is not on the object owning the originally acquired snap.

 

As long as the PT vector line(s) are visible, you are NOT on the snap point.

 

There's more, but I can't seem to describe it easily. To me Polar tracking with vector lines is like having a third hand.

 

Polar tracking does not function at all well with Ortho mode turned on.

 

Sorry, that is not a very clear explanation. I probably should just copy and paste some stuff out of the F1 Help if I can find it. I personally find AutoCad Help as informative as reading the Wall Street journal through a pebbled glass window.

Edited by Dana W

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×