Jump to content
Jozef13

Dynamic Block with "Plan Readable" Attribute

Recommended Posts

Jozef13

Hello, Could you help me please ?

I am frustrated with creation of Dynamic Block with "Plan Readable" Attribute.

I've tried to modify existing block that is also working.

I am able to create DB with always horizontal attribute but I can not create new one with "Plan Readable" Attribute as you can see in attachment.

DB-Plan Readable Att.dwg

Share this post


Link to post
Share on other sites
iconeo

You are having trouble trying to replicate the functionality of the other block because you don't have all the pieces. Its not your fault either, I'd call it a bug, but AutoCAD doesn't have bugs right? :x

 

Go into your source block from Libbya, type in BACTIONBARMODE and toggle it to 0. You will see that there are other parts to this block that must be included.

 

Thanks.

Share this post


Link to post
Share on other sites
Jozef13
You are having trouble trying to replicate the functionality of the other block because you don't have all the pieces. Its not your fault either, I'd call it a bug, but AutoCAD doesn't have bugs right? :x

 

Go into your source block from Libbya, type in BACTIONBARMODE and toggle it to 0. You will see that there are other parts to this block that must be included.

 

Thanks.

 

:)

Thank You very much, It is clear now.

But I am not able to set Lookup range parameter to [0,90],(270,0] but only to [0,90],(270,).

I am wondering why it is possible in original block but not in my new one.

DB-Plan Readable Att-2.dwg

Share this post


Link to post
Share on other sites
iconeo

Change your degree units accuracy to 0.0000

Share this post


Link to post
Share on other sites
Jozef13
Change your degree units accuracy to 0.0000

 

Units accuracy changed but range parameter [0,90],(270,0] still not possible.

But if I checked the original block parameter, it has changed to [0,90],(270,359.9999]

If I use [0,90],(270,359.9999] in my block, it works fine as well.

Is it wrong if I use (270,) for everything greater than 270 ? In fact, greater could be only 360 if I consider degrees.

Share this post


Link to post
Share on other sites
iconeo

[0,90],(270,0] - you can't use this as an entry because you are doubling up on 'zero'. That's why Libbya used 359.9999.

Share this post


Link to post
Share on other sites
Jozef13
[0,90],(270,0] - you can't use this as an entry because you are doubling up on 'zero'. That's why Libbya used 359.9999.

 

I meant [0,90],(270,) without last zero which mean greather tahn 270 based on AutoDask Help:

(For an open-ended range, use one value with a comma, enclosed in brackets or parentheses. For example: [,5] specifies less than or equal to 5; (5,) specifies greater than 5.)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×