Jump to content
MHL

Autocad 2018 - Mouse Pan behaves differently when editing large MTEXT objects

Recommended Posts

MHL

Background: Upgraded both my computer (Was old as hell, now a much better system that is way above minimum 2D CAD requirements) and my version of AutoCAD (was 2013, is now 2018) within the last month. Still fixing things here and there to get it to act like I want, but I'm probably 95% of the way there. This new problem, however, is driving me nuts. It's also something that seems to have only started occuring within the last day or two. I could have missed it after I started using the new system/cad, but I feel I would have noticed something this annoying pretty quick.

 

Anyway, onto the problem: The middle mouse pan works just fine when using no commands, using other commands, or when editing small MTEXT objects (I.E., it moves "one to one" - clicking causes the cursor to lock to one point in the drawing, and dragging the cursor around the screen pans the entire drawing by moving said drawing based off that one point. In other words, "working as intended," so far as I'm aware and have gotten used to). When I'm editing larger MTEXT objects, however, it's not behaving as normal - it's more like the entire screen is moving 5:1, so I have to drag the mouse signifigantly farther than normal to pan the same distance.

 

At the same time, there's a large drop in the framerate of AutoCAD. This wouldn't actually bother me in the slightest (I'm used to my old system/CAD doing this same framerate drop, actually) if the pan worked correctly. I'm just bringing this up in case this somehow pins down the problem, since when I pan with other commands active or with small MTEXT objects, the framerate seems fine.

 

So...what gives? Is this a system variable or something? A quirk of new AutoCAD? Is this indicative that something's wrong with my practically new computer (I7, Geforce 1080, plenty of ram, so I really doubt this part)? If this happened when I was doing another command it might not be so bad, but since I prefer to pan when working with text (So I can track where I am in the object more easily than if I just mouse wheel zoomed in/out), it's reeeeeally frustrating. Any help would be appreciated.

Edited by rkmcswain
disable smiley so the "2018)" comes out right.

Share this post


Link to post
Share on other sites
MHL

I just went through and checked that list - I never knew about that. I've been doing this 10+ years and this is the first I've even heard of this. Apparently, my next build needs a Quadro of some variety, since that appears to be literally my only option for an Nvida card.

 

Anyway, concerning GRAPHICSCONFIG - Turning off just one 3D option fixed my mouse movement not being 1:1 as I had complained about earlier (I turned all of them off anyway, since I do entirely 2D drafting). I still have the framerate drop, but that problem doesn't drive me insane like the mouse movement problem. Plus, I can apparently live with it, as I have been for the past decade. Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×