Jump to content
wimal

Remove unreferenced files from the external reference dialog box

Recommended Posts

wimal

How can remove this unreferenced files from the external reference dialog box.

unrefer.PNG

Share this post


Link to post
Share on other sites
SLW210

Try -PURGE or WBLOCK.

Share this post


Link to post
Share on other sites
rkmcswain

There are several suggestions here.

 

You might also switch to the TREE listing of the xrefs to see if any of those are nested.

Share this post


Link to post
Share on other sites
wimal

Thanks for the both of you.

Share this post


Link to post
Share on other sites
Dana W

Select the top one, shift select the bottom one to select the rest, right click inside the selected list, click detach, wait about 3 seconds, done.

Share this post


Link to post
Share on other sites
SLW210
Select the top one, shift select the bottom one to select the rest, right click inside the selected list, click detach, wait about 3 seconds, done.

 

Have you tried that? The xrefs in the OP shows orphaned images and the detach option will be grayed out. At least it always has when I've run across them.

Share this post


Link to post
Share on other sites
Dana W
Posted (edited)
Have you tried that? The xrefs in the OP shows orphaned images and the detach option will be grayed out. At least it always has when I've run across them.
Not sure what you mean by showing orphaned images. Are you referring to "unreferenced"? I don't see anything different in the OP's list from what i see in my list. All's I know is, once I erase a bunch of attached pdf's from modelspace, I go into the XREF dialog and detach them in a group by either shift+select or ctrl+select. They go away in a bunch. Works every time. One can also do the select, punch the icon in the yellow box, click detach, and they go away too. This is in versions 2016, 2017, and 2018.

unrefer.PNG

Edited by Dana W

Share this post


Link to post
Share on other sites
SLW210

If you have never ran across the issue you wouldn't understand. Looking at the paths to the right of the screen grab, if those are paths only on someone else's computer, Detach has always been grayed out. If you will look to the left of the screen grab, you will see all of the unreferenced files were images. Have a look at rkmcswain's link, you will see this problem has been around a while.

Share this post


Link to post
Share on other sites
Dana W
If you have never ran across the issue you wouldn't understand. Looking at the paths to the right of the screen grab, if those are paths only on someone else's computer, Detach has always been grayed out. If you will look to the left of the screen grab, you will see all of the unreferenced files were images. Have a look at rkmcswain's link, you will see this problem has been around a while.
Oh, ok. That issue. That is most likely the OP's issue. Looking at that list, I couldn't really tell at first, but looking again, they don't look local at all.

 

It has been a number of years since I have had it happen to me. 1099'ing for the mouse ears, xref's were a nightmare in one particular project.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×