Jump to content
PJ01

Cannot print added text

Recommended Posts

PJ01
Posted (edited)

In the drawing attached below, there are 4 lines of text shown above the title. The last 2 lines were added recently.

When I print out the drawing from the Layout1 view, the last two lines of text ( specifying the dimensions of the sides and the base) do not appear on the printed output.

Similarly, if I export the drawing in a .pdf format, the two lines of text are also missing.

Also, the bottom two lines of text do not appear in the Print Preview.

 

I have tried double clicking on the Layout1 page, saving again, zooming, shutting down and restarting the program, to no avail.

Can anyone please advise why this might be happening, and how to overcome it?

Helena_ Notepaper Holder.dwg

Edited by PJ01

Share this post


Link to post
Share on other sites
nukecad

I can't open your drawing on this laptop to check, but the most common cause of this is that the text is on 'layer 0' which never plots.

Move it to a different layer.

 

Second most common is that the text is on another layer that has been set not to plot.

Again move it to a different layer, or turn on plotting for the layer that it is on.

 

Third most common, if this text is in model space then maybe those two added lines have 'strayed' outside the paperspace viewport?

Turn on the viewport outline in paperspace and check.

If the text is falling over the boundry then make the viewport bigger, or move the text so it is fully inside the viewport.

 

There may be another cause, but as I say I can't open the drawing on this laptop and the above are the three most common.

Share this post


Link to post
Share on other sites
Dana W

I can't open it either since I am at home, but maybe the text is color 255, the "other" white that does not change with the background.

 

And layer 0, (zero) does plot, unless it is set not to. It is DEFPOINTS that doesn't plot, nor should it be used to draw or place any objects on so they won't plot. It is a system layer that should be left alone.

Share this post


Link to post
Share on other sites
eldon

That text currently has a colour 255 and is on layer DIM.

 

Set the colour to Bylayer, unless you want it not to print.

Share this post


Link to post
Share on other sites
nukecad
And layer 0, (zero) does plot, unless it is set not to. It is DEFPOINTS that doesn't plot, nor should it be used to draw or place any objects on so they won't plot. It is a system layer that should be left alone.

Thanks for the correction, like everyone else my brain sometimes gets in front of itself.

(It was always 'good practice' never to draw anything on layer 0 and have it turned off for plotting. Of course what is 'good practice' changes over the years as AutoCAD versions change).

Share this post


Link to post
Share on other sites
Dana W
Thanks for the correction, like everyone else my brain sometimes gets in front of itself.

(It was always 'good practice' never to draw anything on layer 0 and have it turned off for plotting. Of course what is 'good practice' changes over the years as AutoCAD versions change).

:thumbsup: It's still good practice to not use it for drawing, but to inform the novices reading...

 

Creating geometry in blocks on Layer 0 is good because they will take on the properties of any other layer the block is inserted on. You can include geometry in blocks on other layers too, but those object properties will not change when inserted on other layers.

Share this post


Link to post
Share on other sites
PJ01
Posted (edited)

Thanks for your ideas and suggestions, folks, I really apprecaite them. I have changed the colour to By Layer, and still the bottom 2 lines do not print.

I have attached print screens of the various pictures which may shed some light:

1. Print Preview

2. Properties of the upper 2 lines of text

3. Properties of the lower 2 lines of text ( these were a separate multiline text addition, not an extension of the upper text)

4.The Layout1 view, showing Viewport boundary

HNH_Preview.jpg

HNH_upper text.jpg

lHNH_lowerText.jpg

HNH_Viewport.jpg

Edited by PJ01

Share this post


Link to post
Share on other sites
Cad64

As Eldon mentioned, your Mtext is set to color 255,255,255, see image below.

 

Double click on the Mtext, highlight all the text and then change it to ByLayer where I have indicated within the red box. Once you do this, your Mtext should change to red and you should see it when you plot.

Mtext.jpg

Share this post


Link to post
Share on other sites
PJ01
Posted (edited)

Many thanks for doing this, Cad64, very much appreciated. As you can see in the post immediately before yours, I had changed things from my original .dwg posted by using the Outline layer ( not the red Dim layer) and changed the Mtext by selecting the two lines of text, going into Properties and changing the Colours to By Layer. Obviously that did not work, as I still could not see the 2nd row of text. Strange!!

 

 

 

In the end I changed it in the Text Editor as you indicated, and the two lines of print appeared in Print Preview. YESS!!!!!

 

 

All this problem printing lines came about because I entered the lines of text while in the Dim layer

Edited by PJ01

Share this post


Link to post
Share on other sites
eldon

If you look at the Content section of the properties of the affected text, you can see some format statements before the actual text {\C0,\c16777215; That gives a clue that something is amiss.

Share this post


Link to post
Share on other sites
PJ01

Thanks everyone, I have learnt lots from this, although I still don't know why changing the Mtext Properties of the selected lines of text did not work.

Share this post


Link to post
Share on other sites
Cad64
Thanks everyone, I have learnt lots from this, although I still don't know why changing the Mtext Properties of the selected lines of text did not work.

 

 

It didn't work because the color property was overridden in the text editor. I know, it's a little confusing. You can set your layer color in the Layers palette, and you can override the layer color by changing the object color in the Properties palette, but then you can override the override in the text editor. :?

Share this post


Link to post
Share on other sites
PJ01

Thanks for this explanation, Cad64. I know what to do next time if it ever crops up. Text Editor is KING !!

 

 

Thanks to eldon too, for his tip about checking the Content in the Mtext Properties menu

Share this post


Link to post
Share on other sites
eldon

You could have also Exploded that Mtext. This gets rid of any embedded formatting, and the colour can be changed to Bylayer, but it is no longer Mtext.

Share this post


Link to post
Share on other sites
SLW210

You can have a look at THIS for Stripping the formatting from MTEXT.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×