Jump to content
OMEGA-ThundeR

DGN Linetype scales when regenerating drawing on different zoom-levels

Recommended Posts

OMEGA-ThundeR

Hi,

 

I can't seem to find an answer on google but perhaps i'm not defining the problem right.

 

When i regen my drawing, every linetype that has a pattern (dashed, dotted, etc) changes the scale of the linetype.

 

I have it down to it only (in my case) is on lines that come from drawings converted from microstation to Autocad (DGN to DWG). The linetypes are all some sort of 'DGN' (DGN1, DGN2, etc.).

 

Unless i use a linetype native to autocad it keeps scaling on regen. Is there some setting to keep the scale the same (relevent to linetypescale in properties) for these microstation/DGN linetypes?

 

Edit: MSltscale , LTscale , PSltscale are my preffered settings (showing the same (linetype)scale in a viewport as in modelspace).

Share this post


Link to post
Share on other sites
BIGAL

Oh yeah just convert the DGN thats what the blurb says, the only way to do it properly is to set up translation tables this linetypedgn=lintypeACAD and so on. I am not a microstation user only know from dealing with old clients that this method was the closest and produced the best result. You could though try finding every object with a line type and change it to an Autocad one. Will a simple BYlayer work ?

 

(setq ssall (ssget "x"))
(setq x 0)
(repeat (sslength ssall)
(setq obj (vlax-ename->vla-object (ssname ssall x)))
(vlax-put-property obj "Linetype" "Bylayer") ; check for dgn linetype here and have a defun than does correct change.
;(vlax-put-property obj "Lineweight" acbylayer)
(vlax-put-property obj "Color" acbylayer)
(vlax-release-object obj)
(setq x (+ x 1))
) ; end repeat

(Alert "All objects now by layer")

Share this post


Link to post
Share on other sites
tombu
Unless i use a linetype native to autocad it keeps scaling on regen. Is there some setting to keep the scale the same (relevent to linetypescale in properties) for these microstation/DGN linetypes?

 

Edit: MSltscale , LTscale , PSltscale are my preffered settings (showing the same (linetype)scale in a viewport as in modelspace).

 

From what I've read Microstation plots linetypes the same as AutoCAD does with PSltscale set to 1 where they look the same regardless of viewport scale. Setting MSltscale and PSltscale (for each layout) to their default value of 1 may fix the issue.

Share this post


Link to post
Share on other sites
OMEGA-ThundeR

In case i just need to change the linetype it's not so hard to just change them in the layer manager.

 

And the PS/MSLTscale settings don't fix it, the DGN linestyles keep re-scaling when regenerating the drawing on different zoom levels no matter what setting ( or ) i use in modelspace.

Share this post


Link to post
Share on other sites
BIGAL

With this sort of problem if you dont post a dwg then no one can have a play.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×