Jump to content
todski

viewport not to scale when printing

Recommended Posts

todski

hi 

 

im after a little bit of help on my layout i have a viewport showing a cabinet ( on the right hand side ) i have it set to a 1/1 scale but when i print its short and does not scale correctly when using a ruler to check.

 

i sure its a setting in the plot screen , i have the plot to scale box ticked so it fits on a piece of a4 - this creates a scale of 1mm = 21.02 units    

 

im stuck as how to get around this 

 

many thanks if your able to help

New furniture template.dwg

Share this post


Link to post
Share on other sites
eldon

I would hazard a guess that you are drawing in mm units, but you have started on a feet and inches drawing template.

 

It is so much easier sorting out layouts and viewports when the correct template has been used to start with. 

 

Share this post


Link to post
Share on other sites
CyberAngel

As I tell people, every plot is to a scale. For instance, 1=21.02 is a scale, it's just not a very useful scale.

 

What most people do is set the paper space to the size of their paper (hence the name). When you add a viewport, you scale it to fit onto that piece of paper, with whatever other bits you need, such as a title block. Then you print at 1:1, which simplifies the plotting process.

Share this post


Link to post
Share on other sites
todski

@eldon -  i am drawing in mm , the drawing units is set to Decimal and the insertion scale is in mm

 

                 as far as i can tell the template i started with is in Decimal 

 

@CyberAngel  i have basically done what you have said , my question is how do i make it plot with out the scale 

 

would it be because i have inserted a block for the grid that you see on the layout page 

Share this post


Link to post
Share on other sites
eldon

To get you out of your present predicament, try changing the plot scale to 1mm = 25.4 drawing units

Share this post


Link to post
Share on other sites
eldon
21 minutes ago, todski said:

@eldon -  i am drawing in mm , the drawing units is set to Decimal and the insertion scale is in mm

 

                 as far as i can tell the template i started with is in Decimal 

 

However, if you type MEASUREMENT at the command line, it returns 0, which suggests that you started with a feet and inches template which would be the cause of your difficulty.

Edited by eldon

Share this post


Link to post
Share on other sites
todski

sorry if my posts appear later they need a mod to approve them as im a newbie 

 

@eldon just tried that the border actual came in about an inch all the way around but i did do 1 mm = 20 units that worked to make the unit the correct size but the grid / block was over the edges of my paper 

198891606_Screenshot2018-09-0418_35_11.thumb.png.0c59599ce56dff98a91cde0e54dd1462.png

 

see picture attached 

Share this post


Link to post
Share on other sites
eldon

i also printed out at a scale of 1mm = 25.4 units and got a border of about one inch all the way round, and when I measured the dimensioned length of 600, I measured 24mm. This means that it is printing out on paper at a scale of 1 to 25.

What border are you expecting? What scale are you expecting on the print? Perhaps your border in model space is not quite right. I still reckon your starting template was not metric.

Share this post


Link to post
Share on other sites
ReMark

Running the -DWGUNITS command one can see that in this case the drawing units are set to inches as eldon has surmised.

Share this post


Link to post
Share on other sites
todski

i did the measurement instruction before and it came up as 0 . so eldon was right im using a template set to inchs but using mm ,

 

i will change to a new template and try again , i will be back for more help 

 

many thanks to all

Share this post


Link to post
Share on other sites
BIGAL

Providing your working in decimal inches it all should still work. As metric is a decimal system rather that 1/4 1/2 etc.

 

If your title block is drawn at 1:1 in decimal units in a layout  it should still work.

 

Something I use all the time is to turn on the viewports toolbar when working in metric its a life saver for plotting with title block at 1:1 make a viewport zoom to about what you want, a number will appear in the toolbar you can type into that box an exact scale number for us its divide 1000 = scale so If I have it zoomed to about what I want and it displays 5.234 I type 5 this is exactly 1:200 scale. 1000 / 200 = 5 move around a bit and lock viewport.

 

You have not mentioned your output sheet size so could help a bit more.

Share this post


Link to post
Share on other sites
BIGAL

Had a look at your dwg and you have a problem no matter what you do you have a title block at A2 size, the mistake you have made is that an A2 cut sheet of paper is exactly 594x420 mm there is no printer that will draw a line at that sheet size exactly on the edge.  You have not taken into account what is known as the hard clip limit, for good printers these days it about 10mm on every side for an A2 sheet.

 

To print on say an A4 sheet its down around 6mm edge so you need to make your title fit in those clip limits, this is a very common and I guess beginners mistake, so you need say -12 all sides plus say 2mm and it will work for A2, A3, A4 100% every time. ie 594-12*2-2 420-12*2-2

 

We print A1 841X594 as A3 every day set plot scale for A1 then set plotting of sheet to 1=2 for A3. A2 to say A3 is same, A4 I think is root2 1.414.....

 

Here is a freebie plot all from model space, but BIG BUT you will have to change your title block and change some of the code like your title block name, sheet size. I would also have a look at some of the plot routines by Maratovich may help also.

 

image.png.16b063fab24242dee8aacf903560d508.png

Plot-multi-titles-in-layout.lsp

Share this post


Link to post
Share on other sites
todski

thank you for all the help and pointers i have got it sorted now 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×