Jump to content
benhubel

Temporary Override Hotkeys - Delay Time

Recommended Posts

benhubel
Posted (edited)

I frequently use the "shift" temporary override hotkey to toggle Orthographic mode on/off. While I am holding shift, orthomode inverts; when I release shift, orthomode returns to the previous setting. The issue is that, every time I press shift to toggle it, I have to wait a second before it activates. This slows things down and gets rather annoying.

The issue exists with the other temporary overrides as well, although I don't particularly care what the delay is on the others. Is there any way to modify how long you have to hold the key before the override initiates? I have looked for an answer several times with no success. I am mostly convinced that it isn't controlled by a system variable. I had my computer listen to the Windows registry while I toggled some temporary overrides; there were no changes visible there.

None of these other posts that I found have received any answers other than people claiming that it simply can't be done. I am open to the option of writing a LISP or AutoHotkey program that will emulate the behavior of the orthomode temporary override by toggling the equivalent of the F8 hotkey on/off when holding/releasing shift, but if there's a simpler way or a better way, I'd rather try to focus on that first.

https://forums.autodesk.com/t5/autocad-forum/change-temp-override-delay-time/td-p/1523584
https://forums.autodesk.com/t5/autocad-forum/temporarily-override-ortho-delay/td-p/2084082
https://forums.autodesk.com/t5/autocad-forum/ortho-shift-override-delay/td-p/3673944

Edited by benhubel

Share this post


Link to post
Share on other sites
SLW210

Seems fast enough to me on AutoCAD 2018, it switches before I can even move a little when drawing a pline. I generally use Shift-X (for Polar Tracking OFF) and Ortho kicks in before I hit the X sometimes, I think that is why the delay is included.

 

Share this post


Link to post
Share on other sites
benhubel
4 hours ago, SLW210 said:

Seems fast enough to me on AutoCAD 2018, it switches before I can even move a little when drawing a pline. I generally use Shift-X (for Polar Tracking OFF) and Ortho kicks in before I hit the X sometimes, I think that is why the delay is included.

 

 

I will test it out on the current version when I get off work. I seem to remember the delay being similar, but I might be remembering wrong. I don't tend to use that version very often because it's the educational license.
I agree that having some delay is good; it's just that I am switching back and forth regularly enough to find myself wishing for a shorter delay. Finding a way to adjust the delay would also be useful to anyone who feels that the delay isn't long enough because it would allow them to extend it.

Share this post


Link to post
Share on other sites
SLW210

I never really looked for a solution....but since you asked.

 

Try

  1. In the Windows Control Panel, click Keyboard.
  2. In the Keyboard Properties dialog box, on the Speed tab, drag the Repeat Rate slider to adjust the keyboard response time. Then click OK.

 

Share this post


Link to post
Share on other sites
benhubel
On 8/7/2019 at 5:50 AM, SLW210 said:

I never really looked for a solution....but since you asked.

 

Try

  1. In the Windows Control Panel, click Keyboard.
  2. In the Keyboard Properties dialog box, on the Speed tab, drag the Repeat Rate slider to adjust the keyboard response time. Then click OK.

 


Wow, that worked. I never even thought to look into the Windows keyboard options. By the way, for anybody else who might try this, it wasn't the Repeat Rate slider; it was the Repeat Delay slider. It'll take some getting used to, as it also affects my typing while in other programs as well. I prefer it this way, though, even if I'm not used to it yet.

Thank you very much for your help, Steve!

Share this post


Link to post
Share on other sites
BIGAL

There will probably be a registry entry somewhere so if you could find could possibly reset as part of using autocad, then reset back.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...