Jump to content

AutoCAD Civils not showing enough minimum and maximum ranges


Recommended Posts

Nellie

Hi,

 

This problem keeps popping up for me, not every time but I really want to understand why the error happens.

 

I am using AutoDesk Civil's 2020 and trying to create a heatmap from data picked up on site by a GPS gas reader, the data needs to be shown in 8 ranges of set readings ranging from green to red but for the last two sets of reading CAD will only offer me 5 or 2 sets of readings instead of the 8 that I need no matter what I do.

 

Seeing as this doesn't happen every time along with the fact that its the same kit that captures the readings the error or setting issue must be in CAD, I have used different drawings but still no luck.

 

I have attached a screen shot showing CAD only offering 2 ranges instead of 8 even though I have input the maximum of 200 along with a screen shot of what the ranges should be and the data I have used.

 

Any help or advice on this would be much appreciated.

 

Cheers

 

Colours.PNG

Ranges.PNG

Amended.csv

Link to post
Share on other sites
rkmcswain

Go to the current Surface Style.

How many ranges are shown there?

 

image.png.1d620e2b47cf409a4a47062b8f6125c4.png

 

What is your elevation range? Mine is from 3' to 22' and this is the result.

 

 

 

Not sure why it auto-configured the first range from 3 to 3 ?

image.png

Link to post
Share on other sites
Nellie

Thanks for the reply rkmcswain.

 

Mine was set to 1 but even if I change it to 8 I still can get more than 2 ranges.

 

For your information I have been told told the following on another site "This is a known problem when there are no or only a few triangles at different elevations. The CSV file contains many (73 of 2341) duplicate points. And only 58 points contain an elevation greater than zero at all. Unfortunately, the points with zero height are read in first and the data with the actual heights are ignored accordingly. Your terrain model is therefore almost completely flat. Look at your DTM from the side. The available data simply do not give different elevation ranges. 

 

Interestingly you have managed to get 6 ranges.....

Link to post
Share on other sites
CyberAngel

From the advice you got elsewhere, the solution may be to weed out as many of the zero readings as you can. I can't tell how you built your surface, so I'm not sure how you would do that. If there are a lot of zero-level triangles, you can probably consolidate them. I believe there's a surface utility for that, I haven't used it much.

 

Once you have taken out the skew of the zero readings, you should be able to use vertical exaggeration to get good separation of the rest of your values (assuming you still need to).

 

Another possibility is to use a grid surface, if you don't need pinpoint accuracy for your readings. Depending on data distribution, though, that might make it worse.

  • Like 1
Link to post
Share on other sites
BIGAL

The csv file found 4 rows all identical not helping. Need delete duplicate maybe as 1st step. Sorry just found 12 rows all X Y Z same.

 

Skipped looking at it for first time now the 1st 347 rows are identical. Not helping.

 

I just tried your data and it has some odd things about it. there are 29 points each with the same X & Y in one location no wonder its not working just look at this image your data this would be vertical faced triangles not a good idea. You need to look seriously at the data its not CIV3d.

 

image.png.288c22c416ffd7222a341a98ae9864ed.png

image.png.0b67e4b7e05157c25c35677f691fde6a.png

Edited by BIGAL
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...