PDA

View Full Version : ACAD.PAT error when trying to hatch



guy martin
1st Jun 2010, 09:53 pm
Have R2006 running in windows 7 and cant hatch, and cant find a solution to fixing this problem. Whenever I try to hatch I get "unable to find acad.pat" and am unable to hatch. Anyone got a fix for this one? Like where is the .pat file lurking, and how do i get the app to see it? thanks...

ReMark
1st Jun 2010, 10:42 pm
Open Arch 2006. At the command line type (findfile"acad.pat") then press Enter. Hopefully it will tell you the "path" to the file.

Is your version of Win7 32-bit or 64-bit?

hugha
1st Jun 2010, 11:02 pm
R2006 may not install properly in Win7 but try

1. Searching your file system for ACAD.PAT - if it cannot be seen enable searching in system files and try again.

2. If found, use Tools>Options to add ACAD.PAT's directory to the Support File Path.

hth

Hugh Adamson
www.hatchkit.com.au (http://www.hatchkit.com.au)

ReMark
1st Jun 2010, 11:09 pm
Acad.pat would not show up in a search of system files but it might show up if you tell Explorer to search for "known" file types.

hugha
2nd Jun 2010, 01:49 am
Sorry to be misleading - wrong OpSys. To search a Win7 computer for ACAD.PAT (edited Win7 help):

To expand a search beyond a specific library or folder



If you can't find what you're looking for in a specific library or folder, you can expand the search to include different locations.
Type ACAD.PAT in the search box.
Scroll to the bottom of the list of search results. Under Search again in, do one of the following:
Click Libraries to search across every library.
Click Computer to search across your entire computer. This is the way to search for files that aren't indexed (such as system or program files). However, be aware that the search will be slower.
Click Custom to search specific locations.
Click Internet to search online, using your default web browser and your default search provider.You could search for *.PAT instead.

Hugh Adamson
www.hatchkit.com.au (http://www.hatchkit.com.au)

guy martin
2nd Jun 2010, 05:21 am
ok... ive found where the hatch definitions are, and when i try to add it to the support path, i get to the folder where it resides and it isnt viewable to click on and add to complete the path.

guy

hugha
2nd Jun 2010, 09:01 am
The folder may be hidden. Again, from Win7 help:

Show hidden files

Here's how to display hidden files and folders.

Click to open Folder Options.

Click the View tab.

Under Advanced settings, click Show hidden files, folders, and drives, and then click OK.

Take the opportunity to turn on file extension display as well.

But this may be indicative of wider problems installing 2006 on W7. Depending on the W7 version and your boxspecs you may have the ability to run a virtual XP to run R2006 in if needs be.

Good luck.

ReMark
2nd Jun 2010, 10:55 am
Could you please answer my question re: Win7? Is it a 32-bit or 64-bit version? Thank you.

guy martin
10th Jun 2010, 12:59 am
sorry missed that, it is the 64 bit from what i can tell..

ReMark
10th Jun 2010, 11:10 am
Let's backtrack a moment.

Acad 2006 is loaded on your computer. The program does open. The only problem is, for some strange reason, Acad cannot locate the acad.pat file. That's it in a nutshell right?

And on your own you have managed to locate the file correct?

hugha
10th Jun 2010, 02:22 pm
Try running as Administrator as detailed here:

http://www.tomshardware.com/forum/2820-63-compatibility-autocad-2006-windows


hth
Hugh Adamson
www.hatchkit.com.au (http://www.hatchkit.com.au)

guy martin
10th Jun 2010, 05:27 pm
Yes.. It Was Hidden And I Now Have It In Support, But Still No Joy.... Opened .pat In Notebook And It Is All There But Still Nothing Doing On Hatching, The Same Is True For Linetypes As Well, Can Get A Few Basic Ones, (ie, Cont, Dasshed, Hidden) But As For Rest Nothing.