Jump to content
benji

Copying Attributes

Recommended Posts

benji

Can any one tell me how to copy a block with attributes?!

 

If i use the simple copy command AutoCAD seems to change the block i copied it from if i edit any properties of it.

 

I hope you understand what i am talking about!?

Share this post


Link to post
Share on other sites
ReMark

Your copied block would probably have to be redefined in order for it to not be changed by AutoCAD when you edit the properties of the original. Attributes would probably have to be redefined as well.

Share this post


Link to post
Share on other sites
benji

so corect me if i am wrong but every time i have to set up a new attdef?

 

i will explain my secnario:

 

i have a desk block

 

i am useing attdef so the block has atributes, i.e name, phone number and department the desk is related to

 

every time i copy the desk with the attributes as a whole block. i cannot change the phone number (for example) without it changing the attributes of the desk i copyed it from!

Share this post


Link to post
Share on other sites
dbroada

are you sure you are changing attribute values, not tags or text?

 

If you have created your block correctly you should be able to copy it many times or insert it many times. Double clicking any one of those blocks should (might - depends on your set-up) give you the edit attribute values box for that one instance only.

Share this post


Link to post
Share on other sites
ReMark

Dave is correct. Sorry, I misunderstood your question. There should be no need to redefine the block. I thought you were changing the attributes themselves and not their values. Whole different story.

Share this post


Link to post
Share on other sites
benji

mmm thanks guys

 

i dont think i understand this subject enough, i should read into it more.

Share this post


Link to post
Share on other sites
ReMark

So, we are ALL confused? Well, I feel better already. For a moment I thought it was only me.

Share this post


Link to post
Share on other sites
AlinOz

I think I may have the answer as to why this doesn't make sense. I think Benji may be putting the wrong info in. This may be something to do with the Prompt and Default and/or the use of the Constant Mode.

Benji, to explain -

The Tag field is the 'name' used when extracting the attributes (typically something like Item_No)

The Prompt field is what the AutoCAD will ask back to the User (Typically "Enter the Item No for this item")

The Default Field is the actual Data that you enter (Say XXX-000 for a dummy Item No).

Now, if you were to set this as Constant, you can't change it at the drawing level as it will always be XXX-000. In this case you will need to be able to change it for each Item, so leave the Constant option unchecked so it can vary.

But, the Attribute for the Type of Item (i.e. Desk) would be a constant (unless you wanted to name it 'desk' here and 'low desk' somewhere else). Check the Constant box in this case

 

Is that what we're talking about? Does that help?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...