Jump to content
Kremer

2010 MEP Piping & The Flatshot Command

Recommended Posts

Kremer

Hey there,

 

Recently our company upgraded to '10 MEP, and we're using the piping tool to eventually go to a full 3d environment. Unfortunetly sometimes we have to FLATSHOT our 3D to show it to clients who either don't have ACAD or whose computers cannot handle 3D processing.

 

My problem is the 3D piping, while 3D does not appear in the flatshot command. Is there a way to explode it and turn it into a solid? Or perhaps a way to have FLATSHOT pick up the 3D piping?

 

I'd much prefer the latter though at this point I'll take anything.

 

Many thanks in advance.

Share this post


Link to post
Share on other sites
ReMark

Why not change the orientation of the 3D piping that you are looking at and use the JPGOUT command to create an image? Most everyone should be able to view a jpg file.

Share this post


Link to post
Share on other sites
tzframpton
Hey there,

 

Recently our company upgraded to '10 MEP, and we're using the piping tool to eventually go to a full 3d environment. Unfortunetly sometimes we have to FLATSHOT our 3D to show it to clients who either don't have ACAD or whose computers cannot handle 3D processing.

 

My problem is the 3D piping, while 3D does not appear in the flatshot command. Is there a way to explode it and turn it into a solid? Or perhaps a way to have FLATSHOT pick up the 3D piping?

 

I'd much prefer the latter though at this point I'll take anything.

 

Many thanks in advance.

AEC Objects created from AutoCAD MEP cannot be used. Only Solids can be used using the FLATSHOT command.

 

When you're using the FLATSHOT command, are you in some type of Isometric View? If you're in Plan View, then don't use FLATSHOT, use the EXPORTTOAUTOCAD tool (either at the command line or through the File menu). In plan view, this knocks all the AEC Objects down to simple AutoCAD entities.

 

However, if you ARE in an Isometric View (or any type of 3DORBIT view other than Plan) and you must use the CONVERTTO3DSOLIDS command and select the objects you want to make into Solids, or select the entire drawing. This will convert all the AEC Objects to a Solid, which WILL NOT be editable anymore as an MEP cataloged part, pipe, duct, etc etc (in other words, make a backup before you do this or UNDO the changes once you've exported).

 

Example:

[font=Courier New]Command: ConvertTo3dSolids [b]<Enter>[/b]
Select AEC objects to convert: [b]Specify opposite corner: 3 found[/b]
Erase selected objects? [Yes/No] <No>: [b]Y[/b]
Added 3 solid(s) to the drawing.[/font]

Share this post


Link to post
Share on other sites
Kremer

Wow thank you so much Styk! Incredible post filled with commands that could've made my day easier time and time again.

 

As well ReMark, I generally avoid jpg's (preferring .png) but that is a great command that, like you said, makes sharing files with autocad limitless as .jpgs are just about universal now.

Share this post


Link to post
Share on other sites
tzframpton

Glad to have helped.

Share this post


Link to post
Share on other sites
BrownKeithA

On a brand new install of Autocad MEP 2010 when using this command, the new 3d geometry dissapears. It says that it is added to the drawing but I cannot see it anywhere. I use the select all command and it will count the objects but they show up no where. Any ideas?? Any help would be appreciated, i need to send these drawings out real soon.

Share this post


Link to post
Share on other sites
tzframpton
On a brand new install of Autocad MEP 2010 when using this command, the new 3d geometry dissapears. It says that it is added to the drawing but I cannot see it anywhere. I use the select all command and it will count the objects but they show up no where. Any ideas?? Any help would be appreciated, i need to send these drawings out real soon.

either your Cut Plane is set or you're not in the right Display Representation.

Share this post


Link to post
Share on other sites
BrownKeithA
either your Cut Plane is set or you're not in the right Display Representation.

 

This is the first thing that entered my mind also but unfortunately, acad entities are not controlled by the display system. You cannot control a 3d solid by changing the display options. Just in case, i drew a 3d solid and it displayed fine. In addition, I have moved my cut plane several times and that too seems to be working correctly. I am not sure that the cut plane will effect a 3d solid anyway. I am sure that there is a parameter not set correctly somewhere. It is odd though because I have gone to 3 different machines and have gotten the same result. Before we moved to new computers and reinstalled Autocad MEP, everything was working as expected. We were even using the same templates.

Share this post


Link to post
Share on other sites
ReMark

Has AutoCAD MEP 2010 Update 1 been loaded?

Share this post


Link to post
Share on other sites
tzframpton

hmmm, weird. I'm at a loss right now, one of those things I would need the file itself to play around with it for an answer. Have you tried asking over at the AUGI boards? Might get some better help over there.

Share this post


Link to post
Share on other sites
BrownKeithA

both MEP update 1 and the content extension have been installed. I am not sure if that was the case on the previous computers.

Share this post


Link to post
Share on other sites
BrownKeithA

I havent asked on the augi boards yet, i have asked on the official forums in a thread about convertto3dsolids. Martin Schmid has been involved in the thread. He works on the development team for autodesk and is also a co-author of the new Autocad MEP book that is out. Which I would highly recomment picking up.

Share this post


Link to post
Share on other sites
tzframpton
Which I would highly recomment picking up.

Already got mine in. :wink:

Share this post


Link to post
Share on other sites
ReMark

Do you have one computer still running the "old" setup that hasn't been converted over? I was thinking maybe a printout of all variable settings could be obtained and checked against one of the new setups.

Share this post


Link to post
Share on other sites
BrownKeithA

Found out some more information. I downloaded a file that contains some mvparts converted to 3dsolids and pasted my piping into that drawing. I then used the convertto3dsolids command and the resulting solid showed up just fine. Again, this leads me to believe that there is a drawing specific setting somewhere that is not correct.

Share this post


Link to post
Share on other sites
BrownKeithA

Thought that I would add that I think that it is in the display system configuration somehow. I took a drawing that the command worked in and copied over all of the display configurations. Now when I try to convert some pipe it dissapears as before. When i track down the culprit, I will be sure to let you all know.

 

p.s. Doesnt make sense to me but looks like you were right StykFacE

Share this post


Link to post
Share on other sites
BrownKeithA

Problem Solved.

 

I copied over what I posted on the official forums. Let me add that we draw our plumbing piping using the piping workspace in order to draw it in 3D.

 

 

 

ok problem solved sort of....... The issue is not with the display configuration but with the system definitions. Specifically, with the "display pipe and inline/anchored components as graphical 1-line". For plumbing systems I have this set to 20". This is mainly because when we print out our plumbing drawings, we want all plumbing to print single line regardless of pipe size. We were using the same display configuration for our hydronic piping which we use 2" as our single line / double line threshold. Apparently I am going to have to setup a display configuration for plumbing and a display configuration for piping and set the plumbing pipe to single line in our print display configuration.

I hope this makes sense. In the meantime, does anyone know if there is a system variable that if the piping is displayed as 2 line that the convertTo3dsolids command will convert it to a viewable 3d solid regardless of the graphical 1-line settings?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...