Jump to content
nicolas

Rotating View via UCS and PLAN - Angle Problem

Recommended Posts

nicolas

Hi,

 

 

I have leaned that there are 3 even 4 ways to rotate a view.

 

For example, the view rotates with the viewport when viewrotateassoc is set to 1. The same is true using the align then rotate option of mvsetup.

 

However there is a problem with the third method namely rotating the ucs and then applying PLAN command. I want to rotate the view 45 degree (by default it is 45 degree CCW). Hence I rotate the ucs 45 degree at the z-axis. However when PLAN is applied, the view has rotate -45 degree or 45 degree CW. Is there any reason for this or am I missing something?

 

Regards,

 

Nicolas MARIE.

 

 

Regards, Nicolas

Share this post


Link to post
Share on other sites
CyberAngel

Think of it this way. You have your plan on a round table. There's a pole in the center in the table (the z axis). If you pick up the table by the pole and turn it counter-clockwise, the plan rotates. From your point of view, the plan has turned counter-clockwise. From the plan's point of view, however, you have turned clockwise.

 

Okay, it's a bug. This is my preferred method of rotating a view, and I've never understood why UCS turns the opposite way when you use Z rotate.

Share this post


Link to post
Share on other sites
BIGAL

Also Units settings clockwise or counter clockwise for angles hence -45 may swing it the correct way. I normally draw a line UCS OB so dont need to worry about angle.

 

forgot Units and Radians 45 gives interesting answer.

Share this post


Link to post
Share on other sites
bjenk8100

hmm i thought it just rotated based on a 360 deg circle. if i want to rotate 45 deg clockwise i will rotate 315 deg.

 

also, rotating ucs - this works for me - whichever direction (x,y,z) that you do not want to change pick that rotate option. for isntance, say the x-axis is in the right direction but you want the z or y to change choose rotate around x and it will eventually have the correct orientation.

Share this post


Link to post
Share on other sites
irneb

I can't reproduce this bug. Or maybe I'm just used to it and can't see the tree for the forest?

 

As I understand it you always use the right-hand rule: place your right-hand making a fist with your thumb pointing in the positive direction of the axis about which you're rotating. The rest of your fingers point in the direction of rotation - if you want the other way round use negative angles. Then the plan command will always place the X axis at the bottom from left to right, Y on the left from bottom to top, and Z pointing directly at you.

Share this post


Link to post
Share on other sites
gutter2d

AutoCAD should copy Microstation and allow you to easy rotate the view by just clicking two points. Rotating the view in Autocad takes forever because it's all trial and error, unless you want north to be facing up.

Share this post


Link to post
Share on other sites
RobDraw

It's all relative. If you rotate the UCS 45, the UCS is now 45 degrees from where it was before in relation to the plan. Thus the plan is -45 in relation to the UCS.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...