Jump to content
DrWho

"Check web for live enablers" does nothing

Recommended Posts

DrWho

I have the same problem as willwould at http://www.cadtutor.net/forum/showthread.php?7526-ACAD_PROXY_ENTITY : "Check web for live enablers" is enabled in Options > System, but it does nothing. PROXYSHOW was initially set to 0, so I set it to 1. No change.

 

(Before I changed PROXYSHOW, when I opened a drawing that announced it needed object enablers, the Proxy Information dialog had "Do not show proxy graphics" selected, and the other 2 Proxy Graphics selections were grayed out. Now, the other 2 options are still grayed out, but "Do not show proxy graphics" is not selected. Whether I select it or not, nothing happens.)

 

I am running AutoCAD 2010. A previous version of AutoCAD behaved the same way.

 

How do I get "Check web for live enablers" to actually work? Trying to do it manually is NOT user friendly (as willwould observed), and drawings that "want" object enablers usually need 2 dozen of them.

Share this post


Link to post
Share on other sites
nestly

I can't provide any specific help, as I've always thought it better not to have stuff installed on my computers without my knowledge, but as I recall, scrolling the dialog box that pops up when loading a drawing with AEC objects tells you exactly which enablers are needed, and there really aren't that many for each product anyway.

 

Object Enablers download page

 

As for why it's not working as expected, perhaps insufficient administrator rights, or a firewall blocking the traffic, or browser security settings (ie disabled JavaScript/ActiveX)?

Share this post


Link to post
Share on other sites
DrWho

Thanks for replying, Nestly.

 

Yes, the dialog does list the enablers needed -- literally, about 20 of them. I would list them except the dialog does not allow printing or copying the text. :x The last time I tried to download some manually (a few months ago), I found the same thing Will did: the names of the enablers required do not match the names of the enablers offered. :x Also, precisely because so many are required, I really don't want to spend a lot of time trying to manually locate and install them. This just begs for automatic installation.

 

The weird thing is, it appears that there is absolutely no attempt at automatic download and installation. I would expect that the first thing to happen after closing the Proxy Information dialog would be that another dialog would pop up saying "Now searching for object enablers", or "The following is preventing a search"... but no.

 

Does anybody know of an error log that might offer a clue as to why no search even begins?

Share this post


Link to post
Share on other sites
nestly

I can't help with the automatic downloading, but installing the Object Enabler isn't as daunting as it may seem.

 

There may be a lot of individual "applications" listed, but they're probably all contained within a single Object Enabler download. Don't worry about the "Application name" just download the Object Enabler that matches the "Product Description"

 

Here's an example from my 2011, but your 2008 should look very similar.

 

ObjectEnablers.jpg

Share this post


Link to post
Share on other sites
DrWho

Thanks again, Nestly.

 

I'm guessing "AutoCAD Architecture and MEP" is the right enabler, which I will download as soon as my IT department unblocks the site. :whistle:

 

"Guessing" because most of the apps don't list a "Product Desc" at all, and the descriptions that ARE listed are variations of AutoCAD Mechanical, which is not a selection under AutoCAD Electrical 2010 (which is what we upgraded to).

 

Crossing my fingers. Thanks again.

Share this post


Link to post
Share on other sites
nestly

One word of caution before you install them. You don't actually need Object Enablers to show the special objects created in the verticals like ACA, MEP, or C3D, those objects will usually display just fine as Proxy Graphics. You only need the OE's if you need to edit or manipulate those objects in your drawing. If you do edit them, I don't believe they'll retain their special properties if the drawing is re-opened in the vertical product it was originally created in.

 

Once installed, OE's are loaded every time you open AutoCAD whether you need them or not. This will add a few seconds to your AutoCAD startup time. If you find you don't need/want the OE's anymore, you can uninstall them from the Control Panel.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...