Jump to content
Yagoona

PDF export is chopping off part of viewport

Recommended Posts

Yagoona

I got a problem with exporting to PDF.

The resulting PDF is cut off on the right and top of the plan.

Funny thing is that when I print it out directly, it is fine.

Can anyone help me with this problem?

I have attached the .dwg and the resulting .pdf and also a plot.log (had to change the extention to .txt for the uploader) file that was created at the time of PDF export

Barramundi BBQ - wall hanger (1123)[20111104810]v01.pdf

Barramundi BBQ - wall hanger (1123)[20111104810]v01.dwg

plot.txt

Share this post


Link to post
Share on other sites
resullins

Are you exporting to PDF or PRINTING to PDF? If you're exporting, try printing. Set yourself up a plot style with PDF as the printer, import it, and then check your viewport. You look like you're outside the printable area, but since you're exporting, you don't know it.

Share this post


Link to post
Share on other sites
Dana W

The printable bounds for the pdf.pc3 iso A4 exp is 198.4 x 275.4 mm Your layout viewport is 201.22 x 286.68. You will have to reduce by a few mm's to get it to fit in the pdf document.

 

Your plotter probably has a bit larger printable area for the hardcopy plot without going through the pdf driver. I don't have your plotter, so I cannot see what size the printable area in yours is.

Share this post


Link to post
Share on other sites
Dana W
Are you exporting to PDF or PRINTING to PDF? If you're exporting, try printing. Set yourself up a plot style with PDF as the printer, import it, and then check your viewport. You look like you're outside the printable area, but since you're exporting, you don't know it.

 

Is there actually an option to export to pdf? I can't find one. Is that something that LT does not have?

 

I assumed a certain level of OP newbie-ness and translated "export" as the generic term for creating a file rather than a hard copy, and "Print it directly" translated to printing the layout to the OP's plotter.pc3 for a hard copy.

 

After a bit of experience, as you know, a plot that looks like that one tells us that it is a printable area problem just about 100% of the time.

Share this post


Link to post
Share on other sites
resullins

You can export to PDF. It's a function of the PDF program, though, not usually CAD itself. I hate PDF. It's a necessary evil, I realize.

Share this post


Link to post
Share on other sites
Dana W
You can export to PDF. It's a function of the PDF program, though, not usually CAD itself. I hate PDF. It's a necessary evil, I realize.

 

Thanks, I figgered that may be it, but I think, just guessing, the OP was trying to use the plot to pdf.

 

I usually use AutoDesk TrueView to make my pdf's. Mainly cuz Acad 2009 pdf's are horrible, stinkin, and nasty. I just set them up in AutoCAD with the DWG to PDF.pc3, close it, open it in TrueView and plot it.

Share this post


Link to post
Share on other sites
pendean

LT what? Like AutoCAD, LT is not static, new versions add new features: if yours does have it, it's an older version.

So which are you using?

Share this post


Link to post
Share on other sites
Dana W

LT what? Are you askin' me? It's right there under my Pit Bull's cute little butt,:lol: there on the left next to the word Using: What's "it" an Export function for pdf doc's?

 

;)Use a reference quote or a user id, posts get in the middle and contin.. uh.. ah.. um.. conta.. :roll: clarity vaporizes.

 

Static or not, most of us only have one version and stick with that one for a couple or three years. See today's threads about recent 2012 installs.

Share this post


Link to post
Share on other sites
Yagoona
The printable bounds for the pdf.pc3 iso A4 exp is 198.4 x 275.4 mm Your layout viewport is 201.22 x 286.68. You will have to reduce by a few mm's to get it to fit in the pdf document.
Hi Dana W I have been diverted from the issue to other things for a while and just came back to it now. Your quote above seems to be nailing it on the head, but I don't know where to set this. Can you tell me where this setting can be found please?

BTW my plotter is simply a Cannon combo scanner/printer (model MG6150)

Edited by Yagoona
forgot to add printer details

Share this post


Link to post
Share on other sites
Dana W
Hi Dana W I have been diverted from the issue to other things for a while and just came back to it now. Your quote above seems to be nailing it on the head, but I don't know where to set this. Can you tell me where this setting can be found please?

BTW my plotter is simply a Cannon combo scanner/printer (model MG6150)

 

The simplest solution is just select your viewport and drag your viewport corner grips until they are inside the system generated dashed line on your page layout. It doesn't have to be by much. Make sure your border lines and title blocks are also inside the dashed lines.

 

I couldn't tell you what is in your plotter.

Share this post


Link to post
Share on other sites
Yagoona

Oh, well I can say that this is not the problem. I had assumed that the dotted line in the layout was the extent of the printable page. My title block and border are, as you suggest just a touch with these dotted lines.

The thing is that if I plot directly to the printer, its fine, it is the PDF generation that is cutting off the page.

I guess from your earlier post, you cannot see this since you do not have this function built into CAD as I have. (I have AutoCAD 2011)

Share this post


Link to post
Share on other sites
Dana W
Oh, well I can say that this is not the problem. I had assumed that the dotted line in the layout was the extent of the printable page. My title block and border are, as you suggest just a touch with these dotted lines.

The thing is that if I plot directly to the printer, its fine, it is the PDF generation that is cutting off the page.

I guess from your earlier post, you cannot see this since you do not have this function built into CAD as I have. (I have AutoCAD 2011)

It may not be the Export function, but the driver settings.

 

I am still not quite sure whether you are using the Export To Pdf function or simply plotting to pdf via the Dwg To Pdf.pc3 file. In either case, I think the Dwg To Pdf.pc3 config file comes into play.

 

Try this, go to the layout tab > Right click > Page Setup Manager > Modify.

 

At Printer/Plotter make sure the Dwg to pdf.pc3 is selected and click the Properties button next to it.

The Plotter Calibration Editor dialog box will come up. Click the Device and Document Settings tab.

expand the User Defined Paper Sizes & Calibration tree if it is not already.

Click on Modify Standard Paper Sizes (Printable Area)

A scroll window will pop in below. Scroll to your paper size and click it so it is highlighted.

Then click the Modify button. Change the printable area size.

 

Change it JUST ENOUGH to fit your drawing into it. I gave you the dimensions you will have to exceed in an earlier post. 201.22 x 286.68 is what I measured your drawing border at. I'd try and make the printable area at least .05 larger than your border both horiz. and vert. Then click all the OK buttons.

 

There is a warning on the dialog that states some printer/plotter/driver combinations may not be able to deal with the changes made here. You might find the maximum printable area alowed by your plotter in the operators manual. Hopefully it will work for you.

Share this post


Link to post
Share on other sites
Yagoona

I sovled it for me Yippeeeeee!

Thanks a lot

I only got to the part where I selected the Dwg to pdf.pc3 as the plotter.

I had this set to my printer and was simply hitting the output > PDF button on the ribbon.

So it seems it was using the printer setting to create a PDF which was not working.

So after doing this, the dotted line of the layout changed to reflect the outline of the PDF creation. When I readjusted my plot to fit into this, it all worked.:notworthy:

Since I am almost never printing directly to printer but rather creating PDFs for the laser cutter to go along with the raw DXF that is imported into the CNC machine, it is the PDF that I want to look good, not the paper print. They will then print off a copy for themselves.

Again thanks for your immense patience with this problem of mine and for your deep insight that finally solved this problem for me.

Share this post


Link to post
Share on other sites
Dana W

Glad to see you got it solved.

 

Yup, it's always best to use the page layout manager to get stuff to the plotter. It can be set up the right way, and it will remember the details for the next time when all you have to do is make the layout current, right click the layout tab, select Plot... , and Bob's yer Uncle.

 

Future hint. Be careful to use specific terminology when posting. The generic use of the "Export" term kinda got us off on a tangent, but we're there now so.....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...