Jump to content

UNITS command and dimension


19cruthik68
 Share

Recommended Posts

If I type the command UNITS and change the insertion scale to millimeter (mine was inches), what is going to happen? At first i used inches to draw 5 inches line and the get the dimension of it, second i drew again a line using the millimeter in units, but when i measured it still it is exact to the first line that i draw. can anyone explain to me the use of this. thanks

Link to comment
Share on other sites

Don't the words "insertion scale" provide any clue? That is in reference to units to scale inserted content and does not refer to lines you are drawing.

 

Did you use the wrong template (metric instead of imperial or vice-versa)?

 

Stick with one or the other don't try to combine the two or you'll just cause yourself all kinds of grief. If you are comfortable working in metric units but the client wants to see imperial units then address the problem using the Alternate Units feature of your Dimension Style.

 

If you've progressed too far to turn back then you'll have to resort to scaling the drawing up or down depending on what units you started working with.

Edited by ReMark
Link to comment
Share on other sites

if you are not going to insert any other object like blocks, you can change your units anytime you like and it wont affect the drawing how it will measure because basically object are drawn as 1:1... if you have drawn a line at 5 using inches, it will still be 5 even if you change to meters when you apply dimension....

 

however, if you are going to insert a block(without changing the scale) or attach exref dwgs drawn in different units, it will either appear smaller or bigger. Remark is correct. avoid using or shall i say changing units in drawing obejcts in one drawing. ;)

Link to comment
Share on other sites

ok, thanks for the answer. but why is that everytime i will open a new drawing, the units is always inches, i want to use millimeter everytime im gonna open a drawing (new drawings or a drawinga need to amend). what is the solution so that every drawings that i will open the units will be automatically in millimeters. thanks

Link to comment
Share on other sites

You should look to use a dedicated template - in a new drawing set the environment that you need in each drawing (layers, linetypes, styles, even layouts), set the units and save it as DWT; then when start a new drawing use this one.

Link to comment
Share on other sites

From what I saw, the template setup/usage seems to not be covered in most AutoCAD courses. I have described briefly the procedure in my previous post; for a detailed one may follow this tutorial.

Link to comment
Share on other sites

Open your OPTIONS > FILES > TEMPLATE > then take a look at the attached image. What you are trying to do here, is determine which of the zillion different available templates is correct for your work. There are all different kinds. But the one thing that you really want to pay attention to, is whether the template is METRIC or IMPERIAL. If you want to work in METRIC then you can choose an ISO template, or any of the others which specifically say METRIC. In this way when you look at your scale lists, they will not be IMPERIAL (feet and inches) based. Once you have figured out the one you think is a good fit you can set that template by browsing through the template directory as shown, and specifying it as your QNEW template. If you ever want to use a different template you can access this template directory by selecting FILE > NEW and choose to open another one, or set a different one as your QNEW default. MSASU is absolutely right, you should create a drawing on this template including layer names, and settings, dimension styles, text styles, drawing sheet and block, and just about anything else that is frequently used in your work. In this way you can save this drawing (check it first) as a .DWT file, which means turn it into a template. Then you can reset this saved template as your new QNEW default, and then you can just go straight to work whenever you start a new drawing. I draw in mms, and so set my insertion and target drawing settings in USER PREFERENCES as unitless & unitless. I have tons of different templates, both for job and task specific needs. It is as simple as saving an existing .DWG as a .DWT file. This will save you tons of time, and make your work much more accurate. Another way to accomplish much of this would be through the use of .DWS (STANDARD files). They are also very simple to create, save any existing drawing as a .DWS file. I hope this helps. :)

Set your default template.jpg

Link to comment
Share on other sites

Here's another way (if your concern is the UNITS only)....

-Open a new dwg file

-In the Drawing Units Dialog box under insertion Scale, choose millimeter then hit OK

-Save as Autocad Drawing Template.

-Choose acad and Save.

A warning prompt will tell you that it is already existing. Just click Yes to overide the file.

-Exit Autocad

When you open AutoCAD, check the UNITS, you will see its already in millimeters.

This is just some kind of an ambush approach concerning changing units but I prefer you follow Dadgad's if you want to consider other details for setting up your own standard or the company you are working... ;)

Link to comment
Share on other sites

Here's another way (if your concern is the UNITS only)....

 

-Open a new dwg file

-In the Drawing Units Dialog box under insertion Scale, choose millimeter then hit OK

-Save as Autocad Drawing Template.

-Choose acad and Save.

A warning prompt will tell you that it is already existing. Just click Yes to overide the file.

-Exit Autocad

 

When you open AutoCAD, check the UNITS, you will see its already in millimeters.

 

This is just some kind of an ambush approach concerning changing units but I prefer you follow Dadgad's if you want to consider other details for setting up your own standard or the company you are working... ;)

 

 

 

 

 

Alternatively ensure you are using ACADISO.DWT as your starting template rather than ACAD.DWT as this will use the metric linetypes too.
Link to comment
Share on other sites

It makes me nuts when I am working on a drawing which was created on an Imperial template, because all of the scale references and lists show default Imperial units of measure, even if the UNITS are set correctly. If you check in OPTIONS > USER PREFERENCES > DEFAULT SCALE LISTS it is very easy to determine what sort of template was used. That of course is much more difficult than just referencing any of the scale lists, which will display architectural scales. As a carpenter trained in the states, I am fine doing woodwork with Imperial measurements, I just don't want to have to use them and think that hard, unless I need to in Autocad. :thumbsup:

imperial template display.JPG

Link to comment
Share on other sites

  • 3 weeks later...

Hi there's another way also, type STARTUP command and change the value from 0 to 1 and save.so that eveytime you open a new drawing, the startup dialog box will appear and you can choose your drawing whether imperial or metric....hope it can help...

 

regards,

sotelliza

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...